summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-03-17 08:57:17 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-03-17 08:57:17 +0000
commit97aa34bff7108ce42722ef26a7890c43a86c4db5 (patch)
treecc6f4c1ca1c63099b1bb30affe863bbfe95b6921 /app-crypt
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-97aa34bff7108ce42722ef26a7890c43a86c4db5.tar.gz
gentoo-2-97aa34bff7108ce42722ef26a7890c43a86c4db5.tar.bz2
gentoo-2-97aa34bff7108ce42722ef26a7890c43a86c4db5.zip
Add seahorse-2.24.1 from gnome overlay (p.masked, gnome-session-2.24)
(Portage version: 2.2_rc25/cvs/Linux i686)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/ChangeLog10
-rw-r--r--app-crypt/seahorse/seahorse-2.24.1.ebuild59
2 files changed, 67 insertions, 2 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index 3c47e2fdace3..31da8778c520 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/seahorse
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.112 2008/11/13 19:30:50 ranger Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.113 2009/03/17 08:57:17 nirbheek Exp $
+
+*seahorse-2.24.1 (17 Mar 2009)
+
+ 17 Mar 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +seahorse-2.24.1.ebuild:
+ Add seahorse-2.24.1 from gnome overlay (p.masked, gnome-session-2.24)
13 Nov 2008; Brent Baude <ranger@gentoo.org> seahorse-2.22.3.ebuild:
Marking seahorse-2.22.3 ppc64 stable for bug 236971
diff --git a/app-crypt/seahorse/seahorse-2.24.1.ebuild b/app-crypt/seahorse/seahorse-2.24.1.ebuild
new file mode 100644
index 000000000000..4e696a38b083
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-2.24.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.24.1.ebuild,v 1.1 2009/03/17 08:57:17 nirbheek Exp $
+
+EAPI="1"
+
+inherit eutils gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi debug ldap libnotify"
+
+RDEPEND=">=gnome-base/libglade-2.0
+ >=gnome-base/gconf-2.0
+ >=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.10
+ net-libs/libsoup:2.4
+ || (
+ =app-crypt/gnupg-1.4*
+ =app-crypt/gnupg-2.0* )
+ >=app-crypt/gpgme-1.0.0
+ net-misc/openssh
+ avahi? ( >=net-dns/avahi-0.6 )
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.23.6
+ ldap? ( net-nds/openldap )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ x11-misc/shared-mime-info"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-pgp
+ --enable-ssh
+ --enable-pkcs11
+ --disable-scrollkeeper
+ --disable-update-mime-database
+ --enable-hkp
+ $(use_enable avahi sharing)
+ $(use_enable debug)
+ $(use_enable ldap)
+ $(use_enable libnotify)"
+}
+
+pkg_postinst() {
+ einfo "The seahorse-agent tool has been moved to app-crypt/seahorse-plugins"
+ einfo "Use that if you want seahorse to manage your terminal SSH keys"
+}