summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-06 18:03:04 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-06 18:03:04 +0000
commit88ab90e9a58a4c6f650f4780d6cb7c528c468710 (patch)
tree1021a40bc09558a802f665a9c7da0c6d7b6e03f8 /app-crypt
parentAdded IUSE=debug, which was dropped when \'inherit debug\' was removed from x... (diff)
downloadgentoo-2-88ab90e9a58a4c6f650f4780d6cb7c528c468710.tar.gz
gentoo-2-88ab90e9a58a4c6f650f4780d6cb7c528c468710.tar.bz2
gentoo-2-88ab90e9a58a4c6f650f4780d6cb7c528c468710.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/trousers/ChangeLog9
-rw-r--r--app-crypt/trousers/files/digest-trousers-0.2.83
-rw-r--r--app-crypt/trousers/trousers-0.2.8.ebuild83
3 files changed, 93 insertions, 2 deletions
diff --git a/app-crypt/trousers/ChangeLog b/app-crypt/trousers/ChangeLog
index ae77865c5e21..71df1e654993 100644
--- a/app-crypt/trousers/ChangeLog
+++ b/app-crypt/trousers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/trousers
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.11 2006/05/06 23:34:41 dragonheart Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/ChangeLog,v 1.12 2007/01/06 18:03:04 alonbl Exp $
+
+*trousers-0.2.8 (06 Jan 2007)
+
+ 06 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> +trousers-0.2.8.ebuild:
+ Version bump
*trousers-0.2.6 (06 May 2006)
diff --git a/app-crypt/trousers/files/digest-trousers-0.2.8 b/app-crypt/trousers/files/digest-trousers-0.2.8
new file mode 100644
index 000000000000..43250b50265b
--- /dev/null
+++ b/app-crypt/trousers/files/digest-trousers-0.2.8
@@ -0,0 +1,3 @@
+MD5 33033166b443abca82e64e24fce4d2ca trousers-0.2.8.tar.gz 1437590
+RMD160 4589958463104e3cabe839556c2d4c535b0918a6 trousers-0.2.8.tar.gz 1437590
+SHA256 87ec23d3cdf7cf8cd1cb54004323aa0503e1ae63c5a8be2679d2cd4dc1c5c3bf trousers-0.2.8.tar.gz 1437590
diff --git a/app-crypt/trousers/trousers-0.2.8.ebuild b/app-crypt/trousers/trousers-0.2.8.ebuild
new file mode 100644
index 000000000000..6aed336d5ca6
--- /dev/null
+++ b/app-crypt/trousers/trousers-0.2.8.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/trousers/trousers-0.2.8.ebuild,v 1.1 2007/01/06 18:03:04 alonbl Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils linux-info autotools
+
+DESCRIPTION="An open-source TCG Software Stack (TSS) v1.1 implementation"
+HOMEPAGE="http://trousers.sf.net"
+SRC_URI="mirror://sourceforge/trousers/${P}.tar.gz"
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND="virtual/libc
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=dev-libs/openssl-0.9.7"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ # Check for driver (not sure it can be an rdep, because ot depends on the
+ # version of virtual/linux-sources... Is that supported by portage?)
+ linux-info_pkg_setup
+ local tpm_kernel_version tpm_kernel_present tpm_module
+ kernel_is ge 2 6 12 && tpm_kernel_version="yes"
+ linux_chkconfig_present TCG_TPM && tpm_kernel_present="yes"
+ has_version app-crypt/tpm-module && tpm_module="yes"
+ has_version app-crypt/tpm-emulator && tpm_module="yes"
+ if [ -n "${tpm_kernel_present}" ] ; then
+ einfo "Good, you seem to have in-kernel TPM support."
+ elif [ -n "${tpm_module}" ] ; then
+ einfo "Good, you seem to have TPM support with the external module."
+ if [ -n "${tpm_kernel_version}" ] ; then
+ einfo
+ einfo "Note that since you have a >=2.6.12 kernel, you could use"
+ einfo "the in-kernel driver instead (CONFIG_TCG_TPM)."
+ fi
+ elif [ -n "${tpm_kernel_version}" ] ; then
+ eerror
+ eerror "To use this package, you will have to activate TPM support"
+ eerror "in your kernel configuration. That's at least CONFIG_TCG_TPM,"
+ eerror "plus probably a chip specific driver (like CONFIG_TCG_ATMEL)."
+ eerror
+ else
+ eerror
+ eerror "To use this package, you should install a TPM driver."
+ eerror "You can have the following options:"
+ eerror " - install app-crypt/tpm-module"
+ eerror " - install app-crypt/tpm-emulator"
+ eerror " - switch to a >=2.6.12 kernel and compile the kernel module"
+ eerror
+ fi
+
+ # New user/group for the daemon
+ enewgroup tss
+ enewuser tss -1 -1 /var/lib/tpm tss
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/dist"
+ epatch "${FILESDIR}/${PN}-0.2.3-nouseradd.patch"
+ cd "${S}"
+ eautoreconf
+}
+
+src_install() {
+ keepdir /var/lib/tpm
+ make "DESTDIR=${D}" install || die
+ dodoc AUTHORS ChangeLog NICETOHAVES README TODO
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*
+ fi
+ newinitd "${FILESDIR}/tcsd.initd" tcsd
+ newconfd "${FILESDIR}/tcsd.confd" tcsd
+}