summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-16 22:25:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-16 22:25:51 +0000
commit833e344422426e53eb243b841008c99b674296c2 (patch)
treef9d162f03ffeb45c9602e02469ac2f65482e5fce /app-crypt
parentmarked x86 per bug 412147 (diff)
downloadgentoo-2-833e344422426e53eb243b841008c99b674296c2.tar.gz
gentoo-2-833e344422426e53eb243b841008c99b674296c2.tar.bz2
gentoo-2-833e344422426e53eb243b841008c99b674296c2.zip
Bump to a new version and add zsh completion.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/sgeps/ChangeLog9
-rw-r--r--app-crypt/sgeps/sgeps-0_pre15.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-crypt/sgeps/ChangeLog b/app-crypt/sgeps/ChangeLog
index 8f7e6aa5b62f..0ddad4c070b2 100644
--- a/app-crypt/sgeps/ChangeLog
+++ b/app-crypt/sgeps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/sgeps
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/sgeps/ChangeLog,v 1.2 2010/07/22 20:36:10 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/sgeps/ChangeLog,v 1.3 2012/04/16 22:25:51 flameeyes Exp $
+
+*sgeps-0_pre15 (16 Apr 2012)
+
+ 16 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org> +sgeps-0_pre15.ebuild:
+ Bump to a new version and add zsh completion.
*sgeps-0_pre12 (22 Jul 2010)
diff --git a/app-crypt/sgeps/sgeps-0_pre15.ebuild b/app-crypt/sgeps/sgeps-0_pre15.ebuild
new file mode 100644
index 000000000000..94604ff0ae0c
--- /dev/null
+++ b/app-crypt/sgeps/sgeps-0_pre15.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/sgeps/sgeps-0_pre15.ebuild,v 1.1 2012/04/16 22:25:51 flameeyes Exp $
+
+EAPI=4
+
+DESCRIPTION="simple GnuPG-encrypted password store written in perl"
+HOMEPAGE="http://roland.entierement.nu/blog/2010/01/22/simple-gnupg-encrypted-password-store.html"
+SRC_URI="http://dev.gentoo.org/~flameeyes/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="zsh-completion"
+
+RDEPEND="app-crypt/gnupg
+ dev-lang/perl
+ virtual/perl-Storable
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ dev-perl/Config-Simple
+ zsh-completion? ( app-shells/zsh )"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ dobin sgeps pwsafe2sgeps
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins zsh-completion _sgeps
+ fi
+}
+
+pkg_postinst() {
+ elog "To make use of sgeps, remember to create a configuration file as"
+ elog " ~/.config/sgeps.conf with these values:"
+ elog ""
+ elog "store = ~/somewhere/safe"
+ elog "keyid = 012345678"
+ elog ""
+ elog "If you want to use the --copy options you should install x11-misc/xclip"
+}