summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2004-04-24 18:21:57 +0000
committerGuy Martin <gmsoft@gentoo.org>2004-04-24 18:21:57 +0000
commit7e0503e9cdadffbdbc2190cf1198689430695e23 (patch)
treec7fc209fd3f7d0d7a8ceb226ba93093fff3ddb90 /app-crypt
parentInitial ebuild by Robin Johnson <robbat2@gentoo.org> (Manifest recommit) (diff)
downloadgentoo-2-7e0503e9cdadffbdbc2190cf1198689430695e23.tar.gz
gentoo-2-7e0503e9cdadffbdbc2190cf1198689430695e23.tar.bz2
gentoo-2-7e0503e9cdadffbdbc2190cf1198689430695e23.zip
Added a alignement patch for hppa. Fix check on some systems.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog6
-rw-r--r--app-crypt/gnupg/files/gnupg-1.2.4-hppa_unaligned_constant.patch39
-rw-r--r--app-crypt/gnupg/gnupg-1.2.4.ebuild8
3 files changed, 51 insertions, 2 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index a045c7cb5cb0..25fa26ea1e82 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.55 2004/03/29 22:48:49 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.56 2004/04/24 18:21:57 gmsoft Exp $
+
+ 24 Apr 2004; Guy Martin <gmsoft@gentoo.org> gnupg-1.2.4.ebuild,
+ files/gnupg-1.2.4-hppa_unaligned_constant.patch:
+ Added a alignement patch for hppa. Fix check on some systems.
30 Mar 2004; Lars Weiler <pylon@gentoo.org> gnupg-1.2.4.ebuild:
stable on ppc
diff --git a/app-crypt/gnupg/files/gnupg-1.2.4-hppa_unaligned_constant.patch b/app-crypt/gnupg/files/gnupg-1.2.4-hppa_unaligned_constant.patch
new file mode 100644
index 000000000000..ffb9b7e3175c
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-1.2.4-hppa_unaligned_constant.patch
@@ -0,0 +1,39 @@
+#!/bin/sh -e
+## 10_hppa_unaligned_constant.dpatch
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Description: Fix unaligned constant in HPPA MPI assembly (#228456)
+## DP: Author: LaMont Jones <lamont@debian.org>
+## DP: Upstream status: Committed for 1.2.5
+## DP: Date: 2004-01-20
+
+if [ $# -lt 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
+
+case "$1" in
+ -patch) patch $patch_opts -p1 < $0;;
+ -unpatch) patch $patch_opts -p1 -R < $0;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+diff -urNad /home/james/debian/packages/gnupg/gnupg-1.2.4/mpi/hppa1.1/udiv-qrnnd.S gnupg-1.2.4/mpi/hppa1.1/udiv-qrnnd.S
+--- /home/james/debian/packages/gnupg/gnupg-1.2.4/mpi/hppa1.1/udiv-qrnnd.S 2002-06-29 15:14:05.000000000 +0100
++++ gnupg-1.2.4/mpi/hppa1.1/udiv-qrnnd.S 2004-02-20 16:03:54.000000000 +0000
+@@ -39,6 +39,7 @@
+ */
+
+ .code
++ .align 8
+ .label L$0000
+ .word 0x43f00000
+ .word 0x0
diff --git a/app-crypt/gnupg/gnupg-1.2.4.ebuild b/app-crypt/gnupg/gnupg-1.2.4.ebuild
index 2096908687dc..2a1f8309261b 100644
--- a/app-crypt/gnupg/gnupg-1.2.4.ebuild
+++ b/app-crypt/gnupg/gnupg-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.4.ebuild,v 1.14 2004/03/29 22:48:49 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.4.ebuild,v 1.15 2004/04/24 18:21:57 gmsoft Exp $
inherit eutils flag-o-matic
@@ -46,6 +46,12 @@ fi
src_unpack() {
unpack ${A}
+ if use hppa
+ then
+ cd ${S}
+ epatch ${FILESDIR}/gnupg-1.2.4-hppa_unaligned_constant.patch
+ fi
+
# Please read http://www.gnupg.org/why-not-idea.html
if use idea; then
mv ${WORKDIR}/idea.c ${S}/cipher/idea.c || ewarn "failed to insert IDEA module"