summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-06-21 09:17:55 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-06-21 09:17:55 +0000
commit76fdbbf74f551c516711a9ecc420858a5cceec06 (patch)
tree3461fb87e106d79999db68f9ad103db98f4856ae /app-crypt
parentbestcrypt-1.6_p1-r1 masked for initial testing (diff)
downloadgentoo-2-76fdbbf74f551c516711a9ecc420858a5cceec06.tar.gz
gentoo-2-76fdbbf74f551c516711a9ecc420858a5cceec06.tar.bz2
gentoo-2-76fdbbf74f551c516711a9ecc420858a5cceec06.zip
Test fix for serpent asm compile problems thanks to author
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/bestcrypt/ChangeLog9
-rw-r--r--app-crypt/bestcrypt/Manifest12
-rw-r--r--app-crypt/bestcrypt/bestcrypt-1.6_p1-r1.ebuild108
-rw-r--r--app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p1-r13
4 files changed, 121 insertions, 11 deletions
diff --git a/app-crypt/bestcrypt/ChangeLog b/app-crypt/bestcrypt/ChangeLog
index f9c6583460ce..333756f7a70c 100644
--- a/app-crypt/bestcrypt/ChangeLog
+++ b/app-crypt/bestcrypt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/bestcrypt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.32 2005/06/20 13:37:37 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.33 2005/06/21 09:17:55 dragonheart Exp $
+
+*bestcrypt-1.6_p1-r1 (21 Jun 2005)
+
+ 21 Jun 2005; Daniel Black <dragonheart@gentoo.org>
+ +bestcrypt-1.6_p1-r1.ebuild:
+ Test fix for serpent asm compile problems thanks to author: Michael
+ Østergaard Pedersen
20 Jun 2005; Daniel Black <dragonheart@gentoo.org>
bestcrypt-1.6_p1.ebuild:
diff --git a/app-crypt/bestcrypt/Manifest b/app-crypt/bestcrypt/Manifest
index 01a20dee8f27..a19e17cf9d1d 100644
--- a/app-crypt/bestcrypt/Manifest
+++ b/app-crypt/bestcrypt/Manifest
@@ -1,7 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 eec320cf91d99b6553b3f974fef81855 ChangeLog 6411
+MD5 b168fb7b2a8ae7b18c8501c5ccc7552e bestcrypt-1.6_p1-r1.ebuild 3027
MD5 68121ad348d78c8efdebce17ab7bbb81 bestcrypt-1.5_p10.ebuild 2942
MD5 566cf4f89e44670d0aba4a745913d748 metadata.xml 224
MD5 c2c1f3279f95f65b86cf226f84bace9b bestcrypt-1.6_p1.ebuild 3285
@@ -11,10 +9,4 @@ MD5 dee6aa8c71224187da9fbc2b2a6fc167 files/digest-bestcrypt-1.6_p1 136
MD5 c9fdd7c76eb3731a6166cc9ff17bf722 files/digest-bestcrypt-1.5_p10 137
MD5 e9585e8f08138f46bdda7b88ddd81cd8 files/bestcrypt-1.5_p10-makefile_fix.patch 1136
MD5 01225cc87eee84cf54232c86b04e8c93 files/bestcrypt.devfs 1673
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCtsa5mdTrptrqvGERAtZqAKCbMbD7g9nDf04AyTNDhsEj0YNXKACeOpAb
-NV7ggbr6w45Oo9mZvS1snJ0=
-=RS7q
------END PGP SIGNATURE-----
+MD5 6a91a7867c21eaa1be5ac4b829ae34d9 files/digest-bestcrypt-1.6_p1-r1 207
diff --git a/app-crypt/bestcrypt/bestcrypt-1.6_p1-r1.ebuild b/app-crypt/bestcrypt/bestcrypt-1.6_p1-r1.ebuild
new file mode 100644
index 000000000000..88ea30787e11
--- /dev/null
+++ b/app-crypt/bestcrypt/bestcrypt-1.6_p1-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/bestcrypt-1.6_p1-r1.ebuild,v 1.1 2005/06/21 09:17:55 dragonheart Exp $
+
+inherit flag-o-matic eutils linux-mod toolchain-funcs
+
+MY_PN="bcrypt"
+DESCRIPTION="commercially licensed transparent filesystem encryption"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BestCrypt-${PV/_p/-}.tar.gz
+ mirror://gentoo/bcrypt-rc6-serpent-c.diff.gz
+ http://www.carceri.dk/files/bcrypt-rc6-serpent.diff.gz"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/linux-sources"
+
+S=${WORKDIR}/bcrypt
+
+#get-version
+MODULE_NAMES="bc(block:${S}/mod)
+ bc_des(block:${S}/mod/des)
+ bc_3des(block:${S}/mod/3des)
+ bc_bf128(block:${S}/mod/bf128)
+ bc_bf448(block:${S}/mod/bf448)
+ bc_blowfish(block:${S}/mod/blowfish)
+ bc_cast(block:${S}/mod/cast)
+ bc_gost(block:${S}/mod/gost)
+ bc_idea(block:${S}/mod/idea)
+ bc_rijn(block:${S}/mod/rijn)
+ bc_twofish(block:${S}/mod/twofish)
+ bc_serpent(block:${S}/mod/serpent)
+ bc_rc6(block:${S}/mod/rc6)"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-makefile_fix.patch
+
+ if use x86;
+ then
+ epatch bcrypt-rc6-serpent.diff
+ else
+ epatch bcrypt-rc6-serpent-c.diff
+ fi
+}
+
+src_compile() {
+ filter-flags -fforce-addr
+
+ emake -C kgsha EXTRA_CXXFLAGS="${CXXFLAGS} -fPIC" || die "library compile failed"
+ emake -C src EXTRA_CFLAGS="${CFLAGS} -I../kgsha256" || die "bctool compile failed"
+
+ # Don't put stack protection in the kernel - it just is bad
+ append-flags -fno-stack-protector-all -fno-stack-protector
+
+ emake -C mod SYMSRC=bc_dev${KV_MAJOR}${KV_MINOR}.c bc_dev.ver EXTRA_CFLAGS="${CFLAGS}" \
+ || die "compile failed"
+
+ emake -C mod OBJS="bc_dev${KV_MAJOR}${KV_MINOR}.o bc_mgr.o" \
+ KERNEL_DIR=${KV_DIR} KEXT=${KV_OBJ} CC=$(tc-getCC) LD=$(tc-getLD) \
+ AS=$(tc-getAS) CPP=$(tc-getCXX) EXTRA_CFLAGS="${CFLAGS}" || die "compile failed"
+ einfo "Modules compiled"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ cd ${S}
+ dodir /etc
+ cp etc/bc.conf ${D}/etc/bc.conf
+
+ dobin bin/bctool
+ insinto /usr/bin
+ for link in bcumount bcformat bcfsck bcnew bcpasswd bcinfo \
+ bclink bcunlink bcmake_hidden bcreencrypt;
+ do
+ dosym bctool /usr/bin/${link}
+ done
+
+
+ doman man/bctool.8
+ newinitd ${FILESDIR}/bcrypt3 bcrypt
+ dodoc README LICENSE HIDDEN_PART
+
+ insinto /etc/devfs.d
+ doins ${FILESDIR}/bestcrypt.devfs
+}
+
+
+pkg_postinst() {
+
+ einfo "If you are using the serpent or rc6 encryption modules and have any problems,"
+ einfo "please submit bugs to http://bugs.gentoo.org because these modules are not part"
+ einfo "of the standard distribution of BestCrypt for Linux released by Jetico."
+ einfo "For more information on these additional modules:"
+ einfo "visit http://www.carceri.dk/index.php?redirect=other_bestcrypt"
+
+ einfo
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+
+ if [ -e "${ROOT}/dev/.devfsd" ]; then
+ killall -HUP devfsd
+ fi
+}
diff --git a/app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p1-r1 b/app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p1-r1
new file mode 100644
index 000000000000..da72c6b6638d
--- /dev/null
+++ b/app-crypt/bestcrypt/files/digest-bestcrypt-1.6_p1-r1
@@ -0,0 +1,3 @@
+MD5 966088b98018c477438d908ad763056c BestCrypt-1.6-1.tar.gz 194566
+MD5 d68956f4c2ed795c68a451a451de27bb bcrypt-rc6-serpent-c.diff.gz 6034
+MD5 aa6e1f0e9ee797b409267bdba1f6534e bcrypt-rc6-serpent.diff.gz 5718