summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-07 14:17:56 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-07 14:17:56 +0000
commit6b182e008024af7a86fd3560c4efbba6030a85f1 (patch)
tree874e29bcf23fbd184a96543dba3a151a6cd5b84e /app-crypt
parentAllow compiling against kernel 2.6.10, fixes bug #76979. (Manifest recommit) (diff)
downloadgentoo-2-6b182e008024af7a86fd3560c4efbba6030a85f1.tar.gz
gentoo-2-6b182e008024af7a86fd3560c4efbba6030a85f1.tar.bz2
gentoo-2-6b182e008024af7a86fd3560c4efbba6030a85f1.zip
Backport as per bug #76992
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpg-agent/ChangeLog7
-rw-r--r--app-crypt/gpg-agent/Manifest12
-rw-r--r--app-crypt/gpg-agent/files/digest-gpg-agent-1.9.101
-rw-r--r--app-crypt/gpg-agent/gpg-agent-1.9.10.ebuild86
4 files changed, 95 insertions, 11 deletions
diff --git a/app-crypt/gpg-agent/ChangeLog b/app-crypt/gpg-agent/ChangeLog
index b8c6be678dc4..ad61a463fc5f 100644
--- a/app-crypt/gpg-agent/ChangeLog
+++ b/app-crypt/gpg-agent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gpg-agent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/ChangeLog,v 1.3 2005/01/07 11:03:55 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/ChangeLog,v 1.4 2005/01/07 14:17:56 dragonheart Exp $
+
+*gpg-agent-1.9.10 (07 Jan 2005)
+
+ 07 Jan 2005; Daniel Black <dragonheart@gentoo.org> +gpg-agent-1.9.10.ebuild:
+ Backport as per bug #76992 by Dirk Heinrichs <ext-dirk.heinrichs@nokia.com>
07 Jan 2005; Daniel Black <dragonheart@gentoo.org> gpg-agent-1.9.14.ebuild:
removed version dependancies for gnupg as per bug #76994. Thanks to Dirk
diff --git a/app-crypt/gpg-agent/Manifest b/app-crypt/gpg-agent/Manifest
index a06f949134f3..627b2e0b010d 100644
--- a/app-crypt/gpg-agent/Manifest
+++ b/app-crypt/gpg-agent/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 d462f4ea30d9bfb373719d04d499140b gpg-agent-1.9.14.ebuild 2133
MD5 559d6370b1181e38b1c32d56d1b218a2 ChangeLog 832
MD5 b1a4c3f100342f9335a6974737f5e5ec metadata.xml 872
+MD5 97ee6e859605007d57693eb0fe82868a gpg-agent-1.9.10.ebuild 2132
MD5 337c9671ff169f922ba7d007a3ceaae6 files/digest-gpg-agent-1.9.14 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFB3myimdTrptrqvGERAu0qAJ97CtFfLAvYpPM+JPFCYAScV9AmdwCfStFc
-cKpMEwvQ55IPfCbHVTd2p48=
-=o5bs
------END PGP SIGNATURE-----
+MD5 8c88d9fdef69bdda173170c5a8abd59e files/digest-gpg-agent-1.9.10 65
diff --git a/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.10 b/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.10
new file mode 100644
index 000000000000..922e315523c5
--- /dev/null
+++ b/app-crypt/gpg-agent/files/digest-gpg-agent-1.9.10
@@ -0,0 +1 @@
+MD5 d923cfe0921898fbeb66374a0e32ddc6 gnupg-1.9.10.tar.gz 1385472
diff --git a/app-crypt/gpg-agent/gpg-agent-1.9.10.ebuild b/app-crypt/gpg-agent/gpg-agent-1.9.10.ebuild
new file mode 100644
index 000000000000..13f6594e4131
--- /dev/null
+++ b/app-crypt/gpg-agent/gpg-agent-1.9.10.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-agent/gpg-agent-1.9.10.ebuild,v 1.1 2005/01/07 14:17:56 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+# gpg-agent is took from gnupg package.
+GPG_P=gnupg-${PV}
+S=${WORKDIR}/${GPG_P}
+
+DESCRIPTION="The GNU Privacy Guard Agent"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/${GPG_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+# ~arm ~ia64 ~mips ~s390 ~sparce missing until libassuan gets the keywords
+# ~alpha missing for dev-libs/libksba-0.9.7
+
+IUSE="nls caps threads"
+
+RDEPEND="app-crypt/gnupg
+ nls? ( sys-devel/gettext )
+ virtual/libc
+ >=dev-libs/libassuan-0.6.9
+ caps? ( sys-libs/libcap )
+ >=dev-libs/libgpg-error-0.7
+ >=dev-libs/libgcrypt-1.1.94
+ >=dev-libs/libksba-0.9.7
+ threads? ( dev-libs/pth )"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ sed -e 's:GNUPG_LIBEXECDIR:"/usr/lib/gnupg":' -i ${S}/g10/keyserver.c
+}
+
+src_compile() {
+
+ append-ldflags -Wl,-z,now
+ econf \
+ --libexecdir=/usr/lib \
+ --enable-agent-only \
+ `use_with caps capabilities` \
+ `use_enable threads` \
+ || die
+
+ emake || die
+}
+
+src_test() {
+ einfo "self test is broken"
+}
+
+src_install() {
+ cd ${S}
+ emake DESTDIR=${D} libexecdir="/usr/lib/gnupg" install || die
+
+ # keep the documentation in /usr/share/doc/...
+ rm -rf "${D}/usr/share/gnupg/FAQ" "${D}/usr/share/gnupg/faq.html"
+
+ dodoc README
+
+ if ! use caps ; then
+ fperms u+s /usr/bin/gpg-agent
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn "** WARNING ** WARNING ** WARNING ** WARNING ** WARNING ** WARNING **"
+ ewarn " THIS IS _ALPHA_ CODE, IT MAY NOT WORK CORRECTLY OR AT ALL. THERE"
+ ewarn " MAY BE UNDISCOVERED SECURITY OR DATA-LOSS ISSUES, DO NOT USE "
+ ewarn " IN A PRODUCTION ENVIRONMENT."
+
+ if ! use caps; then
+ einfo "gpg is installed suid root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ fi
+ echo
+}