summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-03-26 23:41:47 +0000
committerBen de Groot <yngwin@gentoo.org>2010-03-26 23:41:47 +0000
commit48f1593a14eab4e9fc88201ef9a4b3d168e79cd6 (patch)
treea58275948227f287e9ce34dccf8fa63084cf1124 /app-crypt
parentUse qt4-r2.eclass (bug #311481). Tighten formatting. (diff)
downloadgentoo-2-48f1593a14eab4e9fc88201ef9a4b3d168e79cd6.tar.gz
gentoo-2-48f1593a14eab4e9fc88201ef9a4b3d168e79cd6.tar.bz2
gentoo-2-48f1593a14eab4e9fc88201ef9a4b3d168e79cd6.zip
Use qt4-r2.eclass (bug #311481). Tighten formatting.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca-gnupg/ChangeLog8
-rw-r--r--app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild20
2 files changed, 14 insertions, 14 deletions
diff --git a/app-crypt/qca-gnupg/ChangeLog b/app-crypt/qca-gnupg/ChangeLog
index d5f8f2796555..aca52e583b65 100644
--- a/app-crypt/qca-gnupg/ChangeLog
+++ b/app-crypt/qca-gnupg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/qca-gnupg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/ChangeLog,v 1.21 2009/12/29 18:12:34 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/ChangeLog,v 1.22 2010/03/26 23:41:47 yngwin Exp $
+
+ 26 Mar 2010; Ben de Groot <yngwin@gentoo.org>
+ qca-gnupg-2.0.0_beta3.ebuild:
+ Use qt4-r2.eclass (bug #311481). Tighten formatting.
29 Dec 2009; Raúl Porcel <armin76@gentoo.org>
qca-gnupg-2.0.0_beta3.ebuild:
diff --git a/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild b/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
index 08ccb6cca644..3a7b464b1ec5 100644
--- a/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
+++ b/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild,v 1.10 2009/12/29 18:12:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-gnupg/qca-gnupg-2.0.0_beta3.ebuild,v 1.11 2010/03/26 23:41:47 yngwin Exp $
EAPI="2"
-
-inherit eutils qt4
+inherit eutils qt4-r2
MY_P="${P/_/-}"
QCA_VER="${PV%.*}"
@@ -23,19 +22,16 @@ DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]
RDEPEND="${DEPEND}
app-crypt/gnupg"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_configure() {
# cannot use econf because of non-standard configure script
- ./configure \
- --qtdir=/usr \
- $(use debug && echo "--debug" || echo "--release") \
- --no-separate-debug-info \
- || die "configure failed"
+ ./configure --qtdir=/usr --no-separate-debug-info \
+ $(use debug && echo "--debug" || echo "--release") || die
- eqmake4 ${PN}.pro
+ eqmake4
}
src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ emake INSTALL_ROOT="${D}" install || die
}