summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-03-17 09:41:58 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-03-17 09:41:58 +0000
commit471be41f2852c51baf678e980fb4a69f252be3a2 (patch)
treec5d5302bf4620bf81ce646eeb0744e36dfaa668e /app-crypt
parentVersion bump (diff)
downloadgentoo-2-471be41f2852c51baf678e980fb4a69f252be3a2.tar.gz
gentoo-2-471be41f2852c51baf678e980fb4a69f252be3a2.tar.bz2
gentoo-2-471be41f2852c51baf678e980fb4a69f252be3a2.zip
Add new ebuild app-crypt/seahorse-plugins-2.24.1 from the gnome overlay (p.masked, gnome-session-2.24)
(Portage version: 2.2_rc25/cvs/Linux i686)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse-plugins/ChangeLog10
-rw-r--r--app-crypt/seahorse-plugins/files/70-seahorse-agent8
-rw-r--r--app-crypt/seahorse-plugins/metadata.xml15
-rw-r--r--app-crypt/seahorse-plugins/seahorse-plugins-2.24.1.ebuild70
4 files changed, 103 insertions, 0 deletions
diff --git a/app-crypt/seahorse-plugins/ChangeLog b/app-crypt/seahorse-plugins/ChangeLog
new file mode 100644
index 000000000000..57251b6b46b1
--- /dev/null
+++ b/app-crypt/seahorse-plugins/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/seahorse-plugins
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/ChangeLog,v 1.1 2009/03/17 09:41:58 nirbheek Exp $
+
+*seahorse-plugins-2.24.1 (17 Mar 2009)
+
+ 17 Mar 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +files/70-seahorse-agent, +metadata.xml, +seahorse-plugins-2.24.1.ebuild:
+ Add new ebuild app-crypt/seahorse-plugins-2.24.1 from the gnome overlay
+
diff --git a/app-crypt/seahorse-plugins/files/70-seahorse-agent b/app-crypt/seahorse-plugins/files/70-seahorse-agent
new file mode 100644
index 000000000000..492878e0ebf1
--- /dev/null
+++ b/app-crypt/seahorse-plugins/files/70-seahorse-agent
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+# launches a seahorse-agent instance
+
+seahorseagent=`which seahorse-agent 2> /dev/null`
+if [ -n "$seahorseagent" ] && [ -x "$seahorseagent" ] && [ -z "$GPG_AGENT_INFO" ] ; then
+ command="$seahorseagent --execute $command"
+fi
diff --git a/app-crypt/seahorse-plugins/metadata.xml b/app-crypt/seahorse-plugins/metadata.xml
new file mode 100644
index 000000000000..e77af104f1ce
--- /dev/null
+++ b/app-crypt/seahorse-plugins/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="applet">Enable seahorse applet for
+ <pkg>gnome-base/gnome-panel</pkg></flag>
+ <flag name="epiphany">Enable text encryption plugin to integrate into the
+ <pkg>www-client/epiphany</pkg> context menu</flag>
+ <flag name="gedit">Enable text encryption plugin to integrate into
+ <pkg>app-editors/gedit</pkg></flag>
+ <flag name="nautilus">Enable file encryption plugin to integrate into the
+ <pkg>gnome-base/nautilus</pkg> context menu</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-crypt/seahorse-plugins/seahorse-plugins-2.24.1.ebuild b/app-crypt/seahorse-plugins/seahorse-plugins-2.24.1.ebuild
new file mode 100644
index 000000000000..24ad61bd935e
--- /dev/null
+++ b/app-crypt/seahorse-plugins/seahorse-plugins-2.24.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse-plugins/seahorse-plugins-2.24.1.ebuild,v 1.1 2009/03/17 09:41:58 nirbheek Exp $
+
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="applet debug epiphany gedit libnotify nautilus test xulrunner"
+
+RDEPEND="
+ >=gnome-base/libglade-2.0
+ >=gnome-base/gconf-2.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.16
+ || (
+ =app-crypt/gnupg-1.4*
+ =app-crypt/gnupg-2.0* )
+ >=app-crypt/gpgme-1.0.0
+ nautilus? ( >=gnome-base/nautilus-2.12 )
+ >=gnome-base/gnome-keyring-2.23.6
+ >=dev-libs/dbus-glib-0.72
+ epiphany? (
+ >=www-client/epiphany-2.22
+ xulrunner? ( =net-libs/xulrunner-1.8* )
+ !xulrunner? ( =www-client/mozilla-firefox-2* )
+ >=dev-libs/libxml2-2.6.0 )
+ gedit? ( >=app-editors/gedit-2.16 )
+ applet? ( >=gnome-base/gnome-panel-2.10 )
+ >=app-crypt/seahorse-2.23.92
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ >=gnome-extra/evolution-data-server-1.8"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35"
+
+pkg_setup() {
+ if use epiphany ; then
+ if use xulrunner ; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+ fi
+
+ G2CONF="${G2CONF}
+ --enable-agent
+ --disable-update-mime-database
+ $(use_enable applet)
+ $(use_enable debug)
+ $(use_enable epiphany)
+ $(use_enable gedit)
+ $(use_enable libnotify)
+ $(use_enable nautilus)
+ $(use_enable test tests)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/70-seahorse-agent" || die "doexe failed"
+}