summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-11-10 09:18:30 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-11-10 09:18:30 +0000
commit4397ab368e1c2dd36fde615c28aa9107f53f6683 (patch)
treec7c32d0268bb0529233c9f9cd1450f50ed5f2f4f /app-crypt
parentTouch post install message.. (diff)
downloadgentoo-2-4397ab368e1c2dd36fde615c28aa9107f53f6683.tar.gz
gentoo-2-4397ab368e1c2dd36fde615c28aa9107f53f6683.tar.bz2
gentoo-2-4397ab368e1c2dd36fde615c28aa9107f53f6683.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/bcwipe/ChangeLog8
-rw-r--r--app-crypt/bcwipe/bcwipe-1.6_p8.ebuild48
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.6_p8-qa.patch12
-rw-r--r--app-crypt/bcwipe/files/digest-bcwipe-1.6_p86
4 files changed, 73 insertions, 1 deletions
diff --git a/app-crypt/bcwipe/ChangeLog b/app-crypt/bcwipe/ChangeLog
index cd97ccdba6e0..065713872935 100644
--- a/app-crypt/bcwipe/ChangeLog
+++ b/app-crypt/bcwipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/bcwipe
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.18 2007/02/21 20:22:43 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.19 2007/11/10 09:18:30 alonbl Exp $
+
+*bcwipe-1.6_p8 (10 Nov 2007)
+
+ 10 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/bcwipe-1.6_p8-qa.patch, +bcwipe-1.6_p8.ebuild:
+ Version bump
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-crypt/bcwipe/bcwipe-1.6_p8.ebuild b/app-crypt/bcwipe/bcwipe-1.6_p8.ebuild
new file mode 100644
index 000000000000..06457f5ba5bf
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.6_p8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.6_p8.ebuild,v 1.1 2007/11/10 09:18:30 alonbl Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="BCWipe secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BCWipe-${PV/_p/-}.tar.gz
+ http://www.jetico.com/linux/BCWipe.doc.tgz"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-qa.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEFS="${CFLAGS}"|| die "Make failed"
+}
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [ -f testfile ] && die "test file still exists. bcwipe should of deleted it"
+}
+
+src_install() {
+ dobin bcwipe
+ doman bcwipe.1
+ use doc && dohtml -r ../bcwipe-help
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/files/bcwipe-1.6_p8-qa.patch b/app-crypt/bcwipe/files/bcwipe-1.6_p8-qa.patch
new file mode 100644
index 000000000000..a633521d4247
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.6_p8-qa.patch
@@ -0,0 +1,12 @@
+diff -urNp bcwipe.org/options.c bcwipe/options.c
+--- bcwipe.org/options.c 2007-09-11 06:41:19.000000000 +0300
++++ bcwipe/options.c 2007-11-10 11:05:38.000000000 +0200
+@@ -20,6 +20,8 @@ char wipe_c[]="$Id: options.c,v 1.3 2007
+ #include "options.h"
+ #include "schemes.h"
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+
+ int o_verbose = FALSE; /* -v, */
diff --git a/app-crypt/bcwipe/files/digest-bcwipe-1.6_p8 b/app-crypt/bcwipe/files/digest-bcwipe-1.6_p8
new file mode 100644
index 000000000000..2d4a8c4fe7e2
--- /dev/null
+++ b/app-crypt/bcwipe/files/digest-bcwipe-1.6_p8
@@ -0,0 +1,6 @@
+MD5 7607697afe2da66c368b7e52f2ebf74c BCWipe-1.6-8.tar.gz 23779
+RMD160 8433bec23dfb4c14aaebe031d4064de0e3e6d3db BCWipe-1.6-8.tar.gz 23779
+SHA256 6fb81a894916aaa29b94ad0dd18b9f72e7c3524c7ade55e28c24cf7a7250da4d BCWipe-1.6-8.tar.gz 23779
+MD5 f095c187949d08a3cc3b245862df9acd BCWipe.doc.tgz 21218
+RMD160 a38bb741c3aae7d849cc8035010644720434ac2b BCWipe.doc.tgz 21218
+SHA256 afa50bf8653bb6bee108f0ae8b3dc35d289dde3d5c513b7e9ae7fe373635df4f BCWipe.doc.tgz 21218