summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-06-09 14:13:22 +0000
committerDane Smith <c1pher@gentoo.org>2011-06-09 14:13:22 +0000
commit3e0316b5b32a7ee0bef7101930aaca72ad804ae5 (patch)
tree45a5b7d1cdf36d5c5b3dac466d3667e32535df08 /app-crypt
parentadd temporary support for the extras use flag. (diff)
downloadgentoo-2-3e0316b5b32a7ee0bef7101930aaca72ad804ae5.tar.gz
gentoo-2-3e0316b5b32a7ee0bef7101930aaca72ad804ae5.tar.bz2
gentoo-2-3e0316b5b32a7ee0bef7101930aaca72ad804ae5.zip
app-crypt/gnupg: Revbump. Remove caps USE flag wrt bug 360421. Drop old.
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog11
-rw-r--r--app-crypt/gnupg/gnupg-2.0.17-r2.ebuild (renamed from app-crypt/gnupg/gnupg-2.0.17-r1.ebuild)33
2 files changed, 26 insertions, 18 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index bd84f3d88338..0132347588c0 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-crypt/gnupg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.414 2011/05/14 19:37:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.415 2011/06/09 14:13:22 c1pher Exp $
+
+*gnupg-2.0.17-r2 (09 Jun 2011)
+
+ 09 Jun 2011; Dane Smith <c1pher@gentoo.org> -gnupg-2.0.17-r1.ebuild,
+ +gnupg-2.0.17-r2.ebuild:
+ Revision bump. Remove caps USE flag since capabilities are no longer
+ used anywhere wrt bug 360421.
+ Remove no longer needed || die.
+ Drop old revision. No keyword changes necessary.
14 May 2011; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.17.ebuild:
ia64/s390/sh/sparc stable wrt #355265
diff --git a/app-crypt/gnupg/gnupg-2.0.17-r1.ebuild b/app-crypt/gnupg/gnupg-2.0.17-r2.ebuild
index 5194ce7728fa..6ab7e221ed54 100644
--- a/app-crypt/gnupg/gnupg-2.0.17-r1.ebuild
+++ b/app-crypt/gnupg/gnupg-2.0.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.17-r1.ebuild,v 1.1 2011/04/16 23:56:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.17-r2.ebuild,v 1.1 2011/06/09 14:13:22 c1pher Exp $
EAPI="4"
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnupg/gnupg/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="adns bzip2 caps doc ldap nls static selinux smartcard usb"
+IUSE="adns bzip2 doc ldap nls static selinux smartcard usb"
COMMON_DEPEND_LIBS="
>=dev-libs/libassuan-2
@@ -80,43 +80,42 @@ src_configure() {
$(use_enable !elibc_SunOS symcryptrun) \
$(use_enable nls) \
$(use_enable ldap) \
- $(use_with caps capabilities) \
CC_FOR_BUILD="$(tc-getBUILD_CC)"
}
src_compile() {
- emake || die "emake failed"
+ emake
if use doc; then
cd doc
- emake html || die "emake html failed"
+ emake html
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- emake DESTDIR="${D}" -f doc/Makefile uninstall-nobase_dist_docDATA || die
- rm -r "${ED}usr/share/gnupg/help"* || die
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" -f doc/Makefile uninstall-nobase_dist_docDATA
+ rm -r "${ED}usr/share/gnupg/help"*
dodoc ChangeLog NEWS README THANKS TODO VERSION doc/FAQ doc/DETAILS \
- doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER doc/help* || die "dodoc failed"
+ doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER doc/help*
- dosym gpg2 /usr/bin/gpg || die
- dosym gpgv2 /usr/bin/gpgv || die
- dosym gpg2keys_hkp /usr/libexec/gpgkeys_hkp || die
- dosym gpg2keys_finger /usr/libexec/gpgkeys_finger || die
- dosym gpg2keys_curl /usr/libexec/gpgkeys_curl || die
+ dosym gpg2 /usr/bin/gpg
+ dosym gpgv2 /usr/bin/gpgv
+ dosym gpg2keys_hkp /usr/libexec/gpgkeys_hkp
+ dosym gpg2keys_finger /usr/libexec/gpgkeys_finger
+ dosym gpg2keys_curl /usr/libexec/gpgkeys_curl
if use ldap; then
- dosym gpg2keys_ldap /usr/libexec/gpgkeys_ldap || die
+ dosym gpg2keys_ldap /usr/libexec/gpgkeys_ldap
fi
echo ".so man1/gpg2.1" > "${ED}usr/share/man/man1/gpg.1"
echo ".so man1/gpgv2.1" > "${ED}usr/share/man/man1/gpgv.1"
- dodir /etc/env.d || die
+ dodir /etc/env.d
echo "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt" >>"${ED}etc/env.d/30gnupg"
if use doc; then
- dohtml doc/gnupg.html/* doc/*.png || die "dohtml failed"
+ dohtml doc/gnupg.html/* doc/*.png
fi
}