summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2007-01-10 15:38:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2007-01-10 15:38:15 +0000
commit30f23c5b9734ceeb9d52b231cf8feeaebe2fbcc9 (patch)
treea166ec9b1bb87b5472b2245c37f513ae845dd0ab /app-crypt
parentStable on amd64/x86 wrt bug #161177. (diff)
downloadgentoo-2-30f23c5b9734ceeb9d52b231cf8feeaebe2fbcc9.tar.gz
gentoo-2-30f23c5b9734ceeb9d52b231cf8feeaebe2fbcc9.tar.bz2
gentoo-2-30f23c5b9734ceeb9d52b231cf8feeaebe2fbcc9.zip
Version bump to 1.5.2 -- new candidate for stability, owing to bug #158810 and bug #161260. Upstream seems to have abandoned 1.4 series, so we're stuck with the 1.5 series for now (and 1.6 soon). The only problem is lack of --enable-static.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mit-krb5/ChangeLog11
-rw-r--r--app-crypt/mit-krb5/files/digest-mit-krb5-1.5.23
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.5.2.ebuild95
3 files changed, 108 insertions, 1 deletions
diff --git a/app-crypt/mit-krb5/ChangeLog b/app-crypt/mit-krb5/ChangeLog
index 5d7c59f06ae9..ff70f3d28cde 100644
--- a/app-crypt/mit-krb5/ChangeLog
+++ b/app-crypt/mit-krb5/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-crypt/mit-krb5
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.138 2007/01/06 18:26:36 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/ChangeLog,v 1.139 2007/01/10 15:38:15 seemant Exp $
+
+*mit-krb5-1.5.2 (10 Jan 2007)
+
+ 10 Jan 2007; Seemant Kulleen <seemant@gentoo.org> -mit-krb5-1.5.1.ebuild,
+ +mit-krb5-1.5.2.ebuild:
+ Version bump to 1.5.2 -- new candidate for stability, owing to bug #158810
+ and bug #161260. Upstream seems to have abandoned 1.4 series, so we're stuck
+ with the 1.5 series for now (and 1.6 soon). The only problem is lack of
+ --enable-static.
06 Jan 2007; Timothy Redaelli <drizzt@gentoo.org> -mit-krb5-1.4.3.ebuild,
-mit-krb5-1.4.3-r1.ebuild, -mit-krb5-1.4.3-r2.ebuild,
diff --git a/app-crypt/mit-krb5/files/digest-mit-krb5-1.5.2 b/app-crypt/mit-krb5/files/digest-mit-krb5-1.5.2
new file mode 100644
index 000000000000..acc96e7682b6
--- /dev/null
+++ b/app-crypt/mit-krb5/files/digest-mit-krb5-1.5.2
@@ -0,0 +1,3 @@
+MD5 4d1452f775281f5da62e8fde0b517692 krb5-1.5.2-signed.tar 10086400
+RMD160 b8eca92373155eac0661721f0c65777673d4654e krb5-1.5.2-signed.tar 10086400
+SHA256 1db46e506fbc0b1a274cb00c3fda5b5e4de832ce40c209e4f6603adcdf2e770e krb5-1.5.2-signed.tar 10086400
diff --git a/app-crypt/mit-krb5/mit-krb5-1.5.2.ebuild b/app-crypt/mit-krb5/mit-krb5-1.5.2.ebuild
new file mode 100644
index 000000000000..8d6ecf9d1308
--- /dev/null
+++ b/app-crypt/mit-krb5/mit-krb5-1.5.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mit-krb5/mit-krb5-1.5.2.ebuild,v 1.1 2007/01/10 15:38:15 seemant Exp $
+
+inherit eutils flag-o-matic versionator autotools
+
+MY_P=${P/mit-}
+P_DIR=$(get_version_component_range 1-2)
+S=${WORKDIR}/${MY_P}/src
+DESCRIPTION="MIT Kerberos V"
+HOMEPAGE="http://web.mit.edu/kerberos/www/"
+SRC_URI="http://web.mit.edu/kerberos/dist/krb5/${P_DIR}/${MY_P}-signed.tar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="krb4 tcl ipv6 doc"
+
+RDEPEND="!virtual/krb5
+ sys-libs/com_err
+ sys-libs/ss
+ tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/tetex )"
+PROVIDE="virtual/krb5"
+
+src_unpack() {
+ unpack ${MY_P}-signed.tar
+ unpack ./${MY_P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-lazyldflags.patch
+ ebegin "Reconfiguring configure scripts (be patient)"
+ cd "${S}"/appl/telnet
+ eautoconf --force -I "${S}"
+ eend $?
+}
+
+src_compile() {
+ econf \
+ $(use_with krb4) \
+ $(use_with tcl) \
+ $(use_enable ipv6) \
+ --enable-shared \
+ --with-system-et --with-system-ss \
+ --enable-dns-for-realm || die
+
+ emake -j1 || die
+
+ if use doc ; then
+ cd ../doc
+ for dir in api implement ; do
+ make -C ${dir} || die
+ done
+ fi
+}
+
+src_test() {
+ einfo "Testing is being debugged, disabled for now"
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ EXAMPLEDIR=/usr/share/doc/${PF}/examples \
+ install || die
+
+ cd ..
+ dodoc README
+ dodoc doc/*.ps
+ doinfo doc/*.info*
+ dohtml -r doc/*
+
+ use doc && dodoc doc/{api,implement}/*.ps
+
+ for i in {telnetd,ftpd} ; do
+ mv "${D}"/usr/share/man/man8/${i}.8 "${D}"/usr/share/man/man8/k${i}.8
+ mv "${D}"/usr/sbin/${i} "${D}"/usr/sbin/k${i}
+ done
+
+ for i in {rcp,rlogin,rsh,telnet,ftp} ; do
+ mv "${D}"/usr/share/man/man1/${i}.1 "${D}"/usr/share/man/man1/k${i}.1
+ mv "${D}"/usr/bin/${i} "${D}"/usr/bin/k${i}
+ done
+
+ newinitd "${FILESDIR}"/mit-krb5kadmind.initd mit-krb5kadmind
+ newinitd "${FILESDIR}"/mit-krb5kdc.initd mit-krb5kdc
+
+ insinto /etc
+ newins ${D}/usr/share/doc/${PF}/examples/krb5.conf krb5.conf.example
+ newins ${D}/usr/share/doc/${PF}/examples/kdc.conf kdc.conf.example
+}
+
+pkg_postinst() {
+ elog "See /usr/share/doc/${PF}/html/krb5-admin/index.html for documentation."
+}