summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-03-30 23:09:54 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-03-30 23:09:54 +0000
commit10dd9ae7677a489d30dd63e849b347f627364f04 (patch)
tree9ca1aeb780c898cbf1f916defd0fb3cfd881f2fc /app-crypt
parentVersion bump, bug #456072. (diff)
downloadgentoo-2-10dd9ae7677a489d30dd63e849b347f627364f04.tar.gz
gentoo-2-10dd9ae7677a489d30dd63e849b347f627364f04.tar.bz2
gentoo-2-10dd9ae7677a489d30dd63e849b347f627364f04.zip
Fix multi-slot for ActivCard, bug#460662, thanks to Kamil Roman
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/coolkey/ChangeLog7
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r6.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/app-crypt/coolkey/ChangeLog b/app-crypt/coolkey/ChangeLog
index f33cdd8d5150..d9e3ed8210df 100644
--- a/app-crypt/coolkey/ChangeLog
+++ b/app-crypt/coolkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/coolkey
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/coolkey/ChangeLog,v 1.18 2013/02/02 22:21:12 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/coolkey/ChangeLog,v 1.19 2013/03/30 23:09:54 alonbl Exp $
+
+*coolkey-1.1.0-r6 (30 Mar 2013)
+
+ 30 Mar 2013; Alon Bar-Lev <alonbl@gentoo.org> +coolkey-1.1.0-r6.ebuild:
+ Fix multi-slot for ActivCard, bug#460662, thanks to Kamil Roman
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> coolkey-1.1.0-r5.ebuild:
Add ~arm, wrt bug #449220
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r6.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r6.ebuild
new file mode 100644
index 000000000000..73dd22a97133
--- /dev/null
+++ b/app-crypt/coolkey/coolkey-1.1.0-r6.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/coolkey/coolkey-1.1.0-r6.ebuild,v 1.1 2013/03/30 23:09:54 alonbl Exp $
+
+EAPI=3
+
+inherit eutils
+
+PATCHVER="002"
+
+DESCRIPTION="Linux Driver support for the CoolKey and CAC products"
+HOMEPAGE="http://directory.fedora.redhat.com/wiki/CoolKey"
+SRC_URI="http://directory.fedora.redhat.com/download/coolkey/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.6.4
+ dev-libs/nss[utils]
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ >=app-crypt/ccid-1.4.0
+ virtual/pkgconfig"
+
+pkg_setup() {
+ pk="pk11install"
+ dbdir="/etc/pki/nssdb"
+ ck_mod_name="CoolKey PKCS #11 Module"
+
+ if ! [[ -x $dbdir ]]; then
+ ewarn "No /etc/pki/nssdb found; check under \$HOME/.pki and"
+ ewarn "follow the suggested commands using the correct path."
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}/${PN}-patches"/*
+}
+
+src_configure() {
+ econf --enable-pk11install $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake CFLAGS+="-fno-strict-aliasing" -j1 || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ diropts -m 1777
+ keepdir /var/cache/coolkey
+}
+
+pkg_postinst() {
+ if [[ -x $dbdir ]]; then
+ if ! $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You still need to install libcoolkey in your PKCS11 library:"
+ elog "$pk -p $dbdir 'name=$ck_mod_name library=libcoolkeypk11.so'"
+
+ fi
+ else
+ elog ""
+ elog "You still need to setup your PKCS11 library, or at least"
+ elog "find where it is (perhaps \$HOME/.pki/nssdb). Once you"
+ elog "find it, use 'modutil -rawlist -dbdir \$db' to look for"
+ elog "libcoolkeypk11.so, and if not found, add it using:"
+ elog ""
+ elog "$pk -p \$db 'name=$ck_mod_name library=libcoolkeypk11.so'"
+ elog ""
+ elog "where \$db is the full path to your pki/nssdb directory."
+ elog ""
+ fi
+}
+
+pkg_postrm() {
+ if [[ -x $dbdir ]]; then
+ if $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You should remove libcoolkey from your PKCS11 library."
+ fi
+ fi
+}