summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-30 19:21:38 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-30 19:21:38 +0000
commit04cabb08984959cc4f7031124f4c7ad67dfe0953 (patch)
tree338f43c894f0fc138d6605e323ff96e97bb4d6ec /app-crypt
parentStabilize 0.10 for amd64/x86 and drop old (diff)
downloadgentoo-2-04cabb08984959cc4f7031124f4c7ad67dfe0953.tar.gz
gentoo-2-04cabb08984959cc4f7031124f4c7ad67dfe0953.tar.bz2
gentoo-2-04cabb08984959cc4f7031124f4c7ad67dfe0953.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gcr/ChangeLog7
-rw-r--r--app-crypt/gcr/gcr-3.12.2.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/app-crypt/gcr/ChangeLog b/app-crypt/gcr/ChangeLog
index 5546fa79eeff..dab304635768 100644
--- a/app-crypt/gcr/ChangeLog
+++ b/app-crypt/gcr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gcr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.35 2014/04/27 15:25:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.36 2014/05/30 19:21:38 pacho Exp $
+
+*gcr-3.12.2 (30 May 2014)
+
+ 30 May 2014; Pacho Ramos <pacho@gentoo.org> +gcr-3.12.2.ebuild:
+ Version bump
*gcr-3.12.0 (27 Apr 2014)
diff --git a/app-crypt/gcr/gcr-3.12.2.ebuild b/app-crypt/gcr/gcr-3.12.2.ebuild
new file mode 100644
index 000000000000..0d333e04231d
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.12.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.12.2.ebuild,v 1.1 2014/05/30 19:21:38 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.20"
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="https://developer.gnome.org/gcr/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-3
+IUSE="debug gtk +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=app-crypt/gnupg-2
+ >=app-crypt/p11-kit-0.19
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libgcrypt-1.2.2:0=
+ >=dev-libs/libtasn1-1:=
+ >=sys-apps/dbus-1
+ gtk? ( >=x11-libs/gtk+-3:3 )
+ introspection? ( >=dev-libs/gobject-introspection-1.34 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-keyring-3.3
+"
+# gcr was part of gnome-keyring until 3.3
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection-common
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# eautoreconf needs:
+# dev-libs/gobject-introspection-common
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Disable stupid flag changes
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_with gtk) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(usex debug --enable-debug=yes --enable-debug=default) \
+ --disable-update-icon-cache \
+ --disable-update-mime
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}