summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-01 10:29:43 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-01 10:29:43 +0000
commit0087eea3006bd14bd2d716a1f626da7eef694d21 (patch)
tree55bf6662425317bb2b3aa0bbffbc8814d7bedbcc /app-crypt
parentVersion bump (diff)
downloadgentoo-2-0087eea3006bd14bd2d716a1f626da7eef694d21.tar.gz
gentoo-2-0087eea3006bd14bd2d716a1f626da7eef694d21.tar.bz2
gentoo-2-0087eea3006bd14bd2d716a1f626da7eef694d21.zip
Initial imports
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpgsm/ChangeLog9
-rw-r--r--app-crypt/gpgsm/files/digest-gpgsm-0.3.101
-rw-r--r--app-crypt/gpgsm/gpgsm-0.3.10.ebuild36
3 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/gpgsm/ChangeLog b/app-crypt/gpgsm/ChangeLog
new file mode 100644
index 000000000000..80a5b69a22ed
--- /dev/null
+++ b/app-crypt/gpgsm/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-crypt/gpgsm
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgsm/ChangeLog,v 1.1 2002/11/01 10:29:43 aliz Exp $
+
+*gpgsm-0.3.10 (31 Oct 2002)
+
+ 31 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Initial import. Ebuil submitted by Jacob Perkins <jap1@ionet.ne>
+ in #6850.
diff --git a/app-crypt/gpgsm/files/digest-gpgsm-0.3.10 b/app-crypt/gpgsm/files/digest-gpgsm-0.3.10
new file mode 100644
index 000000000000..42a95550d911
--- /dev/null
+++ b/app-crypt/gpgsm/files/digest-gpgsm-0.3.10
@@ -0,0 +1 @@
+MD5 0745d9783df0f7186db3cd3ad0a67b43 newpg-0.3.10.tar.gz 584526
diff --git a/app-crypt/gpgsm/gpgsm-0.3.10.ebuild b/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
new file mode 100644
index 000000000000..aac12818130d
--- /dev/null
+++ b/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgsm/gpgsm-0.3.10.ebuild,v 1.1 2002/11/01 10:29:43 aliz Exp $
+
+S="${WORKDIR}/newpg-${PV}"
+DESCRIPTION="GnuPG Cryptographic message syntax and temporary project for gnupg extensions. Will be merged into gnupg for the gnupg-2.0 release."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/aegypten/newpg-${PV}.tar.gz"
+HOMEPAGE="http://www.gnupg.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/libgcrypt-1.1.8
+ >=dev-libs/libksba-0.4.4
+ >=dev-libs/pth-1.3.7"
+
+#pth isn't really necessary, but is a good thing
+#maybe a threads use variable?
+#this can also be built with smartcard support, but we have no ebuilds or use vars for that
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile(){
+ local myconf
+ use nls \
+ || myconf="--disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README README-alpha THANKS TODO VERSION
+}