summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2013-01-04 00:49:09 +0000
committerDane Smith <c1pher@gentoo.org>2013-01-04 00:49:09 +0000
commit5f9b045941d212fdd1cb0343c1eaf98e578ea675 (patch)
treee5a49db714bc7bf5c2f95633f9157c1d31f352bc /app-crypt/xca
parentSet DISTUTILS_NO_PARALLEL_BUILD to prevent race in tests. (diff)
downloadgentoo-2-5f9b045941d212fdd1cb0343c1eaf98e578ea675.tar.gz
gentoo-2-5f9b045941d212fdd1cb0343c1eaf98e578ea675.tar.bz2
gentoo-2-5f9b045941d212fdd1cb0343c1eaf98e578ea675.zip
app-crypt/xca: version bump wrt bug 449740.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E27104B3)
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/ChangeLog10
-rw-r--r--app-crypt/xca/files/xca-0.9.3-desktop.patch12
-rw-r--r--app-crypt/xca/xca-0.9.3.ebuild53
3 files changed, 73 insertions, 2 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 6fdb9166ae8b..26be691e6207 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/xca
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.36 2012/11/04 21:48:59 c1pher Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.37 2013/01/04 00:49:09 c1pher Exp $
+
+*xca-0.9.3 (04 Jan 2013)
+
+ 04 Jan 2013; Dane Smith <c1pher@gentoo.org> +xca-0.9.3.ebuild,
+ +files/xca-0.9.3-desktop.patch:
+ Version bump wrt bug 449740. Fix issues with the .desktop file in new patch.
*xca-0.9.1 (04 Nov 2012)
diff --git a/app-crypt/xca/files/xca-0.9.3-desktop.patch b/app-crypt/xca/files/xca-0.9.3-desktop.patch
new file mode 100644
index 000000000000..cee9b3261b0a
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.9.3-desktop.patch
@@ -0,0 +1,12 @@
+--- misc/xca.desktop 2012-05-12 05:37:14.000000000 -0400
++++ xca.desktop.new 2013-01-03 19:43:35.877856711 -0500
+@@ -7,7 +7,7 @@
+ Comment[fi]=Graafinen X.509-varmenteiden hallintatyökalu
+ Comment[fr]=Création et gestion de certificats conformes à la norme X.509
+ Exec=xca %F
+-Icon=xca-32x32.xpm
++Icon=xca-32x32
+ Terminal=false
+-Categories=Application;Utility;Qt;
++Categories=Utility;Qt;
+ MimeType=application/x-xca-database;application/x-xca-template;application/x-x509-ca-cert;application/pkcs10;application/x-pkcs7-certificates;application/x-pkcs12;
diff --git a/app-crypt/xca/xca-0.9.3.ebuild b/app-crypt/xca/xca-0.9.3.ebuild
new file mode 100644
index 000000000000..db1e5d2baba4
--- /dev/null
+++ b/app-crypt/xca/xca-0.9.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.9.3.ebuild,v 1.1 2013/01/04 00:49:09 c1pher Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.8[-bindist]
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+src_prepare() {
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1800298&group_id=62274&atid=500028
+ epatch "${FILESDIR}"/${PN}-0.9.0-qt_detection.patch
+ epatch "${FILESDIR}"/${PN}-0.9.1-ldflags.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+}
+
+src_configure() {
+ local LINUXDOC
+ use doc || LINUXDOC='touch $@ && true'
+
+ QTDIR="${EPREFIX}/usr" \
+ STRIP="true" \
+ LINUXDOC="${LINUXDOC}" \
+ CC="$(tc-getCXX)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ ./configure || die "configure failed"
+}
+
+src_install() {
+ emake destdir="${D}" mandir="share/man" install
+
+ dodoc AUTHORS
+
+ insinto /etc/xca
+ doins misc/*.txt
+}