summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-18 17:54:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-18 17:54:26 +0000
commit16a2bd8d2a6254f2fe49e9ade99742cb2f5571d4 (patch)
tree6948ad6321356bb982113316b1b445cf48c1acbb /app-crypt/xca
parentx86 stable, bug #287697 (diff)
downloadgentoo-2-16a2bd8d2a6254f2fe49e9ade99742cb2f5571d4.tar.gz
gentoo-2-16a2bd8d2a6254f2fe49e9ade99742cb2f5571d4.tar.bz2
gentoo-2-16a2bd8d2a6254f2fe49e9ade99742cb2f5571d4.zip
Fix building with GCC 4.4+ wrt #289608.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/ChangeLog6
-rw-r--r--app-crypt/xca/files/xca-0.7.0-gcc44.patch11
-rw-r--r--app-crypt/xca/xca-0.7.0.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 41ec46e90ddf..5d5dad00c7b7 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/xca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.19 2009/10/03 20:11:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.20 2009/10/18 17:54:26 ssuominen Exp $
+
+ 18 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> xca-0.7.0.ebuild,
+ +files/xca-0.7.0-gcc44.patch:
+ Fix building with GCC 4.4+ wrt #289608.
*xca-0.7.0 (03 Oct 2009)
diff --git a/app-crypt/xca/files/xca-0.7.0-gcc44.patch b/app-crypt/xca/files/xca-0.7.0-gcc44.patch
new file mode 100644
index 000000000000..2889b6f00180
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.7.0-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur xca-0.7.0.orig/lib/db.h xca-0.7.0/lib/db.h
+--- xca-0.7.0.orig/lib/db.h 2009-09-11 00:08:25.000000000 +0300
++++ xca-0.7.0/lib/db.h 2009-10-18 20:52:31.000000000 +0300
+@@ -8,6 +8,7 @@
+ #ifndef _XCA_DB_H_
+ #define _XCA_DB_H_
+
++#include <stdint.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/app-crypt/xca/xca-0.7.0.ebuild b/app-crypt/xca/xca-0.7.0.ebuild
index 7fee753ea689..4cfb68b3aaae 100644
--- a/app-crypt/xca/xca-0.7.0.ebuild
+++ b/app-crypt/xca/xca-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.7.0.ebuild,v 1.1 2009/10/03 20:11:18 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.7.0.ebuild,v 1.2 2009/10/18 17:54:26 ssuominen Exp $
EAPI="2"
@@ -27,7 +27,8 @@ DEPEND="${RDEPEND}
# 2. doc hacks.
src_prepare() {
- epatch "${FILESDIR}/${PN}-0.6.4-build.patch"
+ epatch "${FILESDIR}"/${PN}-0.6.4-build.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
sed -e 's/$(LD) $(LDFLAGS)/$(LD) $(RAW_LDFLAGS)/' -i Makefile Rules.mak || die "sed failed"
}