summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 22:26:47 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 22:26:47 +0000
commitcd1a7ea97067adbc34884c21e0abe28712671fa7 (patch)
tree5e4a8ca0a60d19d69e7604cafb886ba78ed150c1 /app-crypt/truecrypt
parentVersion bump per bug#426230, thanks to Gerald (diff)
downloadgentoo-2-cd1a7ea97067adbc34884c21e0abe28712671fa7.tar.gz
gentoo-2-cd1a7ea97067adbc34884c21e0abe28712671fa7.tar.bz2
gentoo-2-cd1a7ea97067adbc34884c21e0abe28712671fa7.zip
Solve gentoo mirror breakage due to restrict fetch, bug#434458
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-crypt/truecrypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog6
-rw-r--r--app-crypt/truecrypt/truecrypt-7.1a.ebuild11
2 files changed, 12 insertions, 5 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 2cbfe24a4ee5..137e063ddacd 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.71 2012/08/02 18:25:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.72 2012/12/14 22:26:47 alonbl Exp $
+
+ 14 Dec 2012; <alonbl@gentoo.org> truecrypt-7.1a.ebuild:
+ Solve gentoo mirror breakage due to restrict fetch, bug#434458
02 Aug 2012; Tim Harder <radhermit@gentoo.org> truecrypt-7.1a.ebuild:
Remove PORTDIR from license warning (bug #416737).
@@ -365,4 +368,3 @@
05 Jun 2006; Daniel Black <dragonheart@gentoo.org>
+files/truecrypt-4.2-makefile.patch, +metadata.xml, +truecrypt-4.2.ebuild:
initial ebuild as per bug #112197 largely based off ebuild by Greg Tassone
-
diff --git a/app-crypt/truecrypt/truecrypt-7.1a.ebuild b/app-crypt/truecrypt/truecrypt-7.1a.ebuild
index c4ac9f3b9a05..e256009b019a 100644
--- a/app-crypt/truecrypt/truecrypt-7.1a.ebuild
+++ b/app-crypt/truecrypt/truecrypt-7.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.1a.ebuild,v 1.3 2012/08/02 18:25:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.1a.ebuild,v 1.4 2012/12/14 22:26:47 alonbl Exp $
EAPI="4"
@@ -9,7 +9,7 @@ inherit flag-o-matic linux-info multilib toolchain-funcs wxwidgets eutils pax-ut
DESCRIPTION="Free open-source disk encryption software"
HOMEPAGE="http://www.truecrypt.org/"
SRC_URI="${P}.tar.gz
- mirror://gentoo/${PN}-pkcs11.h.bz2"
+ ${P}-pkcs11.h"
LICENSE="truecrypt-3.0"
SLOT="0"
@@ -31,6 +31,11 @@ pkg_nofetch() {
elog "Please download the source archive \"TrueCrypt ${PV} Source.tar.gz\" from:"
elog "http://www.truecrypt.org/downloads2"
elog "Then put the file in ${DISTDIR}/${P}.tar.gz"
+
+ # until we support restricted fetch per URI
+ elog ""
+ elog "Please execute:"
+ elog "curl 'http://git.gnupg.org/cgi-bin/gitweb.cgi?p=scute.git;a=blob_plain;f=src/pkcs11.h;hb=38bdba0bb1ab93950489c645938c93ed577f9139' > ${DISTDIR}/${P}-pkcs11.h"
}
pkg_setup() {
@@ -54,7 +59,7 @@ src_prepare() {
epatch "${FILESDIR}/makefile-archdetect.diff"
epatch "${FILESDIR}/execstack-fix.diff"
mkdir "${T}"/pkcs11 || die
- ln -s "${WORKDIR}"/truecrypt-pkcs11.h "${T}"/pkcs11/pkcs11.h || die
+ ln -s "${DISTDIR}"/${P}-pkcs11.h "${T}"/pkcs11/pkcs11.h || die
}
src_compile() {