summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-07-15 13:10:37 +0000
committerDane Smith <c1pher@gentoo.org>2011-07-15 13:10:37 +0000
commit40a6ccaddc333f56f2c0f7761440440d5c7c6290 (patch)
treef3e5c64d9b2559bd71aa9db95144e59e2d24e4dc /app-crypt/truecrypt
parentVersion bump (diff)
downloadgentoo-2-40a6ccaddc333f56f2c0f7761440440d5c7c6290.tar.gz
gentoo-2-40a6ccaddc333f56f2c0f7761440440d5c7c6290.tar.bz2
gentoo-2-40a6ccaddc333f56f2c0f7761440440d5c7c6290.zip
app-crypt/truecrypt: Allow for the use of scute's pkcs11.h file if using >=dev-libs/opensc-0.12 wrt bug 369781.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/truecrypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog7
-rw-r--r--app-crypt/truecrypt/truecrypt-7.0a-r5.ebuild13
2 files changed, 17 insertions, 3 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index da4b920d1517..7fce8191d3a5 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.64 2011/06/01 21:24:10 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.65 2011/07/15 13:10:37 c1pher Exp $
+
+ 15 Jul 2011; Dane Smith <c1pher@gentoo.org> truecrypt-7.0a-r5.ebuild:
+ Allow for the inclusion of our own pkcs11.h if using >=opensc-0.12 wrt
+ bug 369781. No revbump. Thanks to Alon Bar-Lev and Diego Elio Petteno
+ for help with the fix.
*truecrypt-7.0a-r5 (01 Jun 2011)
diff --git a/app-crypt/truecrypt/truecrypt-7.0a-r5.ebuild b/app-crypt/truecrypt/truecrypt-7.0a-r5.ebuild
index bf7fcc7bb11c..492137cda58f 100644
--- a/app-crypt/truecrypt/truecrypt-7.0a-r5.ebuild
+++ b/app-crypt/truecrypt/truecrypt-7.0a-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.0a-r5.ebuild,v 1.1 2011/06/01 21:24:10 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.0a-r5.ebuild,v 1.2 2011/07/15 13:10:37 c1pher Exp $
EAPI="2"
@@ -9,7 +9,8 @@ inherit flag-o-matic linux-info multilib toolchain-funcs wxwidgets eutils \
DESCRIPTION="Free open-source disk encryption software"
HOMEPAGE="http://www.truecrypt.org/"
-SRC_URI="${P}.tar.gz"
+SRC_URI="${P}.tar.gz\
+ mirror://gentoo/${PN}-pkcs11.h.bz2"
LICENSE="truecrypt-3.0"
SLOT="0"
@@ -54,6 +55,11 @@ src_prepare() {
epatch "${FILESDIR}/makefile-archdetect.diff"
epatch "${FILESDIR}/execstack-fix.diff"
+ if ! has_version dev-libs/pkcs11-helper && \
+ has_version "=dev-libs/opensc-0.12*"; then
+ mkdir pkcs11 || die
+ cp "${WORKDIR}"/truecrypt-pkcs11.h pkcs11/pkcs11.h || die
+ fi
}
src_compile() {
@@ -63,6 +69,9 @@ src_compile() {
if has_version dev-libs/pkcs11-helper; then
pkcs11_include_directory="/usr/include/pkcs11-helper-1.0"
+ elif has_version "=dev-libs/opensc-0.12*"; then
+ pkcs11_include_directory="/usr/include/opensc"
+ append-flags -I"${S}"/pkcs11
else
pkcs11_include_directory="/usr/include/opensc"
fi