summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-21 17:39:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-21 17:39:53 +0000
commit2c2669c534d386837ab7782a2e32aec9125e7a34 (patch)
treec96beeaaad9d7f41c0c0d2fae3c8b4d4fd5b74b8 /app-crypt/truecrypt
parentSparc stable, part of Bug #270738. (diff)
downloadgentoo-2-2c2669c534d386837ab7782a2e32aec9125e7a34.tar.gz
gentoo-2-2c2669c534d386837ab7782a2e32aec9125e7a34.tar.bz2
gentoo-2-2c2669c534d386837ab7782a2e32aec9125e7a34.zip
Fix building with USE="-X" when x11-libs/wxGTK is built with USE="X" (bug #270279). Fix dependencies (bug #270441). Check for appropriate kernel configuration.
(Portage version: 13625-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/truecrypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog8
-rw-r--r--app-crypt/truecrypt/truecrypt-6.2.ebuild21
2 files changed, 23 insertions, 6 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 3aa4ab48e8ba..8edbd3b01e2e 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.45 2009/05/18 04:39:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.46 2009/05/21 17:39:53 arfrever Exp $
+
+ 21 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ truecrypt-6.2.ebuild:
+ Fix building with USE="-X" when x11-libs/wxGTK is built with USE="X" (bug
+ #270279). Fix dependencies (bug #270441). Check for appropriate kernel
+ configuration.
18 May 2009; Robin H. Johnson <robbat2@gentoo.org> truecrypt-4.3a.ebuild,
truecrypt-6.2.ebuild:
diff --git a/app-crypt/truecrypt/truecrypt-6.2.ebuild b/app-crypt/truecrypt/truecrypt-6.2.ebuild
index 4e6a81b45502..98b2264bdd5c 100644
--- a/app-crypt/truecrypt/truecrypt-6.2.ebuild
+++ b/app-crypt/truecrypt/truecrypt-6.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-6.2.ebuild,v 1.3 2009/05/18 04:39:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-6.2.ebuild,v 1.4 2009/05/21 17:39:53 arfrever Exp $
EAPI="2"
-inherit flag-o-matic multilib toolchain-funcs wxwidgets
+inherit flag-o-matic linux-info multilib toolchain-funcs wxwidgets
DESCRIPTION="Free open-source disk encryption software"
HOMEPAGE="http://www.truecrypt.org/"
@@ -16,8 +16,9 @@ KEYWORDS="~amd64 ~x86"
IUSE="X"
RESTRICT="bindist fetch mirror"
-RDEPEND="sys-fs/fuse
- x11-libs/wxGTK:2.8"
+RDEPEND="|| ( >=sys-fs/lvm2-2.02.45 sys-fs/device-mapper )
+ sys-fs/fuse
+ x11-libs/wxGTK:2.8[X?]"
DEPEND="${RDEPEND}
|| ( dev-libs/pkcs11-helper dev-libs/opensc )"
@@ -30,7 +31,10 @@ pkg_nofetch() {
}
pkg_setup() {
- WX_GTK_VER="2.8"
+ local CONFIG_CHECK="BLK_DEV_DM DM_CRYPT FUSE_FS CRYPTO"
+ linux-info_pkg_setup
+
+ local WX_GTK_VER="2.8"
if use X; then
need-wxwidgets unicode
else
@@ -38,6 +42,13 @@ pkg_setup() {
fi
}
+src_prepare() {
+ if has_version x11-libs/wxGTK[X]; then
+ # Fix linking when NOGUI=1
+ sed -e "s/WX_CONFIG_LIBS := base/&,core/" -i Main/Main.make || die "sed Main/Main.make failed"
+ fi
+}
+
src_compile() {
local EXTRA pkcs11_include_directory