summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-01 21:33:17 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-01 21:33:17 +0000
commit4bc8efc2bc57d374af696c187a74fb9a478b3b94 (patch)
tree5218a43ae7cce3f580e0db386f5f4c6fc8b5f370 /app-crypt/steghide
parentBump to EAPI=3, add prefix keywords (diff)
downloadgentoo-2-4bc8efc2bc57d374af696c187a74fb9a478b3b94.tar.gz
gentoo-2-4bc8efc2bc57d374af696c187a74fb9a478b3b94.tar.bz2
gentoo-2-4bc8efc2bc57d374af696c187a74fb9a478b3b94.zip
Bump to EAPI=3, add prefix keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-crypt/steghide')
-rw-r--r--app-crypt/steghide/ChangeLog5
-rw-r--r--app-crypt/steghide/steghide-0.5.1.ebuild22
2 files changed, 16 insertions, 11 deletions
diff --git a/app-crypt/steghide/ChangeLog b/app-crypt/steghide/ChangeLog
index c50e2ec34446..3428aee28286 100644
--- a/app-crypt/steghide/ChangeLog
+++ b/app-crypt/steghide/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/steghide
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/ChangeLog,v 1.18 2010/01/22 16:39:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/ChangeLog,v 1.19 2010/04/01 21:33:17 abcd Exp $
+
+ 01 Apr 2010; Jonathan Callen <abcd@gentoo.org> steghide-0.5.1.ebuild:
+ Bump to EAPI=3, add prefix keywords
22 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> steghide-0.5.1.ebuild:
Require SLOT="0" of media-libs/jpeg for headers.
diff --git a/app-crypt/steghide/steghide-0.5.1.ebuild b/app-crypt/steghide/steghide-0.5.1.ebuild
index 2668923f4e3e..af6a8a025638 100644
--- a/app-crypt/steghide/steghide-0.5.1.ebuild
+++ b/app-crypt/steghide/steghide-0.5.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/steghide-0.5.1.ebuild,v 1.13 2010/01/22 16:39:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/steghide-0.5.1.ebuild,v 1.14 2010/04/01 21:33:17 abcd Exp $
-EAPI=1
+EAPI="3"
inherit autotools eutils
DESCRIPTION="A steganography program which hides data in various media files"
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="debug"
DEPEND=">=app-crypt/mhash-0.8.18-r1
@@ -19,22 +19,24 @@ DEPEND=">=app-crypt/mhash-0.8.18-r1
media-libs/jpeg:0
>=sys-libs/zlib-1.1.4-r2"
-src_unpack(){
- unpack ${A}
- cd "${S}"
+src_prepare(){
epatch "${FILESDIR}"/${P}-gcc34.patch \
"${FILESDIR}"/${P}-gcc4.patch \
"${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}
-src_compile() {
+src_configure() {
econf $(use_enable debug)
- emake LIBTOOL="$(type -p libtool)" || die "emake failed."
+}
+
+src_compile() {
+ local libtool
+ [[ ${CHOST} == *-darwin* ]] && libtool=$(type -P glibtool) || libtool=$(type -P libtool)
+ emake LIBTOOL="${libtool}" || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install \
- || die "emake install failed."
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}" install || die "emake install failed"
prepalldocs
}