summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-09-27 00:49:54 +0000
committerSven Wegener <swegener@gentoo.org>2004-09-27 00:49:54 +0000
commit503ce934310df8545400a59f7eadc8675ceb94cf (patch)
tree3d3780da0ef65c7a4e5e3d4f0631677c8484aa46 /app-crypt/shash
parentmodutils damnit (diff)
downloadgentoo-2-503ce934310df8545400a59f7eadc8675ceb94cf.tar.gz
gentoo-2-503ce934310df8545400a59f7eadc8675ceb94cf.tar.bz2
gentoo-2-503ce934310df8545400a59f7eadc8675ceb94cf.zip
Revision bump. Added support for bash-completion. Thanks to James Rowe <jnrowe@ukfsn.org> in bug #64493.
Diffstat (limited to 'app-crypt/shash')
-rw-r--r--app-crypt/shash/ChangeLog9
-rw-r--r--app-crypt/shash/files/digest-shash-0.2.6-r11
-rw-r--r--app-crypt/shash/files/shash.bash-completion41
-rw-r--r--app-crypt/shash/shash-0.2.6-r1.ebuild49
4 files changed, 99 insertions, 1 deletions
diff --git a/app-crypt/shash/ChangeLog b/app-crypt/shash/ChangeLog
index 3cc0d404d4f7..9c55b862276c 100644
--- a/app-crypt/shash/ChangeLog
+++ b/app-crypt/shash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/shash
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/ChangeLog,v 1.5 2004/09/24 18:18:22 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/ChangeLog,v 1.6 2004/09/27 00:49:54 swegener Exp $
+
+*shash-0.2.6-r1 (27 Sep 2004)
+
+ 27 Sep 2004; Sven Wegener <swegener@gentoo.org>
+ +files/shash.bash-completion, +shash-0.2.6-r1.ebuild:
+ Revision bump. Added support for bash-completion. Thanks to James Rowe
+ <jnrowe@ukfsn.org> in bug #64493.
24 Sep 2004; Sven Wegener <swegener@gentoo.org>
+files/0.2.6-manpage-fixes.patch, shash-0.2.6.ebuild:
diff --git a/app-crypt/shash/files/digest-shash-0.2.6-r1 b/app-crypt/shash/files/digest-shash-0.2.6-r1
new file mode 100644
index 000000000000..b1befd302513
--- /dev/null
+++ b/app-crypt/shash/files/digest-shash-0.2.6-r1
@@ -0,0 +1 @@
+MD5 8f38ec66b989fa38275f5170e15241b4 shash-0.2.6.tar.gz 105641
diff --git a/app-crypt/shash/files/shash.bash-completion b/app-crypt/shash/files/shash.bash-completion
new file mode 100644
index 000000000000..9f2212a002be
--- /dev/null
+++ b/app-crypt/shash/files/shash.bash-completion
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/files/shash.bash-completion,v 1.1 2004/09/27 00:49:54 swegener Exp $
+#
+# shash(1) completion.
+
+have shash &&
+_shash() {
+ local cur prev
+
+ COMPREPLY=()
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ case "$prev" in
+ -c|--config)
+ _filedir
+ return 0 ;;
+ -o|--keymode)
+ COMPREPLY=( $( compgen -W "$( shash --listkeygen | tail -n +2 )" \
+ -- $cur ) )
+ return ;;
+ -a|--algorithm)
+ COMPREPLY=( $( compgen -W "$( shash --list )" \
+ -- $cur ) )
+ return ;;
+ *)
+ ;;
+ esac
+
+ COMPREPLY=( $( compgen -W '-V -q -m -d -c -b -t -o -i -a -l -k -h -v \
+ -L \
+ --verbose --quiet --nosalt --time --hmac --doublecheck \
+ --check --binary --text --keymode --config --algorithm \
+ --list --key --listkeygen --help --version --license' \
+ -- $cur ) )
+ _filedir
+ return 0
+}
+
+[ -n "${have:-}" ] && complete -F _shash $filenames shash
diff --git a/app-crypt/shash/shash-0.2.6-r1.ebuild b/app-crypt/shash/shash-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..1f8bd426cd9f
--- /dev/null
+++ b/app-crypt/shash/shash-0.2.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/shash-0.2.6-r1.ebuild,v 1.1 2004/09/27 00:49:54 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="Generate or check digests or MACs of files"
+HOMEPAGE="http://mcrypt.hellug.gr/shash/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+RDEPEND="virtual/libc
+ >=app-crypt/mhash-0.8.18-r1"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ sys-devel/automake
+ sys-devel/autoconf
+ sys-apps/gawk"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.2.6-manpage-fixes.patch
+}
+
+src_compile() {
+ econf $(use_enable static static-link) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS doc/sample.shashrc doc/FORMAT
+ insinto /usr/share/bash-completion
+ newins ${FILESDIR}/shash.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To enable bash command-line completion for ${PN}, execute"
+ einfo "the following command as root:"
+ einfo " ln -s /usr/share/bash-completion/${PN} /etc/bash_completion.d/"
+ einfo
+}