summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-13 18:18:52 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-13 18:18:52 +0000
commitea717d7b9c7678482af5beb3f472a5ef899dbd30 (patch)
treea5d30863a0769856c3365ffc88d9e381a2fda51e /app-crypt/seahorse
parentVersion bump. Drop old. (diff)
downloadgentoo-2-ea717d7b9c7678482af5beb3f472a5ef899dbd30.tar.gz
gentoo-2-ea717d7b9c7678482af5beb3f472a5ef899dbd30.tar.bz2
gentoo-2-ea717d7b9c7678482af5beb3f472a5ef899dbd30.zip
Version bump with significant UI changes. Drop old.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/ChangeLog9
-rw-r--r--app-crypt/seahorse/files/seahorse-3.4.1-g_clear_object.patch25
-rw-r--r--app-crypt/seahorse/seahorse-3.4.1.ebuild (renamed from app-crypt/seahorse/seahorse-3.2.1.ebuild)21
3 files changed, 44 insertions, 11 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index 1c3a43a6f5de..8371af368e3d 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/seahorse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.154 2012/05/03 20:36:57 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.155 2012/05/13 18:18:52 tetromino Exp $
+
+*seahorse-3.4.1 (13 May 2012)
+
+ 13 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -seahorse-3.2.1.ebuild, +seahorse-3.4.1.ebuild,
+ +files/seahorse-3.4.1-g_clear_object.patch:
+ Version bump with significant UI changes. Drop old.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> seahorse-3.2.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/app-crypt/seahorse/files/seahorse-3.4.1-g_clear_object.patch b/app-crypt/seahorse/files/seahorse-3.4.1-g_clear_object.patch
new file mode 100644
index 000000000000..1ae6915b2ed2
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-3.4.1-g_clear_object.patch
@@ -0,0 +1,25 @@
+From 5286af2304b3a59a2deeb508433c13d96fe2287c Mon Sep 17 00:00:00 2001
+From: Stef Walter <stefw@gnome.org>
+Date: Mon, 30 Apr 2012 20:29:42 +0200
+Subject: [PATCH] Fix typo in finalizing of GPGME keyring
+
+---
+ pgp/seahorse-gpgme-keyring.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/pgp/seahorse-gpgme-keyring.c b/pgp/seahorse-gpgme-keyring.c
+index 79ff39b..579ab09 100644
+--- a/pgp/seahorse-gpgme-keyring.c
++++ b/pgp/seahorse-gpgme-keyring.c
+@@ -859,7 +859,7 @@ seahorse_gpgme_keyring_finalize (GObject *object)
+ {
+ SeahorseGpgmeKeyring *self = SEAHORSE_GPGME_KEYRING (object);
+
+- g_clear_object (self->pv->actions);
++ g_clear_object (&self->pv->actions);
+ g_hash_table_destroy (self->pv->keys);
+
+ /* All monitoring and scheduling should be done */
+--
+1.7.8.6
+
diff --git a/app-crypt/seahorse/seahorse-3.2.1.ebuild b/app-crypt/seahorse/seahorse-3.4.1.ebuild
index 5b8706fb660e..2feb3d1381f0 100644
--- a/app-crypt/seahorse/seahorse-3.2.1.ebuild
+++ b/app-crypt/seahorse/seahorse-3.4.1.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-3.2.1.ebuild,v 1.2 2012/05/03 18:16:39 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-3.4.1.ebuild,v 1.1 2012/05/13 18:18:52 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="A GNOME application for managing encryption keys"
HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
LICENSE="GPL-2"
SLOT="0"
-IUSE="avahi debug doc ldap test"
+IUSE="avahi debug ldap"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
COMMON_DEPEND="
+ >=app-crypt/gcr-3.3.4
>=dev-libs/glib-2.10:2
>=x11-libs/gtk+-2.90.0:3
>=gnome-base/gnome-keyring-3.1.5
@@ -36,9 +37,8 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext
>=app-text/gnome-doc-utils-0.3.2
>=app-text/scrollkeeper-0.3
- virtual/pkgconfig
>=dev-util/intltool-0.35
- doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
"
# Need seahorse-plugins git snapshot
RDEPEND="${COMMON_DEPEND}
@@ -52,19 +52,20 @@ pkg_setup() {
--enable-pkcs11
--disable-static
--disable-scrollkeeper
- --disable-update-mime-database
--enable-hkp
$(use_enable avahi sharing)
$(use_enable debug)
- $(use_enable ldap)
- $(use_enable test tests)"
+ $(use_enable ldap)"
DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
}
src_prepare() {
+ # in next release
+ epatch "${FILESDIR}/${P}-g_clear_object.patch"
+
# FIXME: Do not mess with CFLAGS with USE="debug"
- sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
- -e 's/-Werror//' \
+ sed -e '/CFLAGS="$CFLAGS -g/d' \
+ -e '/CFLAGS="$CFLAGS -O0/d' \
-i configure.ac configure || die "sed 1 failed"
gnome2_src_prepare