summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-06 12:50:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-06 12:50:15 +0000
commit8b36a32975877292ce35efc7d35142dad79d4be3 (patch)
tree11b6646a13c719f9668e022f6a3928953ba615cb /app-crypt/seahorse
parentDrop to ~mips (diff)
downloadgentoo-2-8b36a32975877292ce35efc7d35142dad79d4be3.tar.gz
gentoo-2-8b36a32975877292ce35efc7d35142dad79d4be3.tar.bz2
gentoo-2-8b36a32975877292ce35efc7d35142dad79d4be3.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/ChangeLog8
-rw-r--r--app-crypt/seahorse/files/seahorse-2.32.0-libnotify-0.7.patch26
-rw-r--r--app-crypt/seahorse/seahorse-2.32.0.ebuild10
3 files changed, 38 insertions, 6 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index b178429ccb64..f02cca4a99ae 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/seahorse
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.141 2010/11/24 14:02:43 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.142 2011/02/06 12:50:14 ssuominen Exp $
+
+ 06 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> seahorse-2.32.0.ebuild,
+ +files/seahorse-2.32.0-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
24 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org>
-files/seahorse-2.28.0-as-needed.patch, -seahorse-2.28.1.ebuild:
diff --git a/app-crypt/seahorse/files/seahorse-2.32.0-libnotify-0.7.patch b/app-crypt/seahorse/files/seahorse-2.32.0-libnotify-0.7.patch
new file mode 100644
index 000000000000..1a6b478acf0f
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-2.32.0-libnotify-0.7.patch
@@ -0,0 +1,26 @@
+--- libseahorse/seahorse-notification.c
++++ libseahorse/seahorse-notification.c
+@@ -37,6 +37,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ /* -----------------------------------------------------------------------------
+@@ -231,7 +234,12 @@
+ heading = format_key_text (snotif->heading);
+ message = format_key_text (snotif->message);
+
+- notif = notify_notification_new (heading, message, snotif->icon, attachto);
++ notif = notify_notification_new (heading, message, snotif->icon
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , attachto);
++#endif
+
+ g_free (heading);
+ g_free (message);
diff --git a/app-crypt/seahorse/seahorse-2.32.0.ebuild b/app-crypt/seahorse/seahorse-2.32.0.ebuild
index 923e54a709db..13d5de9969b3 100644
--- a/app-crypt/seahorse/seahorse-2.32.0.ebuild
+++ b/app-crypt/seahorse/seahorse-2.32.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.32.0.ebuild,v 1.1 2010/10/17 19:12:26 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.32.0.ebuild,v 1.2 2011/02/06 12:50:14 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="A GNOME application for managing encryption keys"
HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
@@ -61,12 +61,14 @@ pkg_setup() {
}
src_prepare() {
- gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
# Do not mess with CFLAGS with USE="debug"
sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
-e 's/-Werror//' \
-i configure.in configure || die "sed failed"
+
+ gnome2_src_prepare
}
src_install() {