summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-03-25 23:17:24 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-03-25 23:17:24 +0000
commit2d48aab0219f8931af750311df891bf8af8f11e5 (patch)
treeec35890b6cb2221479ed0cd6160f0fba1b247701 /app-crypt/seahorse
parentversion bump. masked bump. (diff)
downloadgentoo-2-2d48aab0219f8931af750311df891bf8af8f11e5.tar.gz
gentoo-2-2d48aab0219f8931af750311df891bf8af8f11e5.tar.bz2
gentoo-2-2d48aab0219f8931af750311df891bf8af8f11e5.zip
bug 85701
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/ChangeLog7
-rw-r--r--app-crypt/seahorse/files/seahorse-0.7.6-gnome-2.10.patch14
-rw-r--r--app-crypt/seahorse/seahorse-0.7.6.ebuild11
3 files changed, 29 insertions, 3 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index 5c72ecf3942a..b9a51637257c 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/seahorse
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.33 2005/02/28 09:47:35 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.34 2005/03/25 23:17:24 vanquirius Exp $
+
+ 25 Mar 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/seahorse-0.7.6-gnome-2.10.patch, seahorse-0.7.6.ebuild:
+ Fix bug 85701, allow seahorse-0.7.6 to compile with gedit-2.10. Thanks to
+ Marien Zwart <m_zwart@123mail.org> and Alexander M. Turek <me@derrabus.de>.
*seahorse-0.7.6 (28 Feb 2005)
diff --git a/app-crypt/seahorse/files/seahorse-0.7.6-gnome-2.10.patch b/app-crypt/seahorse/files/seahorse-0.7.6-gnome-2.10.patch
new file mode 100644
index 000000000000..f0967ccba822
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-0.7.6-gnome-2.10.patch
@@ -0,0 +1,14 @@
+--- configure.in.orig 2005-03-18 01:38:43.000000000 +0100
++++ configure.in 2005-03-18 01:40:01.000000000 +0100
+@@ -217,8 +217,9 @@
+ echo "enabling gedit plugin..."
+ echo "checking for supported versions of gedit..."
+
+- PKG_CHECK_MODULES(GEDIT, gedit-2.8 >= 2.8.0, ,
+- [PKG_CHECK_MODULES(GEDIT, gedit-2.6 >= 2.6.0)])
++ PKG_CHECK_MODULES(GEDIT, gedit-2.10 >= 2.10.0, ,
++ [PKG_CHECK_MODULES(GEDIT, gedit-2.8 >= 2.8.0, ,
++ [PKG_CHECK_MODULES(GEDIT, gedit-2.6 >= 2.6.0)])])
+
+ AC_SUBST(GEDIT_CFLAGS)
+ fi
diff --git a/app-crypt/seahorse/seahorse-0.7.6.ebuild b/app-crypt/seahorse/seahorse-0.7.6.ebuild
index 5baf595a527e..635e2b3e3af9 100644
--- a/app-crypt/seahorse/seahorse-0.7.6.ebuild
+++ b/app-crypt/seahorse/seahorse-0.7.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.7.6.ebuild,v 1.1 2005/02/28 09:47:35 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.7.6.ebuild,v 1.2 2005/03/25 23:17:24 vanquirius Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="gnome front end to gnupg"
HOMEPAGE="http://seahorse.sourceforge.net/"
@@ -37,7 +37,14 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
IUSE="doc ldap"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-gnome-2.10.patch"
+}
+
src_compile() {
+ autoconf
# note below doesn't work - need to fix
append-ldflags -Wl,-z,now
export LDFLAGS