summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-11 21:51:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-11 21:51:18 +0000
commit22509ad57e424e10e88149be2c35b4be36acd7ba (patch)
tree2604c44f49bdfcf2705de6a40563105ab880c5fa /app-crypt/scl011-bin/scl011-bin-2.06.ebuild
parentUse /lib/udev instead of /$(get_libdir)/udev. The required ones should really... (diff)
downloadgentoo-2-22509ad57e424e10e88149be2c35b4be36acd7ba.tar.gz
gentoo-2-22509ad57e424e10e88149be2c35b4be36acd7ba.tar.bz2
gentoo-2-22509ad57e424e10e88149be2c35b4be36acd7ba.zip
Use udev.eclass and udev_dorules instead of hardcoding wrong path.
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-crypt/scl011-bin/scl011-bin-2.06.ebuild')
-rw-r--r--app-crypt/scl011-bin/scl011-bin-2.06.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-crypt/scl011-bin/scl011-bin-2.06.ebuild b/app-crypt/scl011-bin/scl011-bin-2.06.ebuild
index 13c337326d55..436048ff39f1 100644
--- a/app-crypt/scl011-bin/scl011-bin-2.06.ebuild
+++ b/app-crypt/scl011-bin/scl011-bin-2.06.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/scl011-bin/scl011-bin-2.06.ebuild,v 1.3 2012/07/30 05:02:06 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/scl011-bin/scl011-bin-2.06.ebuild,v 1.4 2012/12/11 21:51:18 ssuominen Exp $
EAPI=4
-inherit multilib toolchain-funcs
+inherit multilib toolchain-funcs udev
DESCRIPTION="pcsc-lite driver for the German identification card (nPA)"
HOMEPAGE="http://www.scmmicro.com/de/products-services/chipkartenleser-terminals/kontaktlos-dual-interface/it-sicherheitskit-basisleser/treiber.html"
@@ -39,6 +39,5 @@ src_install() {
exeinto "${INSTALL_DIR}"/SCL011.bundle/Contents/Linux
doexe "${BASEPATH}"/proprietary/SCL011.bundle/Contents/Linux/libSCL011.so.${PV}
- insinto /$(get_libdir)/udev/rules.d
- doins "${FILESDIR}"/92_pcscd_scl011-bin.rules
+ udev_dorules "${FILESDIR}"/92_pcscd_scl011-bin.rules
}