summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-03-08 03:00:38 +0000
committerJonathan Callen <abcd@gentoo.org>2011-03-08 03:00:38 +0000
commita5f9c30866c1be651ed24e05fe2634f4f2adec71 (patch)
treed6fbb12eecc99be09b6875fa97548eb3ee8b9140 /app-crypt/rotix
parentRemove old. (diff)
downloadgentoo-2-a5f9c30866c1be651ed24e05fe2634f4f2adec71.tar.gz
gentoo-2-a5f9c30866c1be651ed24e05fe2634f4f2adec71.tar.bz2
gentoo-2-a5f9c30866c1be651ed24e05fe2634f4f2adec71.zip
Merge prefix support from prefix overlay
(Portage version: 2.2.0_alpha23_p5/cvs/Linux i686)
Diffstat (limited to 'app-crypt/rotix')
-rw-r--r--app-crypt/rotix/ChangeLog8
-rw-r--r--app-crypt/rotix/files/rotix-0.83-interix.patch15
-rw-r--r--app-crypt/rotix/rotix-0.83.ebuild10
3 files changed, 27 insertions, 6 deletions
diff --git a/app-crypt/rotix/ChangeLog b/app-crypt/rotix/ChangeLog
index 38e0e966c8be..ca7d9a4dba46 100644
--- a/app-crypt/rotix/ChangeLog
+++ b/app-crypt/rotix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/rotix
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/ChangeLog,v 1.13 2010/07/16 23:20:29 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/ChangeLog,v 1.14 2011/03/08 03:00:38 abcd Exp $
+
+ 08 Mar 2011; Jonathan Callen <abcd@gentoo.org> rotix-0.83.ebuild,
+ +files/rotix-0.83-interix.patch:
+ Merge prefix support from prefix overlay
16 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
files/0.83-respect-CFLAGS-and-dont-strip.patch, rotix-0.83.ebuild,
diff --git a/app-crypt/rotix/files/rotix-0.83-interix.patch b/app-crypt/rotix/files/rotix-0.83-interix.patch
new file mode 100644
index 000000000000..b691478582ca
--- /dev/null
+++ b/app-crypt/rotix/files/rotix-0.83-interix.patch
@@ -0,0 +1,15 @@
+--- rotix-0.83.orig/help.c
++++ rotix-0.83/help.c
+@@ -24,8 +24,12 @@
+ * I18N
+ \*/
+
++#if I18N
+ #include <libintl.h>
+ #define _(String) gettext (String)
++#else
++#define _(String) (String)
++#endif
+
+ /*\
+ * This function displays the help-information.
diff --git a/app-crypt/rotix/rotix-0.83.ebuild b/app-crypt/rotix/rotix-0.83.ebuild
index b1fbcdd6310c..ac15355c0104 100644
--- a/app-crypt/rotix/rotix-0.83.ebuild
+++ b/app-crypt/rotix/rotix-0.83.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/rotix-0.83.ebuild,v 1.15 2010/07/16 23:20:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/rotix/rotix-0.83.ebuild,v 1.16 2011/03/08 03:00:38 abcd Exp $
EAPI=2
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Rotix allows you to generate rotational obfuscations."
HOMEPAGE="http://elektron.its.tudelft.nl/~hemmin98/rotix.html"
@@ -11,7 +11,7 @@ SRC_URI="http://elektron.its.tudelft.nl/~hemmin98/rotix_releases/${P}/${P}.tar.b
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ia64 ppc x86"
+KEYWORDS="amd64 ia64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE=""
DEPEND="sys-devel/gettext"
@@ -20,9 +20,11 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${PV}-respect-CFLAGS-and-dont-strip.patch
epatch "${FILESDIR}"/${P}-locale.diff
+ epatch "${FILESDIR}"/${P}-interix.patch
}
src_configure() {
+ use elibc_glibc || append-flags -lintl
econf --i18n=1
}