summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-17 17:13:09 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-17 17:13:09 +0000
commit199e1c70e8ed688147e356d42c4f2043c245a874 (patch)
tree4095ae5cfe8b369a52223994e2ac74e8531d73c1 /app-crypt/qca
parentVersion bump. (diff)
downloadgentoo-2-199e1c70e8ed688147e356d42c4f2043c245a874.tar.gz
gentoo-2-199e1c70e8ed688147e356d42c4f2043c245a874.tar.bz2
gentoo-2-199e1c70e8ed688147e356d42c4f2043c245a874.zip
Fix build with gcc 4.7, bug 412353 by <AlphatPC@gmail.com>.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/ChangeLog8
-rw-r--r--app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch59
-rw-r--r--app-crypt/qca/qca-2.0.3.ebuild23
3 files changed, 76 insertions, 14 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 64bb1cab27a0..a24a7838d2c4 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/qca
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.92 2011/09/14 19:11:21 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.93 2012/04/17 17:13:09 pesa Exp $
+
+ 17 Apr 2012; Davide Pesavento <pesa@gentoo.org>
+ +files/qca-2.0.3+gcc-4.7.patch, qca-2.0.3.ebuild:
+ Fix build with gcc 4.7, bug 412353 by <AlphatPC@gmail.com>.
14 Sep 2011; Fabian Groffen <grobian@gentoo.org> qca-2.0.3.ebuild:
Marked ~ppc-macos, bug #382057
diff --git a/app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch b/app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch
new file mode 100644
index 000000000000..1752dff910ff
--- /dev/null
+++ b/app-crypt/qca/files/qca-2.0.3+gcc-4.7.patch
@@ -0,0 +1,59 @@
+--- trunk/kdesupport/qca/src/botantools/botan/botan/secmem.h 2012/01/14 16:09:19 1273507
++++ trunk/kdesupport/qca/src/botantools/botan/botan/secmem.h 2012/01/14 17:12:15 1273508
+@@ -191,15 +191,15 @@
+ {
+ public:
+ MemoryVector<T>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ MemoryVector(u32bit n = 0) { MemoryRegion<T>::init(false, n); }
+ MemoryVector(const T in[], u32bit n)
+- { MemoryRegion<T>::init(false); set(in, n); }
++ { MemoryRegion<T>::init(false); this->set(in, n); }
+ MemoryVector(const MemoryRegion<T>& in)
+- { MemoryRegion<T>::init(false); set(in); }
++ { MemoryRegion<T>::init(false); this->set(in); }
+ MemoryVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
+- { MemoryRegion<T>::init(false); set(in1); append(in2); }
++ { MemoryRegion<T>::init(false); this->set(in1); append(in2); }
+ };
+
+ /*************************************************
+@@ -210,15 +210,15 @@
+ {
+ public:
+ SecureVector<T>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ SecureVector(u32bit n = 0) { MemoryRegion<T>::init(true, n); }
+ SecureVector(const T in[], u32bit n)
+- { MemoryRegion<T>::init(true); set(in, n); }
++ { MemoryRegion<T>::init(true); this->set(in, n); }
+ SecureVector(const MemoryRegion<T>& in)
+- { MemoryRegion<T>::init(true); set(in); }
++ { MemoryRegion<T>::init(true); this->set(in); }
+ SecureVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
+- { MemoryRegion<T>::init(true); set(in1); append(in2); }
++ { MemoryRegion<T>::init(true); this->set(in1); append(in2); }
+ };
+
+ /*************************************************
+@@ -229,14 +229,14 @@
+ {
+ public:
+ SecureBuffer<T,L>& operator=(const SecureBuffer<T,L>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ SecureBuffer() { MemoryRegion<T>::init(true, L); }
+ SecureBuffer(const T in[], u32bit n)
+ { MemoryRegion<T>::init(true, L); copy(in, n); }
+ private:
+ SecureBuffer<T, L>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+ };
+
+ }
diff --git a/app-crypt/qca/qca-2.0.3.ebuild b/app-crypt/qca/qca-2.0.3.ebuild
index e65264a6d3ce..23cc6ceb02bc 100644
--- a/app-crypt/qca/qca-2.0.3.ebuild
+++ b/app-crypt/qca/qca-2.0.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.3.ebuild,v 1.9 2011/09/14 19:11:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-2.0.3.ebuild,v 1.10 2012/04/17 17:13:09 pesa Exp $
EAPI="3"
+
inherit eutils multilib qt4-r2
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
@@ -20,26 +21,24 @@ RDEPEND="${DEPEND}
!<app-crypt/qca-1.0-r3:0"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.0.2-pcfilespath.patch
+ epatch "${FILESDIR}"/${PN}-2.0.2-pcfilespath.patch \
+ "${FILESDIR}"/${P}+gcc-4.7.patch
if use aqua; then
- sed -i \
- -e "s|QMAKE_LFLAGS_SONAME =.*|QMAKE_LFLAGS_SONAME = -Wl,-install_name,|g" \
- src/src.pro || die "Sed failed."
+ sed -i -e "s|QMAKE_LFLAGS_SONAME =.*|QMAKE_LFLAGS_SONAME = -Wl,-install_name,|g" \
+ src/src.pro || die
fi
}
src_configure() {
- _libdir=$(get_libdir)
-
# Ensure proper rpath
- export EXTRA_QMAKE_RPATH="${EPREFIX}/usr/${_libdir}/qca2"
+ export EXTRA_QMAKE_RPATH="${EPREFIX}/usr/$(get_libdir)/qca2"
ABI= ./configure \
--prefix="${EPREFIX}"/usr \
--qtdir="${EPREFIX}"/usr \
--includedir="${EPREFIX}"/usr/include/qca2 \
- --libdir="${EPREFIX}"/usr/${_libdir}/qca2 \
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/qca2 \
--certstore-path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
--no-separate-debug-info \
--disable-tests \
@@ -55,7 +54,7 @@ src_install() {
dodoc README TODO || die
cat <<-EOF > "${WORKDIR}"/44qca2
- LDPATH="${EPREFIX}/usr/${_libdir}/qca2"
+ LDPATH="${EPREFIX}/usr/$(get_libdir)/qca2"
EOF
doenvd "${WORKDIR}"/44qca2 || die
@@ -69,7 +68,7 @@ src_install() {
fi
# add the proper rpath for packages that do CONFIG += crypto
- echo "QMAKE_RPATHDIR += \"${EPREFIX}/usr/${_libdir}/qca2\"" >> \
+ echo "QMAKE_RPATHDIR += \"${EPREFIX}/usr/$(get_libdir)/qca2\"" >> \
"${D%/}${EPREFIX}/usr/share/qt4/mkspecs/features/crypto.prf" \
|| die "failed to add rpath to crypto.prf"
}