summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-28 08:13:54 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-28 08:13:54 +0000
commit31b5082350894b5d895fd5f4c64e128cd18872b9 (patch)
tree5b32a601bc27c369fbea80981516ccc9aa5f29e4 /app-crypt/pinentry
parentver bump (diff)
downloadgentoo-2-31b5082350894b5d895fd5f4c64e128cd18872b9.tar.gz
gentoo-2-31b5082350894b5d895fd5f4c64e128cd18872b9.tar.bz2
gentoo-2-31b5082350894b5d895fd5f4c64e128cd18872b9.zip
ver bump
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/ChangeLog8
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.7.01
-rw-r--r--app-crypt/pinentry/pinentry-0.7.0.ebuild48
3 files changed, 56 insertions, 1 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 47446931c249..1667613da498 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.6 2003/09/21 23:38:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.7 2004/02/28 08:13:54 vapier Exp $
+
+*pinentry-0.7.0 (28 Feb 2004)
+
+ 28 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage. Cause the ebuild to fall back to ncurses if user
+ has -gtk -qt and -ncurses in USE instead of calling die itself.
*pinentry-0.6.9 (21 Sep 2003)
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.7.0 b/app-crypt/pinentry/files/digest-pinentry-0.7.0
new file mode 100644
index 000000000000..ccf204ae1295
--- /dev/null
+++ b/app-crypt/pinentry/files/digest-pinentry-0.7.0
@@ -0,0 +1 @@
+MD5 50275634b3481a231f3319e062a0bd87 pinentry-0.7.0.tar.gz 344261
diff --git a/app-crypt/pinentry/pinentry-0.7.0.ebuild b/app-crypt/pinentry/pinentry-0.7.0.ebuild
new file mode 100644
index 000000000000..f7075b5a456a
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.0.ebuild,v 1.1 2004/02/28 08:13:54 vapier Exp $
+
+DESCRIPTION="collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/pinentry/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="qt gtk ncurses"
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ ncurses? ( sys-libs/ncurses )
+ qt? ( x11-libs/qt )
+ !gtk? ( !qt? ( !ncurses? ( sys-libs/ncurses ) ) )"
+
+src_compile() {
+ local myconf=""
+ if ! use qt && ! use gtk && ! use ncurses ; then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ fi
+ econf \
+ `use_enable qt pinentry-qt` \
+ `use_enable gtk pinentry-gtk` \
+ `use_enable ncurses pinentry-curses` \
+ `use_enable ncurses fallback-curses` \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ # The other two pinentries don't spit out an insecure memory warning when
+ # not suid root, and gtk refuses to start if pinentry-gtk is suid root.
+ fperms +s /usr/bin/pinentry-qt
+}
+
+pkg_postinst() {
+ einfo "pinentry-qt is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}