summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2009-01-06 21:16:23 +0000
committerSven Wegener <swegener@gentoo.org>2009-01-06 21:16:23 +0000
commitec54a22ce8981d47427ec0cbe5397780ea167fa1 (patch)
tree835b0e4037f562ae82a76f9bf32e2d3b74e0dd82 /app-crypt/pinentry/pinentry-0.7.3.ebuild
parentUse external notify-sharp, now that it's in tree. (diff)
downloadgentoo-2-ec54a22ce8981d47427ec0cbe5397780ea167fa1.tar.gz
gentoo-2-ec54a22ce8981d47427ec0cbe5397780ea167fa1.tar.bz2
gentoo-2-ec54a22ce8981d47427ec0cbe5397780ea167fa1.zip
Cleanup.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-crypt/pinentry/pinentry-0.7.3.ebuild')
-rw-r--r--app-crypt/pinentry/pinentry-0.7.3.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/app-crypt/pinentry/pinentry-0.7.3.ebuild b/app-crypt/pinentry/pinentry-0.7.3.ebuild
deleted file mode 100644
index 7f4dbbb28dd7..000000000000
--- a/app-crypt/pinentry/pinentry-0.7.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.3.ebuild,v 1.11 2008/07/27 19:18:05 carlo Exp $
-
-#WANT_AUTOCONF="2.5"
-#WANT_AUTOMAKE="1.9"
-
-EAPI=1
-
-inherit qt3 multilib eutils autotools
-
-DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
-HOMEPAGE="http://www.gnupg.org/aegypten/"
-SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="gtk ncurses qt3 caps"
-
-DEPEND="gtk? ( =x11-libs/gtk+-2* )
- ncurses? ( sys-libs/ncurses )
- qt3? ( x11-libs/qt:3 )
- !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )
- caps? ( sys-libs/libcap )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/0.7.2-libcap.patch"
- epatch "${FILESDIR}/0.7.2-info.patch"
- epatch "${FILESDIR}/${PN}-0.7.2-grab.patch"
- epatch "${FILESDIR}/${PN}-gmem.patch"
-
- AT_M4DIR="m4" eautoreconf
-}
-
-src_compile() {
- local myconf=""
-
- if ! ( use qt3 || use gtk || use ncurses )
- then
- myconf="--enable-pinentry-curses --enable-fallback-curses"
- fi
-
- # Issues finding qt on multilib systems
- export QTLIB="${QTDIR}/$(get_libdir)"
-
- econf \
- --disable-dependency-tracking \
- --enable-maintainer-mode \
- --disable-pinentry-gtk \
- $(use_enable gtk pinentry-gtk2) \
- $(use_enable qt3 pinentry-qt) \
- $(use_enable ncurses pinentry-curses) \
- $(use_enable ncurses fallback-curses) \
- $(use_with caps libcap) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
-}
-
-pkg_postinst() {
- elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
- elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
- elog "The soft resource limit for memory locking specifies the limit an"
- elog "unprivileged process may lock into memory. You can also use POSIX"
- elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
- elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
- elog "your users."
-}