summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:32:48 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:32:48 +0000
commit4014937c1dd1ecb1b3290af160d4e77a946c9543 (patch)
treef2b083818590d150fdc234441a0058bd6cb7f895 /app-crypt/kth-krb
parentinherit eutils (Manifest recommit) (diff)
downloadgentoo-2-4014937c1dd1ecb1b3290af160d4e77a946c9543.tar.gz
gentoo-2-4014937c1dd1ecb1b3290af160d4e77a946c9543.tar.bz2
gentoo-2-4014937c1dd1ecb1b3290af160d4e77a946c9543.zip
add inherit eutils
Diffstat (limited to 'app-crypt/kth-krb')
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.1.ebuild6
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.2-r1.ebuild16
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.2.ebuild6
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.ebuild6
4 files changed, 20 insertions, 14 deletions
diff --git a/app-crypt/kth-krb/kth-krb-1.2.1.ebuild b/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
index 68584915a63d..beed7cafe557 100644
--- a/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.1.ebuild,v 1.8 2003/08/05 18:16:56 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.1.ebuild,v 1.9 2004/04/06 03:30:48 vapier Exp $
+
+inherit eutils
DESCRIPTION="Kerberos 4 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
diff --git a/app-crypt/kth-krb/kth-krb-1.2.2-r1.ebuild b/app-crypt/kth-krb/kth-krb-1.2.2-r1.ebuild
index c07211934a57..a3315e8c0e25 100644
--- a/app-crypt/kth-krb/kth-krb-1.2.2-r1.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.2.2-r1.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.2-r1.ebuild,v 1.7 2004/03/30 14:54:12 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.2-r1.ebuild,v 1.8 2004/04/06 03:31:30 vapier Exp $
+
+inherit eutils
DESCRIPTION="Kerberos 4 implementation from KTH"
-SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha ia64 amd64"
IUSE="ssl afs"
@@ -27,10 +29,8 @@ src_compile() {
use afs || myconf="${myconf} --without-afs-support"
- ./configure \
- --host=${CHOST} \
+ econf \
--prefix=/usr/athena \
- --sysconfdir=/etc \
${myconf} || die
make || die
@@ -42,7 +42,7 @@ src_install() {
install || die
# Doesn't get install otherwise (for some reason, look into this).
- if [ "`use ssl`" ] ; then
+ if use ssl ; then
cd ${S}/lib/des
make prefix=${D}/usr/athena \
@@ -54,7 +54,7 @@ src_install() {
dodir /etc/env.d
cp ${FILESDIR}/02kth-krb ${D}/etc/env.d
- dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+ dodoc ChangeLog README NEWS PROBLEMS TODO
# rphillips: cludge to fix the paths
einfo "Fixing /usr/athena/lib library paths"
diff --git a/app-crypt/kth-krb/kth-krb-1.2.2.ebuild b/app-crypt/kth-krb/kth-krb-1.2.2.ebuild
index ad637ff86700..bf2c0c7cb717 100644
--- a/app-crypt/kth-krb/kth-krb-1.2.2.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.2.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.2.ebuild,v 1.1 2003/08/05 18:16:56 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.2.ebuild,v 1.2 2004/04/06 03:31:40 vapier Exp $
+
+inherit eutils
DESCRIPTION="Kerberos 4 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
diff --git a/app-crypt/kth-krb/kth-krb-1.2.ebuild b/app-crypt/kth-krb/kth-krb-1.2.ebuild
index 8f01e907fee6..d10a0c95b101 100644
--- a/app-crypt/kth-krb/kth-krb-1.2.ebuild
+++ b/app-crypt/kth-krb/kth-krb-1.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.ebuild,v 1.6 2003/08/05 18:16:56 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.ebuild,v 1.7 2004/04/06 03:31:48 vapier Exp $
+
+inherit eutils
DESCRIPTION="Kerberos 4 implementation from KTH"
SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"