summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2005-09-18 14:11:09 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2005-09-18 14:11:09 +0000
commit0af2549553e481dbc85c70f6f30dfec25b4921bd (patch)
treeb17affb5c89a3692bd312a1a9ae5ddc5e90e6532 /app-crypt/heimdal
parentfix for -r5 conf file installed in -r4 ebuild (diff)
downloadgentoo-2-0af2549553e481dbc85c70f6f30dfec25b4921bd.tar.gz
gentoo-2-0af2549553e481dbc85c70f6f30dfec25b4921bd.tar.bz2
gentoo-2-0af2549553e481dbc85c70f6f30dfec25b4921bd.zip
LIBS should contain -lpthread instead of -pthread, fixes bug #103447
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-crypt/heimdal')
-rw-r--r--app-crypt/heimdal/ChangeLog8
-rw-r--r--app-crypt/heimdal/Manifest5
-rw-r--r--app-crypt/heimdal/files/digest-heimdal-0.7.1-r12
-rw-r--r--app-crypt/heimdal/heimdal-0.7.1-r1.ebuild157
4 files changed, 170 insertions, 2 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 7eb91dba72d7..fc398d7e9eab 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/heimdal
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.85 2005/09/15 21:16:29 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.86 2005/09/18 14:11:09 stefaan Exp $
+
+*heimdal-0.7.1-r1 (18 Sep 2005)
+
+ 18 Sep 2005; Stefaan De Roeck <stefaan@gentoo.org>
+ +heimdal-0.7.1-r1.ebuild:
+ LIBS should contain -lpthread instead of -pthread, fixes bug #103447
*heimdal-0.7.1 (15 Sep 2005)
diff --git a/app-crypt/heimdal/Manifest b/app-crypt/heimdal/Manifest
index 26d7fbef21c9..f52691696d03 100644
--- a/app-crypt/heimdal/Manifest
+++ b/app-crypt/heimdal/Manifest
@@ -1,10 +1,13 @@
MD5 6871bcf00d93a0155ce36848d3813011 ChangeLog 14315
MD5 56488f7617b94fd2ee8198c717b9f054 heimdal-0.6.5.ebuild 3783
-MD5 5867e9c2e360d115efb343ccce72525e heimdal-0.7.1.ebuild 3985
MD5 6c9cbfc951ebeca1a88d8722de4dde80 metadata.xml 231
+MD5 5867e9c2e360d115efb343ccce72525e heimdal-0.7.1.ebuild 3985
MD5 e153d71a10d081d1fbe2c26878b72bd6 heimdal-0.7.ebuild 3971
MD5 41f88020389386f6f4909b65cab429d1 heimdal-0.7-r1.ebuild 3996
+MD5 15fb6fec8bd0b353e135b89f85273d2a heimdal-0.7.1-r1.ebuild 3832
MD5 48691f4945f1b98de5fe5d5e4f48ef8b files/digest-heimdal-0.6.5 147
MD5 b067bdf59f1afc68d236c02de0e45c95 files/digest-heimdal-0.7 145
MD5 a669a98f81bb481f75418fdcdf6cd959 files/digest-heimdal-0.7-r1 145
MD5 a30aad19eeaf428725050acaafaf61ee files/digest-heimdal-0.7.1 147
+MD5 1b8665b771c4eb6b56ea8582c96e56e3 files/pthread-fix.patch 296
+MD5 7e46678d57392f8cfcf60114e30768e4 files/digest-heimdal-0.7.1-r1 149
diff --git a/app-crypt/heimdal/files/digest-heimdal-0.7.1-r1 b/app-crypt/heimdal/files/digest-heimdal-0.7.1-r1
new file mode 100644
index 000000000000..dc9311da2c01
--- /dev/null
+++ b/app-crypt/heimdal/files/digest-heimdal-0.7.1-r1
@@ -0,0 +1,2 @@
+MD5 70504c824cb0437e6fae2b866f9d2ed4 heimdal-0.7.1.tar.gz 4515175
+MD5 384f7c0b5e2a86b74d8c5d0eddb4e9b2 heimdal-0.7.1-gentoo-patches-0.1.tar.bz2 4876
diff --git a/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild b/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..d787d9121d06
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.7.1-r1.ebuild,v 1.1 2005/09/18 14:11:09 stefaan Exp $
+
+inherit libtool eutils virtualx toolchain-funcs
+
+PATCHVER=0.1
+PATCH_P=${P}-gentoo-patches-${PATCHVER}
+
+DESCRIPTION="Kerberos 5 implementation from KTH"
+HOMEPAGE="http://www.pdc.kth.se/heimdal/"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/heimdal/src/${P}.tar.gz
+ mirror://gentoo/${PATCH_P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sparc ~x86"
+IUSE="ssl berkdb ipv6 krb4 ldap X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ berkdb? ( sys-libs/db )
+ krb4? ( >=app-crypt/kth-krb-1.2.2-r2 )
+ ldap? ( net-nds/openldap )
+ sys-libs/ss
+ sys-libs/com_err
+ sys-libs/cracklib
+ !virtual/krb5"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/gcc
+ >=sys-apps/sed-4"
+
+PROVIDE="virtual/krb5"
+
+GENTOODIR=${WORKDIR}/gentoo
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ EPATCH_SUFFIX="patch" \
+ epatch ${GENTOODIR}/patches
+}
+
+src_compile() {
+ elibtoolize
+
+ aclocal -I cf || die "configure problem"
+ autoheader || die "configure problem"
+ automake -a || die "configure problem"
+ autoconf || die "configure problem"
+
+ local myconf=""
+
+ use krb4 \
+ && myconf="${myconf} --with-krb4-config=/usr/athena/bin/krb4-config"
+
+ use ldap && myconf="${myconf} --with-openldap=/usr"
+
+ libtoolize --copy --force
+
+ econf \
+ $(use_with ipv6) \
+ $(use_with berkdb berkeley-db) \
+ $(use_with ssl openssl) \
+ $(use_with X x) \
+ $(use_with krb4) \
+ --enable-shared \
+ --includedir=/usr/include/heimdal \
+ --libexecdir=/usr/sbin \
+ ${myconf} || die "econf failed"
+
+ emake || die
+
+ # Compile the added password checker:
+ cd ${S}/lib/kadm5
+ tc-export CC
+ ${CC} -shared -fPIC ${CFLAGS} -I${S}/include \
+ -o sample_passwd_check.so sample_passwd_check.c -lcrack || \
+ die "Failed to compile password checker"
+}
+
+src_test() {
+ addpredict /proc/fs/openafs/afs_ioctl
+ addpredict /proc/fs/nnpfs/afs_ioctl
+
+ if use X ; then
+ KRB5_CONFIG=${S}/krb5.conf Xmake check || die
+ else
+ KRB5_CONFIG=${S}/krb5.conf make check || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dolib ${S}/lib/kadm5/sample_passwd_check.so
+
+ dodoc ChangeLog README NEWS TODO
+
+ # Begin client rename and install
+ for i in {telnetd,ftpd}
+ do
+ mv ${D}/usr/share/man/man8/{,k}${i}.8
+ mv ${D}/usr/sbin/{,k}${i}
+ done
+
+ for i in {rcp,rsh,telnet,ftp,su,login}
+ do
+ mv ${D}/usr/share/man/man1/{,k}${i}.1
+ mv ${D}/usr/bin/{,k}${i}
+ done
+
+ # Create symlinks for the includes
+ dosym heimdal /usr/include/gssapi
+ dosym heimdal/krb5-types.h /usr/include/krb5-types.h
+ dosym heimdal/krb5.h /usr/include/krb5.h
+ dosym heimdal/asn1_err.h /usr/include/asn1_err.h
+ dosym heimdal/krb5_asn1.h /usr/include/krb5_asn1.h
+ dosym heimdal/krb5_err.h /usr/include/krb5_err.h
+ dosym heimdal/heim_err.h /usr/include/heim_err.h
+ dosym heimdal/k524_err.h /usr/include/k524_err.h
+ dosym heimdal/krb5-protos.h /usr/include/krb5-protos.h
+
+ doinitd ${GENTOODIR}/configs/heimdal-kdc
+ doinitd ${GENTOODIR}/configs/heimdal-kadmind
+ doinitd ${GENTOODIR}/configs/heimdal-kpasswdd
+
+ insinto /etc
+ doins ${GENTOODIR}/configs/krb5.conf
+
+ sed -i "s:lib:$(get_libdir):" ${D}/etc/krb5.conf
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins ${GENTOODIR}/configs/krb5-kdc.schema
+ fi
+
+ # default database dir
+ keepdir /var/heimdal
+}
+
+pkg_postinst() {
+ echo
+ ewarn "DANGER WILL ROBINSON!"
+ einfo "There has been a change in the libgssapi shared library version"
+ einfo "This means that _EVERYTHING_ that linked against libgssapi.so.1"
+ einfo "will now be broken. Examples include, but may not be limited to:"
+ einfo "samba, mozilla, mozilla-firefox, subversion and neon, cvs, "
+ einfo "evolution-data-server, and gnome-vfs. As a consequence:"
+ ewarn "PLEASE PLEASE PLEASE PLEASE PLEASE run revdep-rebuild right now"
+ epause
+ ebeep 10
+ echo
+}
+