summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-11 19:18:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-11 19:18:50 +0000
commitf59593fa47b5022038c46eac3a19684276a5169e (patch)
treef18ab9daa98ef7679e865bea1be924f7c87dba18 /app-crypt/gpgme
parentFixed multilib issue and install icons, bug #299769, thank Justin Lecher (jle... (diff)
downloadgentoo-2-f59593fa47b5022038c46eac3a19684276a5169e.tar.gz
gentoo-2-f59593fa47b5022038c46eac3a19684276a5169e.tar.bz2
gentoo-2-f59593fa47b5022038c46eac3a19684276a5169e.zip
Version bump.
(Portage version: 15192-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/gpgme')
-rw-r--r--app-crypt/gpgme/ChangeLog10
-rw-r--r--app-crypt/gpgme/gpgme-1.3.0.ebuild46
2 files changed, 54 insertions, 2 deletions
diff --git a/app-crypt/gpgme/ChangeLog b/app-crypt/gpgme/ChangeLog
index 82dc464b1768..a89e01156bfe 100644
--- a/app-crypt/gpgme/ChangeLog
+++ b/app-crypt/gpgme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gpgme
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.171 2009/12/27 17:10:30 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.172 2010/01/11 19:18:50 arfrever Exp $
+
+*gpgme-1.3.0 (11 Jan 2010)
+
+ 11 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +gpgme-1.3.0.ebuild:
+ Version bump.
27 Dec 2009; Raúl Porcel <armin76@gentoo.org> gpgme-1.1.8-r1.ebuild,
gpgme-1.2.0.ebuild:
diff --git a/app-crypt/gpgme/gpgme-1.3.0.ebuild b/app-crypt/gpgme/gpgme-1.3.0.ebuild
new file mode 100644
index 000000000000..bd5188fb3469
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.3.0.ebuild,v 1.1 2010/01/11 19:18:50 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils libtool
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="common-lisp pth"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/libassuan-1.1.0
+ >=dev-libs/libgpg-error-1.4
+ pth? ( >=dev-libs/pth-1.2 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.1.8-et_EE.patch"
+
+ # Call elibtoolize to get sane .so versioning on FreeBSD.
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --includedir=/usr/include/gpgme \
+ --with-gpg=/usr/bin/gpg \
+ --with-gpgsm=/usr/bin/gpgsm \
+ $(use_with pth)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ if ! use common-lisp; then
+ rm -fr "${D}usr/share/common-lisp"
+ fi
+}