summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2002-12-17 00:34:18 +0000
committerJ Robert Ray <jrray@gentoo.org>2002-12-17 00:34:18 +0000
commit521a0802e8994b17cdcbf66fd611a3408b42cdb5 (patch)
treef4ea1c369b36cf74eb663ee1520c47cfc19a6d8d /app-crypt/gnupg
parentNew version (diff)
downloadgentoo-2-521a0802e8994b17cdcbf66fd611a3408b42cdb5.tar.gz
gentoo-2-521a0802e8994b17cdcbf66fd611a3408b42cdb5.tar.bz2
gentoo-2-521a0802e8994b17cdcbf66fd611a3408b42cdb5.zip
Don't specify fixed photo viewer
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/ChangeLog9
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.2.1-r11
-rw-r--r--app-crypt/gnupg/gnupg-1.2.1-r1.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index a81fe49ec1aa..2bbd7ff44edf 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.15 2002/12/16 22:48:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.16 2002/12/17 00:34:18 jrray Exp $
+
+*gnupg-1.2.1-r1 (16 Dec 2002)
+
+ 16 Dec 2002; J Robert Ray <jrray@gentoo.org> gnupg-1.2.1-r1.ebuild :
+ Don't specify fixed photo viewer, defaults to using xloadimage anyway, but
+ fixing it to 'xview' makes it get called with the wrong args and fail.
+ Closes bug 12017.
16 Dec 2002; Aron Griffis <agriffis@gentoo.org> gnupg-1.2.1.ebuild :
Added ~alpha to KEYWORDS
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.2.1-r1 b/app-crypt/gnupg/files/digest-gnupg-1.2.1-r1
new file mode 100644
index 000000000000..f2c49a1b4492
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.2.1-r1
@@ -0,0 +1 @@
+MD5 e63add33e010b4224ba0841b21fe0bfe gnupg-1.2.1.tar.bz2 1889079
diff --git a/app-crypt/gnupg/gnupg-1.2.1-r1.ebuild b/app-crypt/gnupg/gnupg-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..87a6d75393a5
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.1-r1.ebuild,v 1.1 2002/12/17 00:34:18 jrray Exp $
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ppc sparc ~alpha"
+IUSE="X zlib ldap nls"
+
+DEPEND="sys-devel/perl
+ X? ( x11-misc/xloadimage )
+ zlib? ( sys-libs/zlib )
+ ldap? ( net-nds/openldap )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ldap || myconf="${myconf} --disable-ldap"
+ use zlib || myconf="${myconf} --with-included-zlib"
+ use X || myconf="${myconf} --disable-photo-viewers"
+
+ #Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if [ "${ARCH}" != "sparc" -a "${ARCH}" != "sparc64" ]; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf}
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog OpenPGP
+ docinto sgml
+ dodoc gpg.sgml gpgv.sgml
+ dohtml faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod +s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}