summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2014-08-30 13:04:17 +0000
committerKristian Fiskerstrand <k_f@gentoo.org>2014-08-30 13:04:17 +0000
commite5243983b5c0e3b7d059aa2bbeb39b56ba2f9019 (patch)
tree98b453a72ced258c2bc1a47f18ef2181747a8892 /app-crypt/ekeyd
parentEnable Python 3.4 on the release version. (diff)
downloadgentoo-2-e5243983b5c0e3b7d059aa2bbeb39b56ba2f9019.tar.gz
gentoo-2-e5243983b5c0e3b7d059aa2bbeb39b56ba2f9019.tar.bz2
gentoo-2-e5243983b5c0e3b7d059aa2bbeb39b56ba2f9019.zip
Version bump: Bringing in 1.1.5 from overlay
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xFC3B17DE05E136A0!)
Diffstat (limited to 'app-crypt/ekeyd')
-rw-r--r--app-crypt/ekeyd/ChangeLog11
-rw-r--r--app-crypt/ekeyd/ekeyd-1.1.5.ebuild165
-rw-r--r--app-crypt/ekeyd/files/90-ekeyd.rules16
-rw-r--r--app-crypt/ekeyd/files/ekeyd-1.1.5-const_char_usage.patch32
-rw-r--r--app-crypt/ekeyd/files/ekeyd-1.1.5-enoent.patch23
-rw-r--r--app-crypt/ekeyd/files/ekeyd-1.1.5-misc.patch50
-rw-r--r--app-crypt/ekeyd/files/ekeyd-1.1.5-path-fixes.patch49
-rw-r--r--app-crypt/ekeyd/files/ekeyd-1.1.5-remove-werror.patch29
-rw-r--r--app-crypt/ekeyd/files/ekeyd-1.1.5-udev-rule.patch36
-rw-r--r--app-crypt/ekeyd/files/ekeyd.service8
10 files changed, 418 insertions, 1 deletions
diff --git a/app-crypt/ekeyd/ChangeLog b/app-crypt/ekeyd/ChangeLog
index 0892d42193da..dfc5907b1d0f 100644
--- a/app-crypt/ekeyd/ChangeLog
+++ b/app-crypt/ekeyd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-crypt/ekeyd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/ekeyd/ChangeLog,v 1.33 2014/08/30 12:29:19 k_f Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ekeyd/ChangeLog,v 1.34 2014/08/30 13:04:17 k_f Exp $
+
+*ekeyd-1.1.5 (30 Aug 2014)
+
+ 30 Aug 2014; Kristian Fiskerstrand <k_f@gentoo.org> +ekeyd-1.1.5.ebuild,
+ +files/90-ekeyd.rules, +files/ekeyd-1.1.5-const_char_usage.patch,
+ +files/ekeyd-1.1.5-enoent.patch, +files/ekeyd-1.1.5-misc.patch,
+ +files/ekeyd-1.1.5-path-fixes.patch, +files/ekeyd-1.1.5-remove-werror.patch,
+ +files/ekeyd-1.1.5-udev-rule.patch, +files/ekeyd.service:
+ Version bump: Bringing in 1.1.5 from overlay
30 Aug 2014; Kristian Fiskerstrand <k_f@gentoo.org> metadata.xml:
Adding myself as maintainer for this maintainer-needed package
diff --git a/app-crypt/ekeyd/ekeyd-1.1.5.ebuild b/app-crypt/ekeyd/ekeyd-1.1.5.ebuild
new file mode 100644
index 000000000000..c22e2be8f466
--- /dev/null
+++ b/app-crypt/ekeyd/ekeyd-1.1.5.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ekeyd/ekeyd-1.1.5.ebuild,v 1.1 2014/08/30 13:04:17 k_f Exp $
+
+EAPI=4
+
+inherit eutils multilib linux-info toolchain-funcs udev systemd
+
+DESCRIPTION="Entropy Key userspace daemon"
+HOMEPAGE="http://www.entropykey.co.uk/"
+SRC_URI="mirror://ubuntu/pool/universe/e/ekeyd/ekeyd_${PV}.orig.tar.gz"
+
+LICENSE="MIT GPL-2" # GPL-2 (only) for init script
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kernel_linux munin minimal"
+REQUIRED_USE="minimal? ( !munin )"
+
+EKEYD_RDEPEND="dev-lang/lua"
+EKEYD_DEPEND="${EKEYD_RDEPEND}"
+EKEYD_RDEPEND="${EKEYD_RDEPEND}
+ dev-lua/luasocket
+ kernel_linux? ( virtual/udev )
+ munin? ( net-analyzer/munin )"
+
+RDEPEND="!minimal? ( ${EKEYD_RDEPEND} )
+ !app-crypt/ekey-egd-linux
+ sys-apps/openrc"
+DEPEND="!minimal? ( ${EKEYD_DEPEND} )"
+
+CONFIG_CHECK="~USB_ACM"
+
+pkg_setup() {
+ if ! use minimal && use kernel_linux && ! use usb && linux_config_exists; then
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-const_char_usage.patch";
+ epatch "${FILESDIR}/${P}-enoent.patch";
+ epatch "${FILESDIR}/${P}-path-fixes.patch";
+ epatch "${FILESDIR}/${P}-udev-rule.patch";
+ epatch "${FILESDIR}/${P}-remove-werror.patch";
+ epatch "${FILESDIR}/${P}-misc.patch";
+}
+
+src_compile() {
+ local osname
+
+ # Override automatic detection: upstream provides this with uname,
+ # we don't like using uname.
+ case ${CHOST} in
+ *-linux-*)
+ osname=linux;;
+ *-freebsd*)
+ osname=freebsd;;
+ *-kfrebsd-gnu)
+ osname=gnukfreebsd;;
+ *-openbsd*)
+ osname=openbsd;;
+ *)
+ die "Unsupported operating system!"
+ ;;
+ esac
+
+ # We don't slot LUA so we don't really need to have the variables
+ # set at all.
+ emake -C host \
+ CC="$(tc-getCC)" \
+ LUA_V= LUA_INC= \
+ OSNAME=${osname} \
+ OPT="${CFLAGS}" \
+ BUILD_ULUSBD=no \
+ $(use minimal && echo egd-linux)
+}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe host/egd-linux ekey-egd-linux
+ newman host/egd-linux.8 ekey-egd-linux.8
+
+ newconfd "${FILESDIR}"/ekey-egd-linux.conf.2 ekey-egd-linux
+ newinitd "${FILESDIR}"/ekey-egd-linux.init.2 ekey-egd-linux
+
+ dodoc doc/* AUTHORS ChangeLog THANKS
+
+ use minimal && return
+ # from here on, install everything that is not part of the minimal
+ # support.
+
+ emake -C host \
+ DESTDIR="${D}" \
+ MANZCMD=cat MANZEXT= \
+ install-ekeyd
+
+ # We move the daemons around to avoid polluting the available
+ # commands.
+ dodir /usr/libexec
+ mv "${D}"/usr/sbin/ekey*d "${D}"/usr/libexec
+
+ systemd_dounit "${FILESDIR}/ekeyd.service"
+
+ newinitd "${FILESDIR}"/${PN}.init.2 ${PN}
+
+ if use kernel_linux; then
+ local rules="${FILESDIR}/90-ekeyd.rules"
+ udev_newrules ${rules} 90-${PN}.rules
+ fi
+
+ if use munin; then
+ exeinto /usr/libexec/munin/plugins
+ doexe munin/ekeyd_stat_
+
+ insinto /etc/munin/plugin-conf.d
+ newins munin/plugin-conf.d_ekeyd ekeyd
+ fi
+}
+
+pkg_postinst() {
+ elog "${CATEGORY}/${PN} now install also the EGD client service ekey-egd-linux."
+ elog "To use this service, you need enable EGDTCPSocket for the ekeyd service"
+ elog "managing the key(s)."
+ elog ""
+ elog "The daemon will send more entropy to the kernel once the available pool"
+ elog "falls below the value set in the kernel.random.write_wakeup_threshold"
+ elog "sysctl entry."
+ elog ""
+ ewarn "Since version 1.1.4-r1, ekey-egd-linux will *not* set the watermark for"
+ ewarn "you, instead you'll have to configure the sysctl in /etc/sysctl.conf"
+
+ use minimal && return
+ # from here on, document everything that is not part of the minimal
+ # support.
+
+ elog ""
+ elog "To make use of your EntropyKey, make sure to execute ekey-rekey"
+ elog "the first time, and then start the ekeyd service."
+ elog ""
+ elog "By default ekeyd will feed the entropy directly to the kernel's pool;"
+ elog "if your system has jumps in load average, you might prefer using the"
+ elog "EGD compatibility mode, by enabling EGDTCPSocket for ekeyd and then"
+ elog "starting the ekey-egd-linux service."
+ elog ""
+ elog "The same applies if you intend to provide entropy for multiple hosts"
+ elog "over the network. If you want to have the ekey-egd-linux service on"
+ elog "other hosts, you can enable the 'minimal' USE flag."
+ elog ""
+ elog "The service supports multiplexing if you wish to use multiple"
+ elog "keys, just symlink /etc/init.d/ekeyd → /etc/init.d/ekeyd.identifier"
+ elog "and it'll be looking for /etc/entropykey/identifier.conf"
+ elog ""
+
+ if use kernel_linux; then
+ elog "Some versions of Linux have a faulty CDC ACM driver that stops"
+ elog "EntropyKey from working properly; please check the compatibility"
+ elog "table at http://www.entropykey.co.uk/download/"
+ else
+ elog "Make sure your operating system supports the CDC ACM driver"
+ elog "or otherwise you won't be able to use the EntropyKey."
+ fi
+ elog ""
+ elog "If you're unsure about the working state of the CDC ACM driver"
+ elog "enable the usb USE flag and use the userland USB daemon"
+}
diff --git a/app-crypt/ekeyd/files/90-ekeyd.rules b/app-crypt/ekeyd/files/90-ekeyd.rules
new file mode 100644
index 000000000000..2532ba852efc
--- /dev/null
+++ b/app-crypt/ekeyd/files/90-ekeyd.rules
@@ -0,0 +1,16 @@
+# Entropy key udev rules
+#
+# Centos/RHEL 6 rules for udev version 147
+#
+# These rules create devices under /dev/entropykey/<serialnumber>
+#
+# Copyright 2011-2014 Simtec Electronics
+#
+# For licence terms refer to the COPYING file distributed with the source.
+
+ACTION=="add", SUBSYSTEM=="tty", ENV{ID_VENDOR_ID}=="20df", ENV{ID_MODEL_ID}=="0001", SYMLINK+="entropykey/$env{ID_SERIAL_SHORT}"
+
+ACTION=="add", SUBSYSTEM=="tty", ENV{ID_VENDOR_ID}=="20df", ENV{ID_MODEL_ID}=="0001", RUN+="/usr/sbin/ekeydctl add /dev/entropykey/$env{ID_SERIAL_SHORT}"
+
+ACTION=="remove", SUBSYSTEM=="tty", ENV{ID_VENDOR_ID}=="20df", ENV{ID_MODEL_ID}=="0001", RUN+="/usr/sbin/ekeydctl remove $env{ID_SERIAL_SHORT}"
+
diff --git a/app-crypt/ekeyd/files/ekeyd-1.1.5-const_char_usage.patch b/app-crypt/ekeyd/files/ekeyd-1.1.5-const_char_usage.patch
new file mode 100644
index 000000000000..81ad8e6a5337
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd-1.1.5-const_char_usage.patch
@@ -0,0 +1,32 @@
+# HG changeset patch
+# User kristianf
+# Date 1382916823 -3600
+# Mon Oct 28 00:33:43 2013 +0100
+# Node ID 0d99149615ec5ec70a6d03c685291ddc55babff6
+# Parent fd192324ff9ae4c4c92cdb9c27f5ae100da136a6
+Rewrite static const char *usage
+
+diff -r fd192324ff9a -r 0d99149615ec host/ekey-setkey.c
+--- a/host/ekey-setkey.c Mon Oct 28 00:31:59 2013 +0100
++++ b/host/ekey-setkey.c Mon Oct 28 00:33:43 2013 +0100
+@@ -79,7 +79,7 @@
+ return mac;
+ }
+
+-static const char *usage =
++static const char usage[] =
+ "This is a low level tool. You probably wanted to use ekey-rekey instead.\n\n"
+ "Usage: %s [-d] [-h] [-n] [-f <keyring>] [-m <master>]\n"
+ " [-s <serial>] <path>\n"
+diff -r fd192324ff9a -r 0d99149615ec host/ekeyd.c
+--- a/host/ekeyd.c Mon Oct 28 00:31:59 2013 +0100
++++ b/host/ekeyd.c Mon Oct 28 00:33:43 2013 +0100
+@@ -209,7 +209,7 @@
+ return (output_stream != NULL);
+ }
+
+-static const char *usage=
++static const char usage[] =
+ "Usage: %s [-f <configfile>] [-p <pidfile>] [-v] [-h]\n"
+ "Entropy Key Daemon\n\n"
+ "\t-f Read configuration from configfile\n"
diff --git a/app-crypt/ekeyd/files/ekeyd-1.1.5-enoent.patch b/app-crypt/ekeyd/files/ekeyd-1.1.5-enoent.patch
new file mode 100644
index 000000000000..2d4cccbafafa
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd-1.1.5-enoent.patch
@@ -0,0 +1,23 @@
+# HG changeset patch
+# User kristianf
+# Date 1382916946 -3600
+# Mon Oct 28 00:35:46 2013 +0100
+# Node ID 0a9e41a05aafb98cc8c21562931cb1cbb5e30c1f
+# Parent 0d99149615ec5ec70a6d03c685291ddc55babff6
+libusb_compat
+
+diff -r 0d99149615ec -r 0a9e41a05aaf host/ekey-ulusbd.c
+--- a/host/ekey-ulusbd.c Mon Oct 28 00:33:43 2013 +0100
++++ b/host/ekey-ulusbd.c Mon Oct 28 00:35:46 2013 +0100
+@@ -100,8 +100,9 @@
+
+ #if LIBUSB_HAS_DETACH_KERNEL_DRIVER_NP
+ if ((r = usb_detach_kernel_driver_np(devh, EKEY_IFACE)) != 0) {
+- if (r != -ENODATA) {
+- fprintf(stderr,
++ /* libusb_compat-0.1.3 mistakenly translate ENODATA to ENOENT */
++ if (r != -ENODATA && r != -ENOENT) {
++ fprintf(stderr,
+ "Unable to detach Entropy Key at %s/%s from kernel\n",
+ busmatch, devmatch);
+ usb_close(devh);
diff --git a/app-crypt/ekeyd/files/ekeyd-1.1.5-misc.patch b/app-crypt/ekeyd/files/ekeyd-1.1.5-misc.patch
new file mode 100644
index 000000000000..660f0bacf0ac
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd-1.1.5-misc.patch
@@ -0,0 +1,50 @@
+diff -r 724cf5abf164 host/Makefile
+--- a/host/Makefile Mon Oct 28 00:43:49 2013 +0100
++++ b/host/Makefile Mon Oct 28 00:54:01 2013 +0100
+@@ -19,7 +19,7 @@
+ RM ?= rm -f
+ LUA_V ?= 5.1
+ EXTRA_INC ?=
+-LUA_INC ?= -I/usr/include/lua5.1
++LUA_INC ?= -I/usr/include
+ LIBDL ?= -ldl
+ PTHFLAGS ?=
+ PTHLIBS ?= -lpthread
+@@ -31,7 +31,7 @@
+ MANZEXT := .gz
+
+ # Current tool version as returned from tools
+-EKEYD_VERSION_S="1.1.4"
++EKEYD_VERSION_S="1.1.5"
+
+ # Attempt to detect an OS and set build options as appropriate
+ OSNAME=$(shell uname -s | tr A-Z a-z | tr -d /)
+@@ -91,10 +91,7 @@
+ override MANZCMD:=cat
+ override MANZEXT:=
+ endif
+-override LUA_INC:=-I/usr/local/include/lua51
+ override LIBDL:=
+-LIBDIRS += -L/usr/local/lib
+-INCLUDES += -I/usr/local/include
+ endif
+ endif
+ endif
+@@ -114,7 +111,7 @@
+ CFLAGS += '-DEKEYD_VERSION_S=""$(EKEYD_VERSION_S)""'
+ CFLAGS += $(EXTRA_CFLAGS)
+
+-LIBS += -llua$(LUA_V) -lm $(LIBDL)
++LIBS += -llua -lm $(LIBDL)
+ LDFLAGS += $(LIBDIRS)
+
+
+@@ -157,7 +154,7 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ control.inc: bin2c.lua control.lua
+- lua$(LUA_V) bin2c.lua +control.lua result > control.inc.new
++ lua bin2c.lua +control.lua result > control.inc.new
+ mv control.inc.new control.inc
+
+ lstate.o: lstate.c control.inc
diff --git a/app-crypt/ekeyd/files/ekeyd-1.1.5-path-fixes.patch b/app-crypt/ekeyd/files/ekeyd-1.1.5-path-fixes.patch
new file mode 100644
index 000000000000..0a9a59186d1d
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd-1.1.5-path-fixes.patch
@@ -0,0 +1,49 @@
+# HG changeset patch
+# User kristianf
+# Date 1382917171 -3600
+# Mon Oct 28 00:39:31 2013 +0100
+# Node ID d96c42b36cb125e6e52cff623b7bdad1910284b4
+# Parent 0a9e41a05aafb98cc8c21562931cb1cbb5e30c1f
+entropykey.sh
+
+diff -r 0a9e41a05aaf -r d96c42b36cb1 udev/entropykey.sh
+--- a/udev/entropykey.sh Mon Oct 28 00:35:46 2013 +0100
++++ b/udev/entropykey.sh Mon Oct 28 00:39:31 2013 +0100
+@@ -19,9 +19,10 @@
+ COUNTER=$(( ${COUNTER} + 1 ))
+ test ${COUNTER} -ge 10 && exit 1
+ done
+- $BINPATH/ekey-ulusbd -b${BUSNUM} -d${DEVNUM} -P/var/run/ekey-ulusbd-${ENTROPY_KEY_SERIAL}.pid -p/var/run/entropykeys/${ENTROPY_KEY_SERIAL} -D
++ /usr/libexec/ekey-ulusbd -b${BUSNUM} -d${DEVNUM} -P/dev/.ekey-ulusbd/${ENTROPY_KEY_SERIAL}.pid -p/dev/entropykey/${ENTROPY_KEY_SERIAL} -D
++
+ sleep 1
+- $BINPATH/ekeydctl ${ACTION} /var/run/entropykeys/${ENTROPY_KEY_SERIAL}
++ $BINPATH/ekeydctl ${ACTION} /dev/entropykey/${ENTROPY_KEY_SERIAL}
+ exit 0
+ }
+
+@@ -34,18 +35,18 @@
+ if test "x${BUSNUM}" = "x" -o "x${DEVNUM}" = "x"; then
+ exit 0
+ fi
+- if test -r "/var/run/ekey-ulusbd-${ENTROPY_KEY_SERIAL}.pid"; then
+- kill $(cat "/var/run/ekey-ulusbd-${ENTROPY_KEY_SERIAL}.pid") || true
++ if test -r "/dev/.ekey-ulusbd/${ENTROPY_KEY_SERIAL}.pid"; then
++ kill $(< "/dev/.ekey-ulusbd/${ENTROPY_KEY_SERIAL}.pid") || true
+ fi
+- mkdir -p /var/run/entropykeys
++ mkdir -p /dev/entropykey /dev/.ekeyd-ulusb
+ wait_for_usb &
+ exit 0
+ fi
+ # Update ekeyd with device operation
+- $BINPATH/ekeydctl ${ACTION} /var/run/entropykeys/${ENTROPY_KEY_SERIAL}
++ $BINPATH/ekeydctl ${ACTION} /dev/entropykey/${ENTROPY_KEY_SERIAL}
+ if test "x$ACTION" = "xremove"; then
+- rm "/var/run/ekey-ulusbd-${ENTROPYKEY_KEY_SERIAL}.pid"
+- rm "/var/run/entropykeys/${ENTROPYKEY_KEY_SERIAL}"
++ rm "/dev/.ekey-ulusbd/${ENTROPYKEY_KEY_SERIAL}.pid"
++ rm "/dev/entropykey/${ENTROPYKEY_KEY_SERIAL}"
+ fi
+ fi
+
diff --git a/app-crypt/ekeyd/files/ekeyd-1.1.5-remove-werror.patch b/app-crypt/ekeyd/files/ekeyd-1.1.5-remove-werror.patch
new file mode 100644
index 000000000000..bb5862dee986
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd-1.1.5-remove-werror.patch
@@ -0,0 +1,29 @@
+# HG changeset patch
+# User kristianf
+# Date 1382917429 -3600
+# Mon Oct 28 00:43:49 2013 +0100
+# Node ID 724cf5abf164dd5889a7c72916aa524c3822b8bd
+# Parent 902b9c6908618864319835d69981f9ea902be324
+Makefile
+
+diff -r 902b9c690861 -r 724cf5abf164 host/Makefile
+--- a/host/Makefile Mon Oct 28 00:41:59 2013 +0100
++++ b/host/Makefile Mon Oct 28 00:43:49 2013 +0100
+@@ -107,7 +107,7 @@
+ CFLAGS += $(INCLUDES)
+ CFLAGS += -g -Wall $(OPT)
+ CFLAGS += -fno-strict-aliasing
+-CFLAGS += -std=c99 -Wall -pedantic -Wshadow -Werror -D_GNU_SOURCE
++CFLAGS += -std=c99 -Wall -pedantic -Wshadow -D_GNU_SOURCE
+ CFLAGS += '-DCONFIGFILE="$(SYSCONFPREFIX)/ekeyd.conf"'
+ CFLAGS += '-DPIDFILE="$(RUNTIMEPREFIX)/ekeyd.pid"'
+ CFLAGS += '-DKEYRINGFILE="$(SYSCONFPREFIX)/keyring"'
+@@ -148,7 +148,7 @@
+ $(COMPILE.c) $(OUTPUT_OPTION) $(PTHFLAGS) $^
+
+ egd-linux: egd-linux.o daemonise.o
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ ekeyd: ekeyd.o daemonise.o lstate.o connection.o stream.o frame.o packet.o keydb.o util.o fds.o krnlop.o foldback.o stats.o nonce.o ../device/frames/pem.o ../device/skeinwrap.o ../device/skein/skein.o ../device/skein/skein_block.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
diff --git a/app-crypt/ekeyd/files/ekeyd-1.1.5-udev-rule.patch b/app-crypt/ekeyd/files/ekeyd-1.1.5-udev-rule.patch
new file mode 100644
index 000000000000..c4b53a802bf6
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd-1.1.5-udev-rule.patch
@@ -0,0 +1,36 @@
+# HG changeset patch
+# User kristianf
+# Date 1382917319 -3600
+# Mon Oct 28 00:41:59 2013 +0100
+# Node ID 902b9c6908618864319835d69981f9ea902be324
+# Parent d96c42b36cb125e6e52cff623b7bdad1910284b4
+udev rule
+
+diff -r d96c42b36cb1 -r 902b9c690861 udev/fedora15/60-entropykey-uds.rules
+--- a/udev/fedora15/60-entropykey-uds.rules Mon Oct 28 00:39:31 2013 +0100
++++ b/udev/fedora15/60-entropykey-uds.rules Mon Oct 28 00:41:59 2013 +0100
+@@ -9,7 +9,7 @@
+ # For licence terms refer to the COPYING file.
+
+ # Detect an Entropy Key being inserted and extract serial number
+-ACTION=="add|change|remove", SUBSYSTEM=="usb", BUS=="usb", ATTRS{idVendor}=="20df", ATTRS{idProduct}=="0001", IMPORT{program}="/bin/echo ENTROPY_KEY_SERIAL=$attr{serial}"
++ACTION=="add|change|remove", SUBSYSTEM=="usb", ATTRS{idVendor}=="20df", ATTRS{idProduct}=="0001", IMPORT{program}="/bin/sh -c /bin/echo ENTROPY_KEY_SERIAL=$attr{serial}"
+
+ # And tell the ekeyd about the device action.
+ ENV{ENTROPY_KEY_SERIAL}!="", RUN+="/lib/udev/entropykey.sh"
+diff -r d96c42b36cb1 -r 902b9c690861 udev/fedora15/60-entropykey.rules
+--- a/udev/fedora15/60-entropykey.rules Mon Oct 28 00:39:31 2013 +0100
++++ b/udev/fedora15/60-entropykey.rules Mon Oct 28 00:41:59 2013 +0100
+@@ -9,10 +9,10 @@
+ # For licence terms refer to the COPYING file distributed with the source.
+
+ # Detect an Entropy Key being inserted and add info values to environment
+-ACTION=="add|change|remove", SUBSYSTEM=="tty", KERNEL=="ttyACM[0-9]*", BUS=="usb", ATTRS{idVendor}=="20df", ATTRS{idProduct}=="0001", IMPORT{program}="usb_id --export %p"
++ACTION=="add|change|remove", SUBSYSTEM=="tty", KERNEL=="ttyACM[0-9]*", ATTRS{idVendor}=="20df", ATTRS{idProduct}=="0001", IMPORT{builtin}="usb_id"
+
+ # Detect an Entropy Key being inserted and extract serial number
+-ACTION=="add|change|remove", SUBSYSTEM=="tty", KERNEL=="ttyACM[0-9]*", ATTRS{idVendor}=="20df", ATTRS{idProduct}=="0001", IMPORT{program}="/bin/echo ENTROPY_KEY_SERIAL=$env{ID_SERIAL_SHORT}"
++ACTION=="add|change|remove", SUBSYSTEM=="tty", KERNEL=="ttyACM[0-9]*", ATTRS{idVendor}=="20df", ATTRS{idProduct}=="0001", IMPORT{program}="/bin/sh -c /bin/echo ENTROPY_KEY_SERIAL=$env{ID_SERIAL_SHORT}"
+
+ # Add the /dev/entropykey/<serialnumber> symbolic link
+ ENV{ENTROPY_KEY_SERIAL}!="", SYMLINK+="entropykey/$env{ENTROPY_KEY_SERIAL}"
diff --git a/app-crypt/ekeyd/files/ekeyd.service b/app-crypt/ekeyd/files/ekeyd.service
new file mode 100644
index 000000000000..637b424b703d
--- /dev/null
+++ b/app-crypt/ekeyd/files/ekeyd.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Entropy key daemon
+
+[Service]
+ExecStart=/usr/libexec/ekeyd
+
+[Install]
+WantedBy=multi-user.target