summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-09-17 21:48:30 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-09-17 21:48:30 +0000
commitfe00527dae44a60658db93e7b5ba8cc66fd46bc3 (patch)
tree40814149f0e848f4f229fbd59b69da6e061ca598 /app-crypt/cfs
parentAdded a patch for capi4k-utils; bug #62310. (Manifest recommit) (diff)
downloadgentoo-2-fe00527dae44a60658db93e7b5ba8cc66fd46bc3.tar.gz
gentoo-2-fe00527dae44a60658db93e7b5ba8cc66fd46bc3.tar.bz2
gentoo-2-fe00527dae44a60658db93e7b5ba8cc66fd46bc3.zip
*** empty log message ***
Diffstat (limited to 'app-crypt/cfs')
-rw-r--r--app-crypt/cfs/ChangeLog10
-rw-r--r--app-crypt/cfs/Manifest3
-rw-r--r--app-crypt/cfs/cfs-1.4.1.14.ebuild81
-rw-r--r--app-crypt/cfs/files/README.Gentoo47
-rw-r--r--app-crypt/cfs/files/cfsd.conf12
-rw-r--r--app-crypt/cfs/files/cfsd.init29
-rw-r--r--app-crypt/cfs/files/digest-cfs-1.4.1.142
-rw-r--r--app-crypt/cfs/metadata.xml8
8 files changed, 192 insertions, 0 deletions
diff --git a/app-crypt/cfs/ChangeLog b/app-crypt/cfs/ChangeLog
new file mode 100644
index 000000000000..679789d9c5a1
--- /dev/null
+++ b/app-crypt/cfs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/cfs
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/ChangeLog,v 1.1 2004/09/17 21:48:30 mkennedy Exp $
+
+*cfs-1.4.1.14 (17 Sep 2004)
+
+ 17 Sep 2004; <mkennedy@gentoo.org> +files/README.Gentoo, +files/cfsd.conf,
+ +files/cfsd.init, +cfs-1.4.1.14.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/app-crypt/cfs/Manifest b/app-crypt/cfs/Manifest
new file mode 100644
index 000000000000..568a9eb2a08a
--- /dev/null
+++ b/app-crypt/cfs/Manifest
@@ -0,0 +1,3 @@
+MD5 e324509ff82fcf6e5c49e79bed816ae0 cfs-1.4.1.14.ebuild~ 5794
+MD5 93a699353ce534e8c3ea38b430e56487 cfs-1.4.1.14.ebuild 3003
+MD5 bcd821c98dd591791c23f41cb449078e files/digest-cfs-1.4.1.14 129
diff --git a/app-crypt/cfs/cfs-1.4.1.14.ebuild b/app-crypt/cfs/cfs-1.4.1.14.ebuild
new file mode 100644
index 000000000000..a5b4e28282e2
--- /dev/null
+++ b/app-crypt/cfs/cfs-1.4.1.14.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/cfs-1.4.1.14.ebuild,v 1.1 2004/09/17 21:48:30 mkennedy Exp $
+
+inherit eutils
+
+MY_PV=${PV:0:5}
+DEB_PV=${PV:6:2}
+
+# This is a port of the Debian port of CFS which includes several
+# useful patches. Many thanks to the Debian developers.
+
+DESCRIPTION="Cryptographic Filesystem"
+HOMEPAGE="http://packages.debian.org/unstable/utils/cfs
+ http://www.crypto.com/software/"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cfs/cfs_${MY_PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cfs/cfs_${MY_PV}-${DEB_PV}.diff.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-fs/nfs-utils"
+
+S=${WORKDIR}/${PN}-${MY_PV}.orig
+
+# Originally from the common-lisp-common.eclass:
+
+do-debian-credits() {
+ docinto debian
+ for i in copyright README.Debian changelog; do
+ # be silent, since all files are not always present
+ dodoc ${S}/debian/${i} &>/dev/null || true
+ done
+ docinto .
+}
+
+cfsd-running() {
+ test -n "$(mount |grep '\(/var/cfs\|/var/lib/cfs/\.cfsfs\)')"
+}
+
+pkg_setup() {
+ if cfsd-running; then
+ eerror "It seems that the null directory or CFS root is currently in use."
+ eerror "You must shutdown CFS before merging this port or at least unmount"
+ eerror "the CFS root before using this port."
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch cfs_${MY_PV}-${DEB_PV}.diff
+}
+
+src_compile() {
+ make cfs COPT="${CFLAGS} -DPROTOTYPES -g" || die
+}
+
+src_install() {
+ make install_cfs BINDIR=${D}/usr/bin ETCDIR=${D}/usr/sbin || die
+ insinto /etc/conf.d
+ newins ${FILESDIR}/cfsd.conf cfsd
+# exeinto /var/lib/cfs
+# doexe debian/cfs_*mount.sh
+ keepdir /var/run/cfs
+ keepdir /var/cfs
+ keepdir /var/lib/cfs/.cfsfs
+ chmod 0 ${D}/var/lib/cfs/.cfsfs
+ doman *.[18]
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/cfsd.init cfsd
+ do-debian-credits
+ dodoc LEVELS README* VERSION
+ dodoc ${FILESDIR}/README.Gentoo
+}
+
+pkg_postinst() {
+ rm -f /var/lib/cfs/.cfsfs/.keep
+ einfo "Please read /usr/share/docs/cfs-${PF}/README.Gentoo for"
+ einfo "information on how to get started with CFS on Gentoo."
+}
diff --git a/app-crypt/cfs/files/README.Gentoo b/app-crypt/cfs/files/README.Gentoo
new file mode 100644
index 000000000000..e757b45380f9
--- /dev/null
+++ b/app-crypt/cfs/files/README.Gentoo
@@ -0,0 +1,47 @@
+-*- mode: outline -*-
+
+* Configuration on Gentoo
+
+Before starting CFS, you will need to setup NFS.
+
+Add an export line to your /etc/exports configuration. Such that an
+empty directory with no permissions is exported to localhost with
+read/write access. This directory is known as the "null export"
+directory. Portage has installed such a directory for you at
+/var/lib/cfs/.cfsfs, thus your /etc/exports line would look like this:
+
+ /var/lib/cfs/.cfsfs localhost(rw,sync)
+
+Add an entry to /etc/fstab which mounts the null export share to the
+"crypt root" mount point. By default, Portage has installed such a
+mount point for you at /var/cfs, thus your /etc/fstab entry will look
+like this:
+
+ localhost:/var/lib/cfs/.cfsfs /var/cfs nfs port=3049,intr,nfsvers=2 0 0
+
+At this point, you may restart NFS:
+
+ /etc/init.d/nfs restart
+ /etc/init.d/nfsmount restart
+
+Alternatively you can run the following commands:
+
+ exportfs -rv
+ mount -oport=3049,intr,nfsvers=2 localhost:/var/lib/cfs/.cfsfs /var/cfs
+
+Finally, start the CFS daemon:
+
+ /etc/init.d/cfs start
+
+* Differences between the Gentoo port and Debian port
+
+Differences in the Gentoo port include:
+
+ - No automatic manipulation of user configuration files such as
+ /etc/exports or /etc/fstab. It is the user's responsibility to
+ update those files.
+
+ - cfs_*mount.sh included in Debian are not used. The user must
+ manually add entries to /etc/fstab however the Gentoo RC system
+ will take care of automatically mounting/unmounting NFS and
+ starting CFS in the right order.
diff --git a/app-crypt/cfs/files/cfsd.conf b/app-crypt/cfs/files/cfsd.conf
new file mode 100644
index 000000000000..82d78fa38d1a
--- /dev/null
+++ b/app-crypt/cfs/files/cfsd.conf
@@ -0,0 +1,12 @@
+# -*- mode: shell-script -*-
+
+# Configuration for the Cryptographic Filesystem (CFS)
+
+# Mount point for encrypted filesystems
+CRYPT_ROOT=/var/cfs
+
+# Se this if you don't want a symbolic link /crypt -> $CRYPT_ROOT.
+# NO_CRYPT_SYMLINK=true
+
+# An empty, permissionless directory that is used as the NFS export.
+NULL_EXPORT=/var/lib/cfs/.cfsfs
diff --git a/app-crypt/cfs/files/cfsd.init b/app-crypt/cfs/files/cfsd.init
new file mode 100644
index 000000000000..59d2d89a6e80
--- /dev/null
+++ b/app-crypt/cfs/files/cfsd.init
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/files/cfsd.init,v 1.1 2004/09/17 21:48:30 mkennedy Exp $
+
+depend() {
+ need nfs
+ before nfsmount
+}
+
+start() {
+ ebegin "Starting cfsd"
+ NODAEMON=1 start-stop-daemon --start --pidfile /var/run/cfs.pid \
+ --make-pidfile --background --exec /usr/sbin/cfsd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cfsd"
+ start-stop-daemon --oknodo --stop --pidfile /var/run/cfs.pid \
+ && rm -f /var/run/cfs.pid
+ eend $?
+}
+
+# Local Variables:
+# mode: shell-script
+# indent-tabs-mode: t
+# tab-width: 4
+# End:
diff --git a/app-crypt/cfs/files/digest-cfs-1.4.1.14 b/app-crypt/cfs/files/digest-cfs-1.4.1.14
new file mode 100644
index 000000000000..c9af8cabe261
--- /dev/null
+++ b/app-crypt/cfs/files/digest-cfs-1.4.1.14
@@ -0,0 +1,2 @@
+MD5 3ce2e01211dafe7bfb44849894926eda cfs_1.4.1.orig.tar.gz 98376
+MD5 ec2c4a65dc8fcda74a38d702fc3409d1 cfs_1.4.1-14.diff.gz 17787
diff --git a/app-crypt/cfs/metadata.xml b/app-crypt/cfs/metadata.xml
new file mode 100644
index 000000000000..da3fcfab142f
--- /dev/null
+++ b/app-crypt/cfs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>mkennedy@gentoo.org</email>
+</maintainer>
+</pkgmetadata>