summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-22 15:13:57 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-22 15:13:57 +0000
commit405dd6a0d7ba08a480a6f66269164e6e393f318a (patch)
tree2dd2a55fa89bc0728a807be133c1da4bfc96fa6a /app-crypt/cfs
parentx86 stable wrt #175389 (diff)
downloadgentoo-2-405dd6a0d7ba08a480a6f66269164e6e393f318a.tar.gz
gentoo-2-405dd6a0d7ba08a480a6f66269164e6e393f318a.tar.bz2
gentoo-2-405dd6a0d7ba08a480a6f66269164e6e393f318a.zip
Use versionator for the PV/DEB_PV manipulations; Use die properly; Use neconfd/newinitd for #174266; Properly quote variables.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-crypt/cfs')
-rw-r--r--app-crypt/cfs/ChangeLog7
-rw-r--r--app-crypt/cfs/cfs-1.4.1.14.ebuild27
-rw-r--r--app-crypt/cfs/cfs-1.4.1.17.ebuild27
3 files changed, 32 insertions, 29 deletions
diff --git a/app-crypt/cfs/ChangeLog b/app-crypt/cfs/ChangeLog
index a3f32ea36d26..9b9afcd6f61e 100644
--- a/app-crypt/cfs/ChangeLog
+++ b/app-crypt/cfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/cfs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/ChangeLog,v 1.8 2007/03/19 11:50:06 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/ChangeLog,v 1.9 2007/04/22 15:13:57 phreak Exp $
+
+ 22 Apr 2007; Christian Heim <phreak@gentoo.org> cfs-1.4.1.14.ebuild,
+ cfs-1.4.1.17.ebuild:
+ Use versionator for the PV/DEB_PV manipulations; Use die properly; Use
+ neconfd/newinitd for #174266; Properly quote variables.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove mkennedy from metadata.xml due to retirement.
diff --git a/app-crypt/cfs/cfs-1.4.1.14.ebuild b/app-crypt/cfs/cfs-1.4.1.14.ebuild
index 2ee5980fd7a6..e47e26d5e070 100644
--- a/app-crypt/cfs/cfs-1.4.1.14.ebuild
+++ b/app-crypt/cfs/cfs-1.4.1.14.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/cfs-1.4.1.14.ebuild,v 1.6 2007/02/04 19:16:12 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/cfs-1.4.1.14.ebuild,v 1.7 2007/04/22 15:13:57 phreak Exp $
-inherit eutils
+inherit eutils versionator
-MY_PV=${PV:0:5}
-DEB_PV=${PV:6:2}
+MY_PV="$(get_version_component_range 1-3)"
+DEB_PV="$(get_version_component_range 4)"
# This is a port of the Debian port of CFS which includes several
# useful patches. Many thanks to the Debian developers.
@@ -29,7 +29,7 @@ do-debian-credits() {
docinto debian
for i in copyright README.Debian changelog; do
# be silent, since all files are not always present
- dodoc ${S}/debian/${i} &>/dev/null || true
+ dodoc "${S}"/debian/${i} &>/dev/null || true
done
docinto .
}
@@ -43,7 +43,7 @@ pkg_setup() {
eerror "It seems that the null directory or CFS root is currently in use."
eerror "You must shutdown CFS before merging this port or at least unmount"
eerror "the CFS root before using this port."
- die
+ die "cfs is still running!"
fi
}
@@ -53,25 +53,24 @@ src_unpack() {
}
src_compile() {
- make cfs COPT="${CFLAGS} -DPROTOTYPES -g" || die
+ make cfs COPT="${CFLAGS} -DPROTOTYPES -g" || die "make failed!"
}
src_install() {
- make install_cfs BINDIR=${D}/usr/bin ETCDIR=${D}/usr/sbin || die
- insinto /etc/conf.d
- newins ${FILESDIR}/cfsd.conf cfsd
+ make install_cfs BINDIR="${D}"/usr/bin ETCDIR="${D}"/usr/sbin || \
+ die "make install failed!"
+ newconfd "${FILESDIR}"/cfsd.conf cfsd
# exeinto /var/lib/cfs
# doexe debian/cfs_*mount.sh
keepdir /var/run/cfs
keepdir /var/cfs
keepdir /var/lib/cfs/.cfsfs
- chmod 0 ${D}/var/lib/cfs/.cfsfs
+ chmod 0 "${D}"/var/lib/cfs/.cfsfs
doman *.[18]
- exeinto /etc/init.d/
- newexe ${FILESDIR}/cfsd.init cfsd
+ newinitd "${FILESDIR}"/cfsd.init cfsd
do-debian-credits
dodoc LEVELS README* VERSION
- dodoc ${FILESDIR}/README.Gentoo
+ dodoc "${FILESDIR}"/README.Gentoo
}
pkg_postinst() {
diff --git a/app-crypt/cfs/cfs-1.4.1.17.ebuild b/app-crypt/cfs/cfs-1.4.1.17.ebuild
index ce2a5f92b357..9736eb8a2383 100644
--- a/app-crypt/cfs/cfs-1.4.1.17.ebuild
+++ b/app-crypt/cfs/cfs-1.4.1.17.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/cfs-1.4.1.17.ebuild,v 1.2 2007/02/04 19:16:12 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cfs/cfs-1.4.1.17.ebuild,v 1.3 2007/04/22 15:13:57 phreak Exp $
-inherit eutils
+inherit eutils versionator
-MY_PV=${PV:0:5}
-DEB_PV=${PV:6:2}
+MY_PV="$(get_version_component_range 1-3)"
+DEB_PV="$(get_version_component_range 4)"
# This is a port of the Debian port of CFS which includes several
# useful patches. Many thanks to the Debian developers.
@@ -29,7 +29,7 @@ do-debian-credits() {
docinto debian
for i in copyright README.Debian changelog; do
# be silent, since all files are not always present
- dodoc ${S}/debian/${i} &>/dev/null || true
+ dodoc "${S}"/debian/${i} &>/dev/null || true
done
docinto .
}
@@ -43,7 +43,7 @@ pkg_setup() {
eerror "It seems that the null directory or CFS root is currently in use."
eerror "You must shutdown CFS before merging this port or at least unmount"
eerror "the CFS root before using this port."
- die
+ die "cfs is still running!"
fi
}
@@ -53,25 +53,24 @@ src_unpack() {
}
src_compile() {
- make cfs COPT="${CFLAGS} -DPROTOTYPES -g" || die
+ make cfs COPT="${CFLAGS} -DPROTOTYPES -g" || die "make failed!"
}
src_install() {
- make install_cfs BINDIR=${D}/usr/bin ETCDIR=${D}/usr/sbin || die
- insinto /etc/conf.d
- newins ${FILESDIR}/cfsd.conf cfsd
+ make install_cfs BINDIR="${D}"/usr/bin ETCDIR="${D}"/usr/sbin || \
+ die "make install failed!"
+ newconfd "${FILESDIR}"/cfsd.conf cfsd
# exeinto /var/lib/cfs
# doexe debian/cfs_*mount.sh
keepdir /var/run/cfs
keepdir /var/cfs
keepdir /var/lib/cfs/.cfsfs
- chmod 0 ${D}/var/lib/cfs/.cfsfs
+ chmod 0 "${D}"/var/lib/cfs/.cfsfs
doman *.[18]
- exeinto /etc/init.d/
- newexe ${FILESDIR}/cfsd.init cfsd
+ newinitd "${FILESDIR}"/cfsd.init cfsd
do-debian-credits
dodoc LEVELS README* VERSION
- dodoc ${FILESDIR}/README.Gentoo
+ dodoc "${FILESDIR}"/README.Gentoo
}
pkg_postinst() {