summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2004-04-15 04:07:02 +0000
committerJoshua Brindle <method@gentoo.org>2004-04-15 04:07:02 +0000
commit8dd87e887a4b3e315ba817bfc3d1e967bc58344a (patch)
tree6b2545bb47614f978c94a776442c87143882fd58 /app-crypt/bsign/bsign-0.4.5.ebuild
parentMarked stable on mips. (Manifest recommit) (diff)
downloadgentoo-2-8dd87e887a4b3e315ba817bfc3d1e967bc58344a.tar.gz
gentoo-2-8dd87e887a4b3e315ba817bfc3d1e967bc58344a.tar.bz2
gentoo-2-8dd87e887a4b3e315ba817bfc3d1e967bc58344a.zip
initial import
Diffstat (limited to 'app-crypt/bsign/bsign-0.4.5.ebuild')
-rw-r--r--app-crypt/bsign/bsign-0.4.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/bsign/bsign-0.4.5.ebuild b/app-crypt/bsign/bsign-0.4.5.ebuild
new file mode 100644
index 000000000000..87ea7f0ca3b9
--- /dev/null
+++ b/app-crypt/bsign/bsign-0.4.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bsign/bsign-0.4.5.ebuild,v 1.1 2004/04/15 04:07:02 method Exp $
+
+DESCRIPTION="This package embeds secure hashes (SHA1) and digital signatures (GNU Privacy Guard) into files for verification and authentication"
+HOMEPAGE="http://packages.debian.org/unstable/admin/bsign.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/b/bsign/${PN}_${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin bsign
+ dobin bsign_sign
+ dobin bsign_verify
+ dobin bsign_hash
+ dobin bsign_check
+ doman bsign.1
+}