summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-04-30 20:58:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-04-30 20:58:59 +0000
commit9fbd008a10131f81b36fa301dfdf066e99e0bffc (patch)
tree3f48fba28b57a6bd05ef0e7511280e9bf01fe502 /app-crypt/bcwipe
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-9fbd008a10131f81b36fa301dfdf066e99e0bffc.tar.gz
gentoo-2-9fbd008a10131f81b36fa301dfdf066e99e0bffc.tar.bz2
gentoo-2-9fbd008a10131f81b36fa301dfdf066e99e0bffc.zip
Version bump (bug #267817).
(Portage version: 13564-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/bcwipe')
-rw-r--r--app-crypt/bcwipe/ChangeLog11
-rw-r--r--app-crypt/bcwipe/bcwipe-1.9.1.ebuild (renamed from app-crypt/bcwipe/bcwipe-1.7_p2.ebuild)28
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.9.1-fix_warnings.patch38
3 files changed, 63 insertions, 14 deletions
diff --git a/app-crypt/bcwipe/ChangeLog b/app-crypt/bcwipe/ChangeLog
index eac325635b8b..0de32bb5d1e3 100644
--- a/app-crypt/bcwipe/ChangeLog
+++ b/app-crypt/bcwipe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/bcwipe
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.34 2009/04/26 19:16:16 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.35 2009/04/30 20:58:58 arfrever Exp $
+
+*bcwipe-1.9.1 (30 Apr 2009)
+
+ 30 Apr 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -bcwipe-1.7_p2.ebuild, +bcwipe-1.9.1.ebuild,
+ +files/bcwipe-1.9.1-fix_warnings.patch:
+ Version bump (bug #267817).
26 Apr 2009; Brent Baude <ranger@gentoo.org> bcwipe-1.7_p7.ebuild:
stable ppc, bug 266807
diff --git a/app-crypt/bcwipe/bcwipe-1.7_p2.ebuild b/app-crypt/bcwipe/bcwipe-1.9.1.ebuild
index 7a0718eaf470..5a9afb704d8f 100644
--- a/app-crypt/bcwipe/bcwipe-1.7_p2.ebuild
+++ b/app-crypt/bcwipe/bcwipe-1.9.1.ebuild
@@ -1,40 +1,44 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.7_p2.ebuild,v 1.5 2008/04/09 17:27:25 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.9.1.ebuild,v 1.1 2009/04/30 20:58:58 arfrever Exp $
-inherit toolchain-funcs eutils
+EAPI="2"
-MY_PV="${PV/_p/-}"
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 2 -)"
DESCRIPTION="BCWipe secure file removal utility"
HOMEPAGE="http://www.jetico.com/"
SRC_URI="http://www.jetico.com/linux/BCWipe-${MY_PV}.tar.gz
- http://www.jetico.com/linux/BCWipe.doc.tgz"
+ doc? ( http://www.jetico.com/linux/BCWipe.doc.tgz )"
LICENSE="bestcrypt"
SLOT="0"
IUSE="doc"
-KEYWORDS="amd64 ppc sparc x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
DEPEND=""
RDEPEND=""
S="${WORKDIR}/${PN}-${MY_PV}"
-src_compile() {
- emake CC="$(tc-getCC)" DEFS="${CFLAGS}"|| die "Make failed"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_warnings.patch"
}
src_test() {
echo "abc123" >> testfile
./bcwipe -f testfile || die "bcwipe test failed"
- [ -f testfile ] && die "test file still exists. bcwipe should of deleted it"
+ [ -f testfile ] && die "test file still exists. bcwipe should have deleted it"
}
src_install() {
- dobin bcwipe
- doman bcwipe.1
- use doc && dohtml -r ../bcwipe-help
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc ; then
+ dohtml -r ../bcwipe-help || die "dohtml failed"
+ fi
}
pkg_postinst() {
diff --git a/app-crypt/bcwipe/files/bcwipe-1.9.1-fix_warnings.patch b/app-crypt/bcwipe/files/bcwipe-1.9.1-fix_warnings.patch
new file mode 100644
index 000000000000..6d71638320e1
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.9.1-fix_warnings.patch
@@ -0,0 +1,38 @@
+--- schemes.c
++++ schemes.c
+@@ -15,6 +15,7 @@
+ *
+ *******************************************************************/
+ #include "config.h"
++#include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <errno.h>
+--- wipe.c
++++ wipe.c
+@@ -773,7 +773,7 @@
+ static int do_verify_pass(int fd, wipe_info_t *ctx)
+ {
+ long long int pos, len, size;
+- time_t cur_time, start_time;
++ time_t start_time;
+ int x;
+ char verifyBuff[BUFFSIZE];
+ char buff[BUFFSIZE];
+@@ -839,7 +839,6 @@
+ {
+ int fd, is_dev, ret;
+ long long int size;
+- char *type_str;
+
+ if (o_wipe_slacks)
+ return wipe_file_slack_nas( ctx, pass, verify );
+@@ -1478,7 +1477,7 @@
+ int fd, res, j, write_fail;
+ long long int file_size, ss, free_space, x;
+ time_t start_time;
+- int cnt, err;
++ int cnt;
+ seed_t seed, prev_seed;
+
+