summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-23 05:43:57 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-23 05:43:57 +0000
commit561f51b9a88eb89a8044929bc3c1c554809c9988 (patch)
tree66c93e3504d273b6e26632fb11ba3545fefa9263 /app-crypt/aespipe
parent0.5.6 stable on x86 (#144686). Removed old version. (diff)
downloadgentoo-2-561f51b9a88eb89a8044929bc3c1c554809c9988.tar.gz
gentoo-2-561f51b9a88eb89a8044929bc3c1c554809c9988.tar.bz2
gentoo-2-561f51b9a88eb89a8044929bc3c1c554809c9988.zip
fix broken LDFLAGS handling #125923 by solar
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'app-crypt/aespipe')
-rw-r--r--app-crypt/aespipe/aespipe-2.3b.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/app-crypt/aespipe/aespipe-2.3b.ebuild b/app-crypt/aespipe/aespipe-2.3b.ebuild
index 24a127966a83..35af27e4c44d 100644
--- a/app-crypt/aespipe/aespipe-2.3b.ebuild
+++ b/app-crypt/aespipe/aespipe-2.3b.ebuild
@@ -1,31 +1,28 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/aespipe/aespipe-2.3b.ebuild,v 1.2 2005/08/10 16:44:12 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/aespipe/aespipe-2.3b.ebuild,v 1.3 2006/08/23 05:43:57 vapier Exp $
-DESCRIPTION="Encrypts data from stdin to stdout."
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
HOMEPAGE="http://loop-aes.sourceforge.net"
SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
IUSE="static"
DEPEND=""
-S="${WORKDIR}/${PN}-v${PV}"
-src_compile() {
- use static && export LDFLAGS="-static -s"
+S=${WORKDIR}/${PN}-v${PV}
+src_compile() {
+ use static && append-flags -static
econf || die
-
- if [ "${ARCH}" == "x86" ]; then
- emake i586 || die
- else
- emake || die
- fi
+ emake || die
}
src_install() {
- dobin aespipe
- dobin bz2aespipe
+ dobin aespipe bz2aespipe || die
dodoc README
doman aespipe.1
}