summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 21:59:41 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 21:59:41 +0000
commit313e6e7dac9eaeb511b11c9e91ab1d7285a2ad83 (patch)
tree6b5dd8b9af7665d8b8a34a1200b1f96cee09c5b7 /app-crypt/aespipe
parentbug#405525 add support for USE static-libs (diff)
downloadgentoo-2-313e6e7dac9eaeb511b11c9e91ab1d7285a2ad83.tar.gz
gentoo-2-313e6e7dac9eaeb511b11c9e91ab1d7285a2ad83.tar.bz2
gentoo-2-313e6e7dac9eaeb511b11c9e91ab1d7285a2ad83.zip
Version bump per bug#426230, thanks to Gerald
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-crypt/aespipe')
-rw-r--r--app-crypt/aespipe/ChangeLog8
-rw-r--r--app-crypt/aespipe/aespipe-2.4c.ebuild30
2 files changed, 36 insertions, 2 deletions
diff --git a/app-crypt/aespipe/ChangeLog b/app-crypt/aespipe/ChangeLog
index 333235570a16..0921e74a2d7d 100644
--- a/app-crypt/aespipe/ChangeLog
+++ b/app-crypt/aespipe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/aespipe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/aespipe/ChangeLog,v 1.31 2012/09/18 04:39:41 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/aespipe/ChangeLog,v 1.32 2012/12/14 21:59:41 alonbl Exp $
+
+*aespipe-2.4c (14 Dec 2012)
+
+ 14 Dec 2012; <alonbl@gentoo.org> +aespipe-2.4c.ebuild:
+ Version bump per bug#426230, thanks to Gerald
18 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
@@ -95,4 +100,3 @@
11 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> aespipe-2.2a.ebuild:
Initial import. Ebuild submitted by Venkat Manakkal <venkat@rayservers.com> in
#20669.
-
diff --git a/app-crypt/aespipe/aespipe-2.4c.ebuild b/app-crypt/aespipe/aespipe-2.4c.ebuild
new file mode 100644
index 000000000000..9ba711196c67
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.4c.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/aespipe/aespipe-2.4c.ebuild,v 1.1 2012/12/14 21:59:41 alonbl Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="http://loop-aes.sourceforge.net"
+SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="static"
+DEPEND=""
+RDEPEND="app-arch/sharutils"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dobin aespipe bz2aespipe
+ dodoc README
+ doman aespipe.1
+}