summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-22 00:30:14 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-22 00:30:14 +0000
commit9339325fd1b7bcfd821a556f7534151bd03d3ab1 (patch)
tree2c8655af37e3a36282ef00de6c6ce15b9bb37050 /app-cdr
parentBump, now supports "raw" images of CSS-encrypted DVDs (e.g. produced by dd). ... (diff)
downloadgentoo-2-9339325fd1b7bcfd821a556f7534151bd03d3ab1.tar.gz
gentoo-2-9339325fd1b7bcfd821a556f7534151bd03d3ab1.tar.bz2
gentoo-2-9339325fd1b7bcfd821a556f7534151bd03d3ab1.zip
Bump, now uses glib's gdbus instead of dbus-glib. Drop old.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/cdemud/ChangeLog8
-rw-r--r--app-cdr/cdemud/cdemud-1.3.0.ebuild41
-rw-r--r--app-cdr/cdemud/cdemud-1.5.0.ebuild45
3 files changed, 52 insertions, 42 deletions
diff --git a/app-cdr/cdemud/ChangeLog b/app-cdr/cdemud/ChangeLog
index 49b6844fd27e..ee6f17a9a00d 100644
--- a/app-cdr/cdemud/ChangeLog
+++ b/app-cdr/cdemud/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/cdemud
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/ChangeLog,v 1.21 2012/01/18 12:08:10 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/ChangeLog,v 1.22 2012/01/22 00:30:14 tetromino Exp $
+
+*cdemud-1.5.0 (22 Jan 2012)
+
+ 22 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -cdemud-1.3.0.ebuild, +cdemud-1.5.0.ebuild:
+ Bump, now uses glib's gdbus instead of dbus-glib. Drop old.
18 Jan 2012; Agostino Sarubbo <ago@gentoo.org> cdemud-1.4.0.ebuild:
Stable for amd64, wrt bug #397709
diff --git a/app-cdr/cdemud/cdemud-1.3.0.ebuild b/app-cdr/cdemud/cdemud-1.3.0.ebuild
deleted file mode 100644
index e3d234d24c3d..000000000000
--- a/app-cdr/cdemud/cdemud-1.3.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/cdemud-1.3.0.ebuild,v 1.4 2011/11/23 10:13:58 tetromino Exp $
-
-EAPI="2"
-
-DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
-HOMEPAGE="http://cdemu.org"
-SRC_URI="mirror://sourceforge/cdemu/cdemu-daemon-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa pulseaudio"
-
-RDEPEND=">dev-libs/dbus-glib-0.6
- >=dev-libs/libdaemon-0.10
- >=dev-libs/libmirage-1.3.0
- media-libs/libao[alsa?,pulseaudio?]
- >=sys-fs/vhba-20101015"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/cdemu-daemon-${PV}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README || die
-
- newconfd "${FILESDIR}/${PN}.conf.d-1.1.0" ${PN} || die
- newinitd "${FILESDIR}/${PN}.init.d-1.1.0" ${PN} || die
-}
-
-pkg_postinst() {
- elog "Either cdemu group users can start"
- elog "their own daemons or you can start"
- elog "a systembus style daemon, adding"
- elog "${PN} to the default runlevel by"
- elog " # rc-update add ${PN} default"
- elog "as root. Systembus style daemons can be configured"
- elog "in /etc/conf.d/{PN}"
-}
diff --git a/app-cdr/cdemud/cdemud-1.5.0.ebuild b/app-cdr/cdemud/cdemud-1.5.0.ebuild
new file mode 100644
index 000000000000..71bf2290b047
--- /dev/null
+++ b/app-cdr/cdemud/cdemud-1.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemud/cdemud-1.5.0.ebuild,v 1.1 2012/01/22 00:30:14 tetromino Exp $
+
+EAPI="4"
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-daemon-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pulseaudio"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=dev-libs/libmirage-${PV}
+ >=media-libs/libao-0.8.0[pulseaudio?]
+ sys-apps/dbus
+ >=sys-fs/vhba-20101015
+ !pulseaudio? ( >=media-libs/libao-0.8.0[alsa] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/cdemu-daemon-${PV}
+
+src_prepare() {
+ if ! use pulseaudio; then
+ sed -e 's:AUDIO_DRIVER=pulse:AUDIO_DRIVER=alsa:' \
+ -i session/cdemu-daemon-session.sh || die "sed failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
+ fi
+}