summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-21 19:09:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-21 19:09:33 +0000
commit5711fa02a491fe5bc78bc601230e5574d3012e0b (patch)
tree52aed31d75cd863e67b2c8be1cc3aa1a464add70 /app-cdr
parentVersion bump, new features from bug 265264 and bug 388233. (diff)
downloadgentoo-2-5711fa02a491fe5bc78bc601230e5574d3012e0b.tar.gz
gentoo-2-5711fa02a491fe5bc78bc601230e5574d3012e0b.tar.bz2
gentoo-2-5711fa02a491fe5bc78bc601230e5574d3012e0b.zip
Version bump wrt #399587 by "khorio"
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/isomaster/ChangeLog8
-rw-r--r--app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch16
-rw-r--r--app-cdr/isomaster/isomaster-1.3.9.ebuild48
3 files changed, 71 insertions, 1 deletions
diff --git a/app-cdr/isomaster/ChangeLog b/app-cdr/isomaster/ChangeLog
index f59e113c9789..946397d7d826 100644
--- a/app-cdr/isomaster/ChangeLog
+++ b/app-cdr/isomaster/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/isomaster
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/isomaster/ChangeLog,v 1.17 2012/01/07 18:42:47 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/isomaster/ChangeLog,v 1.18 2012/01/21 19:09:33 ssuominen Exp $
+
+*isomaster-1.3.9 (21 Jan 2012)
+
+ 21 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +isomaster-1.3.9.ebuild,
+ +files/isomaster-1.3.9-asneeded.patch:
+ Version bump wrt #399587 by "khorio"
*isomaster-1.3.8 (07 Jan 2012)
diff --git a/app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch b/app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch
new file mode 100644
index 000000000000..fc4c2d4350a2
--- /dev/null
+++ b/app-cdr/isomaster/files/isomaster-1.3.9-asneeded.patch
@@ -0,0 +1,16 @@
+diff -ur isomaster-1.3.9.orig/Makefile isomaster-1.3.9/Makefile
+--- isomaster-1.3.9.orig/Makefile 2012-01-19 21:58:06.000000000 +0200
++++ isomaster-1.3.9/Makefile 2012-01-21 21:04:18.952310071 +0200
+@@ -75,9 +75,9 @@
+ isomaster: $(OBJECTS) lib iniparser
+ @echo 'Linking isomaster'
+ ifndef USE_SYSTEM_INIPARSER
+- @$(CC) $(LDFLAGS) `pkg-config --libs gtk+-2.0` $(OBJECTS) bk/bk.a iniparser-2.17/libiniparser.a -o isomaster
++ @$(CC) $(LDFLAGS) $(OBJECTS) -o isomaster bk/bk.a iniparser-2.17/libiniparser.a `pkg-config --libs gtk+-2.0`
+ else
+- @$(CC) $(LDFLAGS) `pkg-config --libs gtk+-2.0` $(OBJECTS) bk/bk.a -liniparser -o isomaster
++ @$(CC) $(LDFLAGS) $(OBJECTS) -o isomaster bk/bk.a -liniparser `pkg-config --libs gtk+-2.0`
+ endif
+
+ # static pattern rule
+Only in isomaster-1.3.9: Makefile.orig
diff --git a/app-cdr/isomaster/isomaster-1.3.9.ebuild b/app-cdr/isomaster/isomaster-1.3.9.ebuild
new file mode 100644
index 000000000000..80c172f239be
--- /dev/null
+++ b/app-cdr/isomaster/isomaster-1.3.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/isomaster/isomaster-1.3.9.ebuild,v 1.1 2012/01/21 19:09:33 ssuominen Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Graphical CD image editor for reading, modifying and writing ISO images"
+HOMEPAGE="http://littlesvr.ca/isomaster"
+SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="nls"
+
+#dev-libs/iniparser, see pkg_setup() and bug 399629
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ myisoconf=(
+ DEFAULT_EDITOR=leafpad
+ MYDOCPATH=/usr/share/doc/${PF}/bkisofs
+ #USE_SYSTEM_INIPARSER=1
+ PREFIX=/usr
+ )
+
+ use nls || myisoconf+=( WITHOUT_NLS=1 )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_configure() { :; } #274361
+
+src_compile() {
+ tc-export CC
+ emake ${myisoconf[@]}
+}
+
+src_install() {
+ emake ${myisoconf[@]} DESTDIR="${D}" install
+ dodoc {CHANGELOG,CREDITS,README,TODO}.TXT *.txt
+}