summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-10-19 14:36:51 +0000
committerPeter Volkov <pva@gentoo.org>2010-10-19 14:36:51 +0000
commit060a1b9f65a03249c15f013f5835388fc481d0af (patch)
treea58b245ad8dee5faa879567cfcc4ce569411964a /app-cdr
parentVersion bump. Added nocdemud USE flag to avoid cdemud dependency #315491 wrt ... (diff)
downloadgentoo-2-060a1b9f65a03249c15f013f5835388fc481d0af.tar.gz
gentoo-2-060a1b9f65a03249c15f013f5835388fc481d0af.tar.bz2
gentoo-2-060a1b9f65a03249c15f013f5835388fc481d0af.zip
Version bump. Updated python related code, bug 308323, thank Arfrever Frehtes Taifersar Arahesis for report.
(Portage version: 2.1.9.18/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/gcdemu/ChangeLog8
-rw-r--r--app-cdr/gcdemu/gcdemu-1.3.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/app-cdr/gcdemu/ChangeLog b/app-cdr/gcdemu/ChangeLog
index 6a6ff4b652b3..a10fccb949dd 100644
--- a/app-cdr/gcdemu/ChangeLog
+++ b/app-cdr/gcdemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/gcdemu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcdemu/ChangeLog,v 1.10 2010/02/01 20:24:42 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcdemu/ChangeLog,v 1.11 2010/10/19 14:36:51 pva Exp $
+
+*gcdemu-1.3.0 (19 Oct 2010)
+
+ 19 Oct 2010; Peter Volkov <pva@gentoo.org> +gcdemu-1.3.0.ebuild:
+ Version bump. Updated python related code, bug 308323, thank Arfrever
+ Frehtes Taifersar Arahesis for report.
01 Feb 2010; Peter Volkov <pva@gentoo.org> -gcdemu-1.1.0.ebuild,
gcdemu-1.2.0.ebuild:
diff --git a/app-cdr/gcdemu/gcdemu-1.3.0.ebuild b/app-cdr/gcdemu/gcdemu-1.3.0.ebuild
new file mode 100644
index 000000000000..23f3473ae85c
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-1.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcdemu/gcdemu-1.3.0.ebuild,v 1.1 2010/10/19 14:36:51 pva Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit python gnome2
+
+DESCRIPTION="gCDEmu is a GNOME applet for controlling CDEmu daemon"
+HOMEPAGE="http://cdemu.org/"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+COMMON_DEPEND=">=dev-lang/python-2.4
+ >=dev-python/pygtk-2.6
+ >=dev-python/pygobject-2.6
+ >=dev-python/gnome-python-2.6
+ >=dev-python/libgnome-python-2.6
+ >=dev-python/gnome-applets-python-2.6
+ >=dev-python/dbus-python-0.71
+ >=app-cdr/cdemud-1.0.0"
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ dev-util/pkgconfig
+ dev-util/intltool"
+RDEPEND="${COMMON_DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+DOCS="AUTHORS ChangeLog README"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # disable compilation of python modules
+ rm py-compile && \
+ ln -s "$(type -P true)" py-compile || die
+ python_convert_shebangs 2 src/gcdemu
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}