summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:16:43 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:16:43 +0000
commita2f743a5e3909c5efd52d377ee2ad149c1d10daf (patch)
tree77bf079f12856f392f0211d8867b67c08526c8b3 /app-cdr/nrg2iso
parentStable on amd64. (diff)
downloadgentoo-2-a2f743a5e3909c5efd52d377ee2ad149c1d10daf.tar.gz
gentoo-2-a2f743a5e3909c5efd52d377ee2ad149c1d10daf.tar.bz2
gentoo-2-a2f743a5e3909c5efd52d377ee2ad149c1d10daf.zip
use $(tc-getCC)
Diffstat (limited to 'app-cdr/nrg2iso')
-rw-r--r--app-cdr/nrg2iso/files/0.2-lfs.patch55
-rw-r--r--app-cdr/nrg2iso/files/digest-nrg2iso-0.21
-rw-r--r--app-cdr/nrg2iso/files/digest-nrg2iso-0.2-r11
-rw-r--r--app-cdr/nrg2iso/nrg2iso-0.2-r1.ebuild34
-rw-r--r--app-cdr/nrg2iso/nrg2iso-0.2.ebuild27
-rw-r--r--app-cdr/nrg2iso/nrg2iso-0.4.ebuild9
6 files changed, 4 insertions, 123 deletions
diff --git a/app-cdr/nrg2iso/files/0.2-lfs.patch b/app-cdr/nrg2iso/files/0.2-lfs.patch
deleted file mode 100644
index cbf11e76c5f4..000000000000
--- a/app-cdr/nrg2iso/files/0.2-lfs.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- nrg2iso.c.orig 2004-05-05 22:38:35.056108024 -0400
-+++ nrg2iso.c 2004-05-05 22:41:46.129060520 -0400
-@@ -78,8 +78,8 @@
- FILE *nrgFile, *isoFile;
- char buffer[1048576];
- int i=0,j=0;
-- int size=0,k=0,l;
-- int nrgSize=0;
-+ off_t size=0,k=0,l, stepsize;
-+ off_t nrgSize=0;
- float pourcent=0.0;
- struct stat buf;
-
-@@ -96,6 +96,8 @@
- nrgFile=fopen(argv[1],"r");
- fseek (nrgFile, 307200, SEEK_SET);
-
-+ stepsize = nrgSize / 70;
-+
- isoFile=fopen(argv[2],"w+");
-
- while((i= fread( buffer, 1, 1048576, nrgFile ))>0){
-@@ -104,17 +106,13 @@
- size+=i;
- pourcent = (100.0*size)/nrgSize;
-
-- if(j==10){
-- j=0;
-- k++;
-- printf("\r");
-- printf("|");
-- for(l=0;l<k;l++)
-+ k = size / stepsize;
-+ printf("\r");
-+ printf("|");
-+ for(l=0;l<k;l++)
- printf("=");
-- printf(">[%d\%]",(int)pourcent);
-- fflush(stdout);
-- }
-- j++;
-+ printf(">[%d\%]", (int)pourcent);
-+ fflush(stdout);
- }
-
- printf("\r");
-@@ -126,7 +124,7 @@
-
- fclose(nrgFile);
- fclose(isoFile);
-- printf("\n%s written : %d bytes\n",argv[2],size);
-+ printf("\n%s written : %.2f MB\n",argv[2],(float)size/1024/1024);
- }
- }
- else
diff --git a/app-cdr/nrg2iso/files/digest-nrg2iso-0.2 b/app-cdr/nrg2iso/files/digest-nrg2iso-0.2
deleted file mode 100644
index f4e89040dae5..000000000000
--- a/app-cdr/nrg2iso/files/digest-nrg2iso-0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4ffe8f1617f969c0c381ad101e76d8a6 nrg2iso.tgz 8285
diff --git a/app-cdr/nrg2iso/files/digest-nrg2iso-0.2-r1 b/app-cdr/nrg2iso/files/digest-nrg2iso-0.2-r1
deleted file mode 100644
index f4e89040dae5..000000000000
--- a/app-cdr/nrg2iso/files/digest-nrg2iso-0.2-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4ffe8f1617f969c0c381ad101e76d8a6 nrg2iso.tgz 8285
diff --git a/app-cdr/nrg2iso/nrg2iso-0.2-r1.ebuild b/app-cdr/nrg2iso/nrg2iso-0.2-r1.ebuild
deleted file mode 100644
index 413253b087a3..000000000000
--- a/app-cdr/nrg2iso/nrg2iso-0.2-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/nrg2iso/nrg2iso-0.2-r1.ebuild,v 1.6 2004/10/05 11:22:56 pvdabeel Exp $
-
-inherit gcc flag-o-matic eutils
-
-DESCRIPTION="Converts nrg CD-images to iso"
-HOMEPAGE="http://gregory.kokanosky.free.fr/v4/linux/nrg2iso.en.html"
-SRC_URI="http://gregory.kokanosky.free.fr/v4/linux/${PN}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc ~sparc ~amd64"
-IUSE=""
-
-DEPEND="virtual/libc"
-RDEPEND=""
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-lfs.patch
-}
-
-src_compile() {
- append-lfs-flags
- $(gcc-getCC) ${CFLAGS} -o nrg2iso nrg2iso.c || die "failed to compile"
-}
-
-src_install() {
- dobin nrg2iso || die
-}
diff --git a/app-cdr/nrg2iso/nrg2iso-0.2.ebuild b/app-cdr/nrg2iso/nrg2iso-0.2.ebuild
deleted file mode 100644
index dff61ee6f8c4..000000000000
--- a/app-cdr/nrg2iso/nrg2iso-0.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/nrg2iso/nrg2iso-0.2.ebuild,v 1.6 2004/10/05 11:22:56 pvdabeel Exp $
-
-inherit gcc
-
-DESCRIPTION="Converts nrg CD-images to iso"
-HOMEPAGE="http://gregory.kokanosky.free.fr/v4/linux/nrg2iso.en.html"
-SRC_URI="http://gregory.kokanosky.free.fr/v4/linux/${PN}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc ~sparc"
-IUSE=""
-
-DEPEND="virtual/libc"
-RDEPEND=""
-
-S=${WORKDIR}/${PN}
-
-src_compile() {
- $(gcc-getCC) ${CFLAGS} -o nrg2iso nrg2iso.c || die "failed to compile"
-}
-
-src_install() {
- dobin nrg2iso || die
-}
diff --git a/app-cdr/nrg2iso/nrg2iso-0.4.ebuild b/app-cdr/nrg2iso/nrg2iso-0.4.ebuild
index a0da17c1d1ad..4e61d6fdf720 100644
--- a/app-cdr/nrg2iso/nrg2iso-0.4.ebuild
+++ b/app-cdr/nrg2iso/nrg2iso-0.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/nrg2iso/nrg2iso-0.4.ebuild,v 1.1 2004/07/30 10:28:32 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/nrg2iso/nrg2iso-0.4.ebuild,v 1.2 2004/10/26 13:16:43 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Converts Nero nrg CD-images to iso"
HOMEPAGE="http://gregory.kokanosky.free.fr/v4/linux/nrg2iso.en.html"
@@ -10,16 +10,15 @@ SRC_URI="http://gregory.kokanosky.free.fr/v4/linux/${PN}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="amd64 ppc sparc x86"
IUSE=""
DEPEND="virtual/libc"
-RDEPEND=""
S=${WORKDIR}/${PN}
src_compile() {
- ${CC} ${CFLAGS} -o nrg2iso nrg2iso.c || die "failed to compile"
+ $(tc-getCC) ${CFLAGS} -o nrg2iso nrg2iso.c || die "failed to compile"
}
src_install() {