summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-15 11:15:50 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-15 11:15:50 +0000
commit250f59485d1dfb603184f0033078c5a6295b236c (patch)
treee6cfb63bfb13605f9700e5f447af1a83edf99371 /app-cdr/nrg2iso
parentBug #226505 - For compatibility with phase execution order in (diff)
downloadgentoo-2-250f59485d1dfb603184f0033078c5a6295b236c.tar.gz
gentoo-2-250f59485d1dfb603184f0033078c5a6295b236c.tar.bz2
gentoo-2-250f59485d1dfb603184f0033078c5a6295b236c.zip
old, respect LDFLAGS.
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-cdr/nrg2iso')
-rw-r--r--app-cdr/nrg2iso/nrg2iso-0.1.ebuild26
-rw-r--r--app-cdr/nrg2iso/nrg2iso-0.4-r1.ebuild10
2 files changed, 5 insertions, 31 deletions
diff --git a/app-cdr/nrg2iso/nrg2iso-0.1.ebuild b/app-cdr/nrg2iso/nrg2iso-0.1.ebuild
deleted file mode 100644
index 8b8fc4bacf81..000000000000
--- a/app-cdr/nrg2iso/nrg2iso-0.1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/nrg2iso/nrg2iso-0.1.ebuild,v 1.7 2005/01/01 12:20:35 eradicator Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Converts Nero nrg CD-images to iso"
-HOMEPAGE="http://gregory.kokanosky.free.fr/v4/linux/nrg2iso.en.html"
-SRC_URI="http://gregory.kokanosky.free.fr/v4/linux/${PN}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-
-DEPEND="virtual/libc"
-
-S=${WORKDIR}/${PN}
-
-src_compile() {
- $(tc-getCC) ${CFLAGS} -o nrg2iso nrg2iso.c || die "failed to compile"
-}
-
-src_install() {
- dobin nrg2iso || die
-}
diff --git a/app-cdr/nrg2iso/nrg2iso-0.4-r1.ebuild b/app-cdr/nrg2iso/nrg2iso-0.4-r1.ebuild
index d2bbd056140b..2ba0a89a5707 100644
--- a/app-cdr/nrg2iso/nrg2iso-0.4-r1.ebuild
+++ b/app-cdr/nrg2iso/nrg2iso-0.4-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/nrg2iso/nrg2iso-0.4-r1.ebuild,v 1.8 2007/04/28 06:36:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/nrg2iso/nrg2iso-0.4-r1.ebuild,v 1.9 2008/06/15 11:15:50 drac Exp $
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Converts Nero nrg CD-images to iso"
HOMEPAGE="http://gregory.kokanosky.free.fr/v4/linux/nrg2iso.en.html"
@@ -16,10 +16,10 @@ IUSE=""
DEPEND="virtual/libc"
src_compile() {
- $(tc-getCC) ${CFLAGS} -o nrg2iso nrg2iso.c || die "failed to compile"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o nrg2iso nrg2iso.c || die "compile failed."
}
src_install() {
- dobin nrg2iso || die
- dodoc CHANGELOG || die
+ dobin nrg2iso || die "dobin failed."
+ dodoc CHANGELOG
}