summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-12 23:27:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-12 23:27:47 +0000
commit1ce25b3c7b99d941e9e110e539a0c4d1f1066c66 (patch)
tree258622eac2f57d12f235bffe5d6d63eabe78e357 /app-cdr/gcombust
parentAdded USE dependent nls compilation (diff)
downloadgentoo-2-1ce25b3c7b99d941e9e110e539a0c4d1f1066c66.tar.gz
gentoo-2-1ce25b3c7b99d941e9e110e539a0c4d1f1066c66.tar.bz2
gentoo-2-1ce25b3c7b99d941e9e110e539a0c4d1f1066c66.zip
Version upgrade, and USE dependent nls compilation
Diffstat (limited to 'app-cdr/gcombust')
-rw-r--r--app-cdr/gcombust/ChangeLog18
-rw-r--r--app-cdr/gcombust/files/digest-gcombust-0.1.491
-rw-r--r--app-cdr/gcombust/gcombust-0.1.49.ebuild35
3 files changed, 54 insertions, 0 deletions
diff --git a/app-cdr/gcombust/ChangeLog b/app-cdr/gcombust/ChangeLog
new file mode 100644
index 000000000000..c45a7201b563
--- /dev/null
+++ b/app-cdr/gcombust/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-cdr/gcombust
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+
+*gcombust-0.1.49 (11 Mar 2002)
+
+ 11 Mar 2002; Matthew Kennedy <mbkennedy@ieee.org> ebuild :
+
+ Version update. NLS bug fix.
+
+*cdrtools-1.11.12 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-cdr/gcombust/files/digest-gcombust-0.1.49 b/app-cdr/gcombust/files/digest-gcombust-0.1.49
new file mode 100644
index 000000000000..36b478486bc2
--- /dev/null
+++ b/app-cdr/gcombust/files/digest-gcombust-0.1.49
@@ -0,0 +1 @@
+MD5 ff2460c1e090f7cc026759d6cc708718 gcombust-0.1.49.tar.gz 777203
diff --git a/app-cdr/gcombust/gcombust-0.1.49.ebuild b/app-cdr/gcombust/gcombust-0.1.49.ebuild
new file mode 100644
index 000000000000..12ee7fc3eef2
--- /dev/null
+++ b/app-cdr/gcombust/gcombust-0.1.49.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Matthew Kennedy <mbkennedy@ieee.com>
+# Maintainer: Chris Houser <chouser@gentoo.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A GUI for mkisofs/mkhybrid/cdda2wav/cdrecord/cdlabelgen"
+SRC_URI="http://www.abo.fi/~jmunsin/gcombust/${P}.tar.gz"
+HOMEPAGE="http://www.abo.fi/~jmunsin/gcombust/"
+SLOT="0"
+DEPEND=">=x11-libs/gtk+-1.2.10
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myopts
+
+ if [ -z "`use nls`" ]
+ then
+ myopts="${myopts} --disable-nls"
+ else
+ myopts="${myopts} --enable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO
+ dohtml -a shtml FAQ.shtml
+}