summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-10-08 16:52:28 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-10-08 16:52:28 +0000
commit5ba581e8e49765f883cf4e18facbded54fb91a82 (patch)
treedb082cc13061514e7dd6c24b9bb714db7dea3e31 /app-cdr/gcdemu/gcdemu-2.1.1.ebuild
parentVersion bump. Remove old. (diff)
downloadgentoo-2-5ba581e8e49765f883cf4e18facbded54fb91a82.tar.gz
gentoo-2-5ba581e8e49765f883cf4e18facbded54fb91a82.tar.bz2
gentoo-2-5ba581e8e49765f883cf4e18facbded54fb91a82.zip
Version bump. Remove old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-cdr/gcdemu/gcdemu-2.1.1.ebuild')
-rw-r--r--app-cdr/gcdemu/gcdemu-2.1.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-cdr/gcdemu/gcdemu-2.1.1.ebuild b/app-cdr/gcdemu/gcdemu-2.1.1.ebuild
new file mode 100644
index 000000000000..ee7a2771c09b
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-2.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/gcdemu/gcdemu-2.1.1.ebuild,v 1.1 2013/10/08 16:52:28 tetromino Exp $
+
+EAPI="5"
+
+CMAKE_MIN_VERSION="2.8.5"
+PYTHON_COMPAT=( python2_6 python2_7 )
+PLOCALES="de fr no pl sl zh_CN"
+
+# cmake-utils after gnome2, to make sure cmake-utils is used for building
+inherit gnome2 cmake-utils l10n python-single-r1
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org/"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ app-cdr/cdemu-daemon:0/6
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ sys-apps/dbus
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang src/gcdemu
+ # build system doesn't respect LINGUAS :/
+ l10n_find_plocales_changes po "" ".po"
+ rm_po() {
+ rm po/$1.po || die
+ }
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_configure() {
+ DOCS="AUTHORS README"
+ local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+ cmake-utils_src_configure
+}