summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-03-08 16:57:50 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-03-08 16:57:50 +0000
commitf945ab7528cba9ca45f828ab6f991629907e646b (patch)
tree25bb1789eca975b3e80237aee7d03128d07e3b27 /app-benchmarks
parentKeyworded on alpha, bug #256165 (diff)
downloadgentoo-2-f945ab7528cba9ca45f828ab6f991629907e646b.tar.gz
gentoo-2-f945ab7528cba9ca45f828ab6f991629907e646b.tar.bz2
gentoo-2-f945ab7528cba9ca45f828ab6f991629907e646b.zip
Bump per patrick's request on #gentoo-bugs. Fix libtool-2.2 breakage with some sed foo and eautoreconf.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog10
-rw-r--r--app-benchmarks/siege/siege-2.67.ebuild72
2 files changed, 80 insertions, 2 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index a32537464ada..3d1cc30c9122 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/siege
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.45 2008/12/28 00:32:11 caleb Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.46 2009/03/08 16:57:50 loki_val Exp $
+
+*siege-2.67 (08 Mar 2009)
+
+ 08 Mar 2009; Peter Alfredsen <loki_val@gentoo.org> +siege-2.67.ebuild:
+ Bump per patrick's request on #gentoo-bugs. Fix libtool-2.2 breakage with
+ some sed foo and eautoreconf.
28 Dec 2008; Caleb Tennis <caleb@gentoo.org> siege-2.66.ebuild:
amd64 stable
diff --git a/app-benchmarks/siege/siege-2.67.ebuild b/app-benchmarks/siege/siege-2.67.ebuild
new file mode 100644
index 000000000000..22ef79b077e8
--- /dev/null
+++ b/app-benchmarks/siege/siege-2.67.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.67.ebuild,v 1.1 2009/03/08 16:57:50 loki_val Exp $
+
+WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="ftp://sid.joedog.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="debug ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # To make siege compile with libtool-2.2, from acinclude.m4 rip out the
+ # included copy of libtool.m4 from libtool-1.5.2x so we use the host's
+ # macros. We have to eautoreconf to make this work.
+ sed -i \
+ -e '/libtool.m4 - Configure libtool for the host system./,/])# AC_LTDL_FUNC_ARGZ/d' \
+ acinclude.m4 \
+ || die "Sedding some sense into acinclude.m4 failed."
+ epatch "${FILESDIR}/${PN}"-2.60-gentoo.diff
+
+ # use of \b causes the T in "Transactions" to be displayed
+ # on the last column of the previous line.
+ sed -i 's/\\b\(Transactions:\)/\1/' src/main.c || \
+ die "sed src/main.c failed"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+
+ econf ${myconf} \
+ $(use_with debug debugging) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ "${D}"/usr/bin/siege.config
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ siegerc-example urls.txt || die "dodoc failed"
+ dobashcompletion "${FILESDIR}/${PN}".bash-completion
+
+ for x in $(find "${D}"/usr/bin -name '*.pl') ; do mv "${x}" "${x%.*}" ; done
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed as"
+ elog "/usr/share/doc/${PF}/siegerc-example.gz"
+ bash-completion_pkg_postinst
+}