summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-14 06:25:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-14 06:25:29 +0000
commitcfe293909e38d82933235cc0f9b2d1bfa41b148c (patch)
tree86a281425e9a803136dacf0f5e32e8b99eb55291 /app-benchmarks
parentmetadata; add python herd, revbump; add py3.3 support (diff)
downloadgentoo-2-cfe293909e38d82933235cc0f9b2d1bfa41b148c.tar.gz
gentoo-2-cfe293909e38d82933235cc0f9b2d1bfa41b148c.tar.bz2
gentoo-2-cfe293909e38d82933235cc0f9b2d1bfa41b148c.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog9
-rw-r--r--app-benchmarks/siege/siege-3.0.6.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index 468c487752eb..e50bb9154f7c 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/siege
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.61 2013/11/27 04:00:30 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.62 2014/01/14 06:25:29 patrick Exp $
+
+*siege-3.0.6 (14 Jan 2014)
+
+ 14 Jan 2014; Patrick Lauer <patrick@gentoo.org> +siege-3.0.6.ebuild:
+ Bump
*siege-3.0.5 (27 Nov 2013)
diff --git a/app-benchmarks/siege/siege-3.0.6.ebuild b/app-benchmarks/siege/siege-3.0.6.ebuild
new file mode 100644
index 000000000000..a41d9d211b28
--- /dev/null
+++ b/app-benchmarks/siege/siege-3.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-3.0.6.ebuild,v 1.1 2014/01/14 06:25:29 patrick Exp $
+
+EAPI=4
+
+#WANT_AUTOMAKE=1.9
+
+inherit eutils bash-completion-r1 libtool autotools
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="http://www.joedog.org/pub/siege/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ # bundled macros break recent libtool
+ sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+ econf ${myconf}
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "An example ~/.siegerc file has been installed in"
+ elog "/usr/share/doc/${PF}/"
+}