summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-29 18:00:34 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-29 18:00:34 +0000
commita4a71b2c342154e4e7eca81cbe87a83a79a3003c (patch)
treea2d60a0e5177714ee682174b2891cac2303bf6c9 /app-benchmarks
parentremove old (diff)
downloadgentoo-2-a4a71b2c342154e4e7eca81cbe87a83a79a3003c.tar.gz
gentoo-2-a4a71b2c342154e4e7eca81cbe87a83a79a3003c.tar.bz2
gentoo-2-a4a71b2c342154e4e7eca81cbe87a83a79a3003c.zip
app-benchmarks/bootchart2: Default on *getty as default
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/bootchart2/ChangeLog7
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.2-r3.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/app-benchmarks/bootchart2/ChangeLog b/app-benchmarks/bootchart2/ChangeLog
index 76fddf820cb8..349dee9b0e59 100644
--- a/app-benchmarks/bootchart2/ChangeLog
+++ b/app-benchmarks/bootchart2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/bootchart2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.7 2012/05/15 14:31:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/ChangeLog,v 1.8 2012/05/29 18:00:34 jlec Exp $
+
+*bootchart2-0.14.2-r3 (29 May 2012)
+
+ 29 May 2012; Justin Lecher <jlec@gentoo.org> +bootchart2-0.14.2-r3.ebuild:
+ Default on *getty as default
15 May 2012; Justin Lecher <jlec@gentoo.org> bootchart2-0.14.2-r1.ebuild,
bootchart2-0.14.2-r2.ebuild:
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.2-r3.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.2-r3.ebuild
new file mode 100644
index 000000000000..95dce29dd467
--- /dev/null
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.2-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bootchart2/bootchart2-0.14.2-r3.ebuild,v 1.1 2012/05/29 18:00:34 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit linux-info python systemd toolchain-funcs
+
+DESCRIPTION="Performance analysis and visualization of the system boot process"
+HOMEPAGE="https://github.com/mmeeks/bootchart/"
+SRC_URI="mirror://github/mmeeks/bootchart/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="svg"
+
+RDEPEND="
+ !app-benchmarks/bootchart
+ dev-python/pycairo[svg?]
+ dev-python/pygtk
+ sys-apps/lsb-release"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
+
+src_prepare() {
+ tc-export CC
+ sed \
+ -e "/^install/s:py-install-compile::g" \
+ -e "/^VER/s:0.14.1:0.14.2:g" \
+ -e "/^SYSTEMD_UNIT_DIR/s:=.*:= $(systemd_get_unitdir):g" \
+ -i Makefile || die
+ sed \
+ -e '/^EXIT_PROC/s:^.*$:EXIT_PROC="agetty mgetty mingetty":g' \
+ -i bootchartd.conf bootchartd.in || die
+}
+
+src_test() {
+ testing() {
+ emake test
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ export NO_PYTHON_COMPILE=0
+ export DOCDIR=/usr/share/doc/${PF}
+ default
+
+ # Note: LIBDIR is hardcoded as /lib in collector/common.h, so we shouldn't
+ # just change it. Since no libraries are installed, /lib is fine.
+ keepdir /lib/bootchart/tmpfs
+
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PY_SITEDIR=$(python_get_sitedir) \
+ py-install-compile
+ }
+ python_execute_function installation
+
+ # does not like python3 as active interpreter
+ python_convert_shebangs 2 "${ED}"/usr/bin/pybootchartgui
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+}
+
+pkg_postinst() {
+ elog "Please add the init script to your default runlevel"
+ elog "rc-update add bootchart2 default"
+ echo
+ python_mod_optimize pybootchartgui
+}
+
+pkg_postrm() {
+ python_mod_cleanup pybootchartgui
+}